Americas (English)

Choose Your Location

Please select your location & language for the best website experience

Support

Upgrade Your Software to the Latest Version

Protect your business from the risk of using unsupported software

Technology changes every day, and the pace of change is not slowing down. To ensure your TEKLYNX barcode label software runs smoothly, we are continually improving our software solutions through new version releases to best meet your business needs. We highly recommend our customers stay on the most current version to avoid the risk of production downtime.

 

REQUEST UPGRADE

 

BENEFITS OF UPGRADING

 

RISKS OF USING UNSUPPORTED SOFTWARE

How do I upgrade my TEKLYNX software?

Upgrade options and cost depend on the licensing option your company has chosen

 

Subscription
Perpetual + SMA
Perpetual, No SMA
Upgrade option
Subscription
With an active subscription license, upgrade your software to the latest version at no extra cost.
Perpetual + SMA
As long as your SMA is valid, upgrade your software to the latest version at no extra cost.
Perpetual, No SMA
Version upgrades are the full price of a new license.

 

NOTE: Regional differences may apply to license benefits and upgrade option offerings. Contact TEKLYNX in your region to learn more.

 

REQUEST UPGRADE

 

Need assistance? We’re here to help.

 

Call the TEKLYNX Customer Support team to help determine your best upgrade option. We’ll help you understand your options and choose the best way to stay on the latest version.

 

CONTACT CUSTOMER SUPPORT

Upgrade to the latest version

Stay on the latest version of TEKLYNX software to ensure your software is fully supported.

 

If your Subscription or SMA is valid, your license is eligible for a version upgrade.

 

Fill out this form to speak with a TEKLYNX representative about your upgrade options.

Required field Too long. 250 character limit. Not valid
Required field Too long. 250 character limit. Not valid
Required field
Required field
Required field
Required field Not valid
Required field Not valid
Required field
Required field Too long. 250 character limit. Not valid
Required field Too long. 250 character limit. Not valid
Required field Too long. 250 character limit. Not valid

Required field Too long. 250 character limit. Not valid
Required field
Required field
Required field Too long. 250 character limit. Not valid
Required field