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CHAPTER 1

Getting Started

About this Manual

This manual is designed to provide you with the basic
information you need to install, configure, and use TEKLYNX
CENTRAL.

Typographic  This manual uses the following conventions to distinguish
Conventions between different types of information:

« Terms taken from the interface itself, such as menu names,
commands and button names appear in bold.

» Keys appear in uppercase, as in the following example:

“Press the SHIFT key.”

* Numbered lists indicate a procedure to follow.

* The sequence for selecting a command from a menu will be
described, but a button is also available for many
functions.

* Angle brackets <> indicate system setup information that
must be entered by keyboard. Enter only the information,
not the brackets.

Product Components
Your software is packaged with the following components:

« DVD

¢ This documentation
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System and Server Requirements

Requirements

Processor Minimum:
2 GHz or faster
e Windows Server 2008 SP2 x32/x64
Operating e Windows Server 2008 R2 x64
System
e Windows Server 2012/2012 R2 x64
Memory 1 GB of free RAM (not includes database server)
Hard Disk Minimum 1.5 GB of free disk space
Space
On the server:
Microsoft Internet Information Services (IIS) 7.0 or higher
Microsoft SQL Server 2008/2008R2/2012/2014 or Oracle 11,
.NET Framework 3.5 SP1 (Server and Client), 2.0,
4.5.2 (Server), ASP .NET 4.0
On the print client:
Supporting Microsoft Internet Explorer 11, Mozilla Firefox 48.0, Google
Software Chrome 52.0 or later
On the label designer client:
Microsoft Internet Explorer 11, Mozilla Firefox 48.0, Google
Chrome 52.0 or later
.NET Framework 3.5 SP1
Microsoft Data Access Components (MDAC) 2.8 or later
Adobe Acrobat Reader X or later
Video Card DirectX 9.0 minimum
Additional

Administrator rights to the computer used during installation

Other Documentation Resources

Product DVD

In addition to any printed documentation that may be included
with your product, you can find all available TEKLYNX
CENTRAL documentation in PDF format on the product DVD.
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Other Product
Documentation

The PDF documents can be viewed in Adobe Acrobat Reader
and printed for easy reference.

To access the TEKLYNX CENTRAL documentation on the
DVD, click the Installation Guide button available on the
DVD'’s opening screen.

You can also download product documentation at
www.teklynx.com.

Supplementary manuals for CODESOFT, LABEL ARCHIVE,
SENTINEL, and the Printing Interface are also included on the
DVD. For more detailed instructions on these products, refer to
the corresponding product documentation.

User and administration manuals for these applications are also
available online at www.teklynx.com.
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CHAPTER 2

Installation

Welcome!

Thank you for purchasing TEKLYNX CENTRAL. This
installation guide contains information on how to install and
configure TEKLYNX CENTRAL, in addition to using the
Command Center to interact with CODESOFT, LABEL
ARCHIVE, SENTINEL, and the Printing Interface.

About TEKLYNX CENTRAL

TEKLYNX CENTRAL manages enterprise labeling users,
licenses, and installation within one interface. The Command
Center coordinates TEKLYNX' proven label design, printing,
security, and tracing applications to simplify administration.

TEKLYNX CENTRAL offers the following features:

Label Design Security and Traceability — You can create all
of your label templates in the label designer and secure them in
the label database. All modifications and print requests are
tracked in the database to provide an audit trail of print and label
history.

Browser-Based Printing Interface — The browser-based
printing interface uses a unique data input model that allows
you to eliminate unnecessary user steps by limiting access to
labels at the work order, workstation, and printer level. In
addition, the configurable interface allows you to use
terminology specific to your business environment, which
reduces training time for new users.

Label Printing — Print requests that are sent from a host system
or the browser-based user interface are processed and sent to
networked printers.
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Installing TEKLYNX CENTRAL

1 |Insert the DVD, click TEKLYNX CENTRAL Installation,
and then click the Install icon. If the DVD does not auto-
matically launch, use the Windows Run command to type
the letter of the DVD drive followed by index.hta (for exam-
ple, D:\index.hta) and press ENTER.

The TEKLYNX CENTRAL Installer opens.

JC TEKLYNX CENTRAL Installer x|

TEKLYNX CENTRAL manages enterprise labeling users, licenses, and
installation within one interface. This command center coordinates
TEKLYMX' proven label design, printing, security, and tracing applications
to simplify administration.

If the Windows prerequisites are not installed, you will be prompted to
install before continuing with the TEKLYNX CENTRAL installation.
Installation of Windows prerequisites may require a system reboot to
complete the installation.

Click Start to begin the installation and follow the on-screen instructions.

=

Figure 2-1 TEKLYNX CENTRAL Installer

2 Click Start. If a required Windows application is missing on
your system, the installation program will prompt you to
install the prerequisite file.
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TEKLYNX CENTRAL - Installshield Wizard )

T TEKLYM: CEMTRAL requires the Following items to be installed on vour computer. Click
Install ko begin installing these requirements,

Status | Requirerment
Pending Windows Installer 4.5 Update For Windows Server 2003 SP2 and later (x86)

Inskall I Cancel

Figure 2-2 Required Windows Prerequisite

Click Install to install any required prerequisites.

Installation of Windows prerequisites may require a system
reboot to complete the installation. If a system reboot is
required, a message will appear prompting you to restart
your computer. Click Yes to restart your computer.

3 If all required Windows prerequisites are already installed,
or after the installation of any necessary prerequisites has
finished, the TEKLYNX CENTRAL Installation Wizard
appears.
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Welcome to the InstallShield Wizard for
TEKLYNX CENTRAL

The InstallShield(R) Wizard will install TEKLYNX CENTRAL on
your computer. To continue, dick Next.

TEKLYNX'

WARNING: This program is protected by copyright law and
international treaties.

= Back Mext = Cancel |

Figure 2-3 TEKLYNX CENTRAL Installation Wizard

4 Click Next.

The License Agreement window appears.

i TEKLYNX CENTRAL - InstallShield Wizard

License Agreement

Please read the following license agreement carefully.

Teklynx Newco SAS Software License Agreement ﬂ

Teklynx Newco SAS (hereafter "Teklynx ™) or its affiliated companies hereby grants
you a non-exclusive, nontransferable license to use this software and the
accompanying documentation according to the following terms:

LICENSE GRANT - You may

1) install and use the software on the number of computers covered by invoices for
this license from Teklynx, which are hereby incorporated by reference;

2} use and transmit the software on a network within a site if authorized by an
invoice from Teklynx, and Ll

% I accept the terms in the license agreement Print |
(" 1do not accept the terms in the license agreement

InstallShield

<Back Next > Cancel |

Figure 2-4 License Agreement window
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5 Read the license agreement. If you agree with the terms of
the license agreement, select | accept the terms of the
license agreement and click Next.

The Customer Information window appears.

{i TEKLYNX CENTRAL - InstaliShield Wizard B x|

Customer Information

Please enter your information.

User Name:

Organization:

InstalShield

< Back I MNext = I Cancel

Figure 2-5 Customer Information window

6 Enter your name and the name of your company and click
Next.
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The Destination Folder window appears.

{% TEKLYNX CENTRAL - InstallShield Wizard ]

Destination Folder

Click Next to install to this folder, or dick Change to install to
folder.

'Iﬁ|

T Install TEKLYMX CENTRAL to:

l- C:'\Program Files (x86) {Teklynx\, Change... |

InstaliShield

< Back I Next = I Cancel

Figure 2-6 Destination Folder window

7 The default installation folder is C:\Program Files\Teklynx. If
you would like to change the installation folder, click
Change and browse to the desired location. Click Next.

7.1 On the next screen it's possible to specify if Online Printing
Interface should be installed. Select preferred option and

Click Next.
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The Web Site Selection window appears.

i TEKLYNX CENTRAL - InstallShield Wizard B Xl

Web site selection 1L
Specify the Web site settings ’

Pleasze select the web site on which you want to deploy:

InstallStisld

< Back I Next > I Cancel

Figure 2-7 Web Site Selection window

8 From the drop-down list, select the 1IS web site. The IIS
web site is the site from which the TEKLYNX CENTRAL
browser-based printing interface will launch on client
workstations. Click Next.
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The Virtual Directory window appears.

{8 TEKLYNX CENTRAL - InstallShield Wizard 1 x|

.
Virtual directory
Virtual directory definition 3

Flease spedify the settings for virtual directory of the web site:

MName:

Instalshield

< Back I Mext > I Cancel

Figure 2-8 Virtual Directory window

9 Specify the virtual directory name for the TEKLYNX
CENTRAL browser-based printing interface. The virtual
directory is part of the path that displays in the browser
address bar when a user launches the printing interface.
Click Next.

9.1 Specify the virtual directory name for the TEKLYNX
CENTRAL Administrative interface. The virtual
directory is part of the path that displays in the browser
address bar when a user launches the printing interface.
Click Next.
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The Database Type window appears.

{5 TEKLYNX CENTRAL - InstaliShield Wizard ] |

Database type
Select type of server database

Select type of server database you would like to install:

% Microsoft SOL Server

" Orade

Installstield

< Back Mext = Cancel

Figure 2-9 Database Type window

10 Choose the database type that will be used. Click Next.
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« |If Microsoft SQL Server was selected, the Database
Server window appears.

{% TEKLYNX CENTRAL - InstallShield Wizard 1 x|
» -
Database Server

Select database server and authentication method

Database server that you are installing to:
)

j Browse. .. |

Connect using:
% Windows authentication credentials of current user

{~ Server authentication using the Login ID and password below

Login ID: Isa

Password: |

< Back | Mext = I Cancel

Figure 2-10 Database Server window

From the drop-down list, select the SQL database
server. This is the server that stores your configuration
data (including label data and the relationships between
items and labels).

Note: SQL configurations with “named instances”
require special installation. During TEKLYNX CENTRAL
installation, the wizard may display several possible
database servers; for example, (Local)/DB instance
name or (Workstation name)/DB instance name. You
must select an item that contains a workstation name to
ensure a correct connection. Click Next.
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« If Oracle was selected, the Datasource window
appears.

{5 TEKLYNX CENTRAL - InstallShield Wizard [ x|

Datasource |
Select datasources and account credentials r

~ LABEL ARCHIVE Server and UMSS\MSGS
Datasource:

User ID: Password:

~ TEKLYMX CENTRAL Printing Interface
Datasource:

User ID: Password:

Installshield

< Back I Mext = I Cancel

Figure 2-11 Datasource window

Enter the database that will be used for the LABEL
ARCHIVE Server, UMSS\MSGS, and TEKLYNX
CENTRAL instances, along with the relevant user
credentials. This is the server that stores your
configuration data (including label data and the
relationships between items and labels). Click Next.

Note: Oracle database support is only available in
32-bit operating systems. The Microsoft Server 2003 R2
32-bit operating system is not supported.
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11 You are ready to install TEKLYNX CENTRAL.

i!“_:" TEKLYNX CENTRAL - Installshield Wizard

Ready to Install the Program

x|
H
The wizard is ready to begin installation,

Click Install ko begin the installation.

IF you want ko review or change any of your installation settings, click Back., Click Cancel to
exit the wizard.

Inistallshield

< Back Cancel

Figure 2-12 Ready to Install window

12 Click Install to begin installing TEKLYNX CENTRAL. The
installation wizard will indicate when installation is
complete.

13 Click Finish to exit the wizard.

14 When installation is complete, click Close to exit the
TEKLYNX CENTRAL Installer.
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CHAPTER 3

Using the Command Center

Once TEKLYNX CENTRAL has been installed, it can be used
to administer all components of your enterprise labeling
solution.

The Command Center

The TEKLYNX CENTRAL Command Center provides access to
all components of your enterprise labeling software.

Logged in: Administrator

TEKLYNX

Software Maintenance Agreement (SMA) Licensing
An SMA gives you acosss to the latest updates and training manuals for your registered  Manag user groups users, and user licanses
TEKLYNX products =
5] Manage Users
SMA Bxiretion Date: .
SMA Number- (3] View Comnected Users
[3] Enter SMA Number (3] Add Licenses
[3] Renew SMA Label manager
Label designer Manage the labels that were designed in the Label Designer and define which users

2nd madications

Design and prttest labels that wil be used in your erterprise labeling system
(3] Delete, Archive, or Reset Labels

3] Desion and Test Labels o
(3] Corfiqure Approval Rules

Print manager
Printing interface

Corfigure the transfer of data from your host system to the Label Designer and view

print status Corfigure what information displays in the printing interface:

[3] Corfigure Data Watch or View Frint Status (3] Corfiqure Prirting Interface
(3] Creste Map. (3] Launch Printing Interface:

Workstation Installation

Install and cortigure the Label Designer on remote worksiations

(3] Install Label Designer on Remote Workstation

Figure 3-1 TEKLYNX CENTRAL Command Center

Use the default user to log into TEKLYNX CENTRAL for the first
time. The user name for this account is administrator and the
password is admin.

Managing Software Maintenance Agreements

A TEKLYNX Software Maintenance Agreement (SMA) gives
you access to the latest software updates and training manuals
for your registered TEKLYNX products. Entering your SMA
number into the Command Center gives you quick access to
your registration and expiration information. The system will
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Entering
SMA
Information

also remind you when your SMA contract is up for renewal.

To enter your SMA number in TEKLYNX CENTRAL:

1 Click the Enter SMA Number link in the Software
Maintenance Agreement (SMA) section. The SMA window
opens.

SMaDialog x|

Enter Skt Mumber: ||

Ok |

Figure 3-2 SMA window

2 Type your SMA number in the Enter SMA Number field.

3 Click OK.

TEKLYNX CENTRAL will query the TEKLYNX SMA Center
to locate the expiration date of your maintenance
agreement. If your system does not have an Internet
connection, an error message will appear.

x

l'\ Error retrivieng SMA data. Connection issue

Figure 3-3 SMA error message
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Managing Licenses

The Licenses section of the Command Center allows you to
manage user licenses and roles.

Adding/ To add or configure user rights:

Configuring
User Rights 1 Click the Manage Users link in the Licenses section.

The UMSS-MSGS window opens.

] UMSS-MSGS Servers
=-{&¥ UMS5-MSGS Servers

----- @ User Groups

..... E Applications
[]-:- Sessions

Figure 3-4 UMSS-MSGS window

2 In the file tree on the left, go to UMSS-MSGS Servers >
UMSS > Users, and right-click to select New > User.
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The User Properties - New window opens.

& User properties - New ) =10l x|
User I Group memberships |
Username Ibrc\iohndoe

First name |.J ohn

Last name |Doe

Authertication IW’indowS ﬂ

Fazsword I
Fazzword [2gain] I

User may change password [T
Uzer must change password [T

Locked [T

Phone
Mobile

Email

ag I Cancel | Help |

Figure 3-5 User Properties - New window

3 On the User tab, enter the user’s first and last name in the
appropriate fields.

Then, if:
* Using UMSS authentication, enter a user name and
password, and confirm the password.

» Using Active Directory, select Windows from the
Authentication drop-down list and click the Browse
button to locate the appropriate user.

4 On the Group Memberships tab, select the user groups
that the user should belong to.

The following user groups can be used:

* Administrators — This user group is used by the
installed components of TEKLYNX CENTRAL and
provides initial access to the application to set up other
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# User properties - New - ;Iglﬂ

users. You must have at least one user in this user
group. This user can then create the TEKLYNX
CENTRAL Administrator in user group ACAdministrator.

PrintUsers — This user group should not be used.
TEKLYNX CENTRAL print users should be added to
the ACPrintUser group.

ACAdministrator — This group presents Administration
applications: Command Center, TC Web Administration,
UMSS-MSGS Admin console, LA Server Administration.

ACDesignUsers — This group presents label design
application: CODESOFT.

ACPrintUsers — This group presents printing application.
Web Printing Interface license will be consumed.

ACReportUsers — Generate audit and history reports.
Consumed by LA Client Console and via CODESOFT.

[ Administratars
1 PrintUsers

] ACAdministrator
[] ACDesignUsers
] ACPrintUsers
[ ACReportl)zers

QK I Cancel | Help |

v

Figure 3-6 User Properties - Group Memberships tab

5 Click OK to save your user and group settings.
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Viewing
Connected
Users

To view connected users:

1 Click the View Connected Users link.

The Users window appears.
A% TEKLYNX CENTRAL Command Center o= =

Back

3
2

- Print Users {0 of 5}

- Design Users (Dof 1)
- Reporting Users (0 of 1)
- Printers (0 of 3)

&1 AddOns (1 of 1)

License is active.

Figure 3-7 Users window

2 Expand each user group to display the connected users.
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Adding To activate or add licenses:
Licenses

1 Click Add Licenses. The License Activation window
appears.

License Manager - Home 3

TEKLYNX"

CENTRAL

Curment license:
NSPPE7098 - TEKLYNX CENTRAL-USA (Upgraded)

<) Upgrade software license

<) Deactivate software license

) Transfer software license

€ Back P Ned Ext

Figure 3-8 License Activation window

2 Click Upgrade software license and follow the on-screen
instructions to upgrade your license.
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Using the Label Designer

The Label Designer section of the Command Center provides
links to launch the label designer application, where you can
design and test print labels.

The label designer is powered by CODESOFT. For more
information on designing and test printing labels, refer to the
CODESOFT User Guide. For more information on checking
labels in and out of the label database, refer to the LABEL
ARCHIVE User Guide.

To launch the label designer, click the Design and Test Labels
link in the Label Designer section.

Using the Label Manager

Managing
Labels

The Label Manager section of the Command Center provides
links to manage labels and define approval rules.

Note: When a new version of a label is checked into LABEL
ARCHIVE, the printing interface will automatically use this
version for any subsequent print requests.

The TEKLYNX CENTRAL label manager is powered by LABEL
ARCHIVE. For more information on managing labels, refer to
the LABEL ARCHIVE Administrator’s Guide and LABEL
ARCHIVE User Guide.

1 Click the Delete, Archive, or Reset Labels link in the
Label Manager section. This will launch the LABEL
ARCHIVE Server application.

2 To delete labels:

a Inthe LABEL ARCHIVE Server application, select
Console Root > LABEL ARCHIVE Server
Administration > Tasks > Delete documents and
data from the Console Root tree in the left pane.

b On the Filter tab, choose the categories and types of
labels to search for.

¢ Onthe Documents tab, choose the labels to delete and
click Delete.
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Managing
Approval
Rules

Note: This action will permanently delete labels from the
label database.

To archive labels:

a Inthe LABEL ARCHIVE Server application, select
Console Root > LABEL ARCHIVE Server
Administration > Tasks > Archiving from the Console
Root tree in the left pane.

b On the Filter tab, choose the categories and types of
labels to search for.

On the Documents tab, choose the labels to archive.

On the Archive Options tab, browse to the folder
where the archived database will be stored. Enter a
name for the backup file and click Save.

If you want to delete the label(s) from the label
database, select Delete after archive and click
Archive.

To reset the label’s check out state:

a Inthe LABEL ARCHIVE Server application, select
Console Root > LABEL ARCHIVE Server
Administration > Tasks > Reset documents >
Checkout state from the Console Root tree in the left
pane.

b Select the desired label and click Reset.
Click Configure Approval Rules. The LABEL ARCHIVE
Client application will launch.

In the LABEL ARCHIVE Client application, select Console
Root > LABEL ARCHIVE Client Administration >
Approval rules from the Console Root tree in the left pane.

To create a new approval rule, click New.
Enter a name for the new rule in the Name field.

Select when the step should be processed in the State
drop-down list.

Select whether the step applies to a single user or a user
group in the Handler drop-down list.
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7 Select the user or user group in the Parameter drop-down
list.

8 If the step is mandatory, select Must Approve in the Type
drop-down list.

9 Click Apply.

Using the Print Manager

The Print Manager section of the Command Center provides
links to create maps, configure sentinels, and monitor sentinels.

The TEKLYNX CENTRAL print manager is powered by
SENTINEL. For more information on managing sentinels, refer
to the SENTINEL Administrator’s Guide and SENTINEL User

Guide.
Configuring Three sentinel watches (Print, Preview and Sync) are
Printing for automatically created for the Printing Interface during
Data the installation. Printers must be configured for both of these
watches.
Watches

To add or remove printers:

1 Click the Configure Data Watch link in the Print Manager
section of the Command Center.

2 Select the Print sentinel and click Properties.

3 On the Process tab, select CODESOFT Printing. Click
Settings to launch the CODESOFT Printing Plug-in
properties, where you can add or remove printers and
define default settings.

4 Atfter you have configured the printer, click OK.

Creating In some cases additional sentinel watches are required if you are
Additional sending data to TEKLYNX CENTRAL at print time to trigger a print.
Data

Watches To create a sentinel watch:
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Managing
Printing
Status

Creating Map
Files

Click the Configure Data Watch link in the Print Manager
section of the Command Center.

Note: Data watches install automatically for the web
printing module.

Click File > New.

On the General tab, enter a name and group for the data
watch. If you are sending data within a file, select the map
you created for the file.

On the Input tab, select how the data input will be sent to
TEKLYNX CENTRAL (that is, what will trigger the print
request). If you are sending data within a file, click File
Capture. Click Settings to define the folder where the file
will be created to trigger the print request.

On the Process tab, select CODESOFT Printing. Click
Settings to launch the CODESOFT Printing Plug-in
properties, where you can add or remove printers and
define default settings. On the Archiving tab of the
CODESOFT Printing Plug-in properties, enter a user name
and password for a print user in the PrintUser group.

Click OK.

Check the Enable option in the Manager window.

To activate a sentinel watch or monitor status:

Click the View Printing Status link in the Print Manager
section of the Command Center.

To activate a watch, select the watch and select Activate
from the SENTINEL menu.

To monitor print status, select Information from the View
menu. The Information window opens. Select the Log tab
to view print status.

A map file is required if you are sending data within a file to
TEKLYNX CENTRAL at print time to trigger a print request.
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Because the necessary sentinels and map files are
automatically created when TEKLYNX CENTRAL is installed,
you will only need to create map files if you have a specific
need.

To create a map file:

1 Create a sample of the data that will be sent to trigger the
print job.

2 Click the Create Map link in the Print Manager section of
the Command Center.

3 Click File > New and follow the instructions in the wizard to
create a new map file.

Using the Printing Interface

The Printing Interface section of the Command Center provides
links to configure and test the printing interface.

The TEKLYNX CENTRAL label manager is powered by the
Printing Interface. For more information on configuring the
printing interface, refer to the TEKLYNX CENTRAL 4.6
Administration Help which is accessible on website.
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Configuring To configure the printing interface:
the Printing

Interface 1 Click the Configure Printing Interface link in the

Printing Interface section of the Command Center.

The Printing Interface Configuration Log In Page opens.

Application settings

Langu agel English j
User name|
Password |

I windows Authentication
[ Change password

Figure 3-9 Log In Page

2 Enter your credentials and click the Log In button. If the
system is configured to use your Windows credentials, click
the Windows Authentication check box, then click Log In.
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3 After logging in, you will see the Options window.

General options

O

Display options & external database

‘Workorder

The identifier that specifies which Product will print

‘Workstation Logic

Determine Products and printers based on Workstation

Printer Logic

Determine printer based on which Labels can print to the printer
User Logic

Determine links between users, Workorders, Products and printers
Test Print

The ability to print a test Label with a watermark.

Reprint

The ability to reprint a previously printed Label.

Allow Queued Print Requests

Allows deferred batch printing by adding Labels to queue based on
Workstation/User

Common variables

When one variable change - all variables in Product with the same name will
change too.

Quantity of Label

Allow user to set quantity of Label which will be printed.

Truncate Label path

Allow users to hide the Label path in all locations where the Label name displays.

[
[~

O

O

O

Use Printer Aliases

Alias instead of Printer name on the Printing Interface Web Site.

Automatic Site Log Off

‘Webh site logs you out automatically after period of time. Re-login is required to

apply this option

A i D Wi

Determine Workstation based on static IP or MAC address

Clear Label Quantity

Clear Label quantity field after the Label has been printed

Clear variables after print

Clear variables after the Label has been print

Use Windows Authetication by Default

Use windows authentication by default on Login screen of Printing Interface
A lication p: prompt

‘Windows users must enter passwerd in printing and admin screen

Default datetime format: | MM/dd/yyyy

O

Product/Workorder Variable
Variable io be populated with Product value

Manage connections

Save

Defining
Workstations

Figure 3-10 Options window

On this screen you can choose the different features of the
interface that you would like to enable. The options chosen
here will affect the windows under the Data Configuration
tab. After selecting the desired options, click the Save

button.

All other configuration of the interfaces is done through the
Data Configuration tab. Simply hover over Data
Configuration, then choose the appropriate configuration
menu you would like to access.

The following sections offer additional detail on specific

configuration options.

TEKLYNX CENTRAL allows you to define unique workstations
which will use the Printing Interface. This allows you to

configure specific field labels and logic per workstation — these
configuration steps are detailed in later sections.
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To define workstations:

1 Click the Configure Printing Interface link in the Printing
Interface section of the Command Center.

2 Login using your credentials.

3 Click on the Data Configuration tab at the top of the
screen, then choose the Workstations link.

Workstations
Workstation
| Add H Browse |
[ Agmin x
| Test X

Figure 3-11 Printing Interface — Data Configuration tab,
Workstations link

4 Add any necessary workstations either by clicking Browse
and navigating to the workstation or by manually entering in
the workstation name.

5 Click Add to store each workstation.
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Changing TEKLYNX CENTRAL allows you to define different field names
Field Names for each workstation on your network.
for To define field :
Workstations o define field names:
1 Click the Configure Printing Interface link in the Printing
Interface section of the Command Center.
2 Log in using your credentials.
3 Click on the Data Configuration tab at the top of the
screen, then choose the Naming link.
Naming

Workstation

Change "Work Order” to:
Change "Work Orders” to:
Change "Product” to:
Change "Products” to:
Change “Label" to:
Change "Labels” to:
Change "Workstation” fo:

Change "Workstations” to:

Figure 3-12 Printing Interface — Data Configuration tab, Naming
link

4 In the Workstation drop-down list, select the workstation
for which you want to modify the interface terminology.
Enter the field name substitutions as needed and click
Save to store the changes for that workstation. Repeat as
needed for each workstation.
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Associating
Labels with
Product

In TEKLYNX CENTRAL, you can link labels to products to
a ensure print users are printing the correct labels for each print
job.

To associate labels with a product:

1 Click the Configure Printing Interface link in the Printing
Interface section of the Command Center.

2 Log in using your credentials.

3 Click on the Data Configuration tab at the top of the
screen, then choose the Products link.

Products
Add Product
|
Product1 x
Product2 b 4
Product3 b 4

Figure 3-13 Printing Interface — Data Configuration tab,
Products link.

4 Enter the names of your products in the Add Product field,
then click Add.
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5 Once all of your Products have been added, click on the
Data Configuration tab at the top of the screen, then
choose the Labels link.

Product Name

| 2l

[DemoProduct v|
Labels Label Preview
Label | DataSource | Table "]
Cocoa Label with Entered Mig and Exp Date.lab ‘anseleded ﬂ |Nu|se|er:ted I *x
ADM Sample Label lab ‘an selected E |Nmseletted M x
Blommer Label iab [Notselected [ [Notselected  [v] X LoTE 0345
CPD Paliet ID Iab [Notselected ] [Notselected [v] X DOTRTEDBY. oy
CPD Straight.lah ‘an selected  |v] |Nul selected  |v] X [a] — M0 AR CHEACO, L 4MBL 333
= —
Milk Allergen Shipping.ab [Notselected  [v] [Notselected [v] X | — MANIFACTURE DATE: (G035
Coating US.lab [Notselected [+ [Notselected [v] X Net Wt
4 February, 2015 3
Su Mo Tu We Th Fr Sa
25 26 27 28 20 30 N
1 2 3 5 6 7
g 9 10 11 12 13 14 < >
| AT 1 1 17 18 19 20 n —
22 23 24 25 26 27 22
s . 2 12 3 4 5 6 [Saturdsy, February 28, 2015 Revert
Variable Name Variable Prompt Show/Hide ang Input Mask to Is Date| Order
Today: February 4, 2015 Default
[ENTER DATE OF 1| [Enter date of manu| [Show  [¥] |[ozi0az015 |28 [[NONE V][] || o i O [¥] x
[ENTER LOT NUME]| [ENTER LOT NUME| NONE M || o s O O |[&F |x
[sku || [sKu || [Show__ [v]|[esatrasc J|[NoNE [V || o = O O [ X

Caneel

Figure 3-14 Printing Interface - Data Configuration tab, Labels
link

6 Choose the desired Product you would like to add labels to
from the Product name drop-down list.
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7 Click Add Label. The Add Label window appears.

Add Label ®
Product Name: Label Name
Product1
[ |  Search
Do et ldentiy labversion ) &
CODESCFT =

Mame:  Doris Samosison o] 5
T “

‘*
Stlei cg |Z¢ mn %

o

AddLabel || Back

Figure 3-15 Printing Interface — Add Label window

8 Click on the CODESOFT link in the Select Label Category
box.

9 Select the desired label in the list.

Use the empty field above the Label Name drop-down list
to search for labels. The search results automatically
update as you type into this box and any label names that
contain matching text appear in the list.

Note: Each label will appear only once in the list regardless
of how many versions are stored in your system.

10 Click Add Label to associate the selected label with the
Product.
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Adding a
Quantity
Field to the
Printing
Interface

Once the label is added you can click on it to bring up its
variable options. Configure as necessary to define the
prompt, determine whether to show, show but not allow
edits or hide the variable, set a default value, choose to
revert to this default value after a print request is sent, and
even set the order in which the variables will appear.

A Quantity field can be added to the printing interface so that
the print user can enter a quantity for each label loaded within
the interface.

To add the Quantity field to the printing interface:

1

Click the Configure Printing Interface link in the Printing
Interface section of the Command Center.

Log in using your credentials.
Click on the Options tab.

Select the Quantity of Labels check box to add the
Quantity field to the printing interface.

[ Common variables
When one variable change - all variables in Product
with the same name will change oo
Quantity of Label
Alow user to sat quantity of Label which will be prnted
[~ Truncate Label path
Allow users to hide the Labal path in all locations
where the Labal name displays.

"

Figure 3-16 Printing Interface — Options tab, Quantity of Labels

check box
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5 Click Save.

Infinite Print NOTICE: Infintine Printing requests support was removed in
Requests TEKLYNX CENTRAL 4.6.
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Defining
Common
Variable
Entry
Settings

If multiple labels are associated with a product and the same
variable names are used across all labels, you can set up
TEKLYNX CENTRAL so that a user only enters the information
once to update each common variable.

To define common variable entry settings:

1 Click the Configure Printing Interface link in the Printing
Interface section of the Command Center.

2 Log in using your credentials.
3 Click on the Options tab.

4 Select the Common Variables check box to update the
variable on all labels for a product when the variable is
modified in one label design.

Allow Queued Print Requests
Allows deferred batch printing by adding labels fo queue based on
workstation/username

[] Common variables
When one variable change - all variables in Product with the same name will
change too.

Quantity of Label
Allow user to set guantity of Label which will be printed.

Figure 3-18 Printing Interface — Options tab, Common Variables
check box

5 Click Save.
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Truncating
the Label
Path in the
Printing
Interface

You can configure TEKLYNX CENTRAL so that only the label
name is displayed instead of the entire storage path. This will
help keep the directory in which the label is stored concealed
from end users.

To truncate the label path in the printing interface:

1

Click the Configure Printing Interface link in the Printing
Interface section of the Command Center.

Log in using your credentials.
Click on the Options tab.

Select the Truncate Label Path check box to display only
the label name in the printing interface.

Click Save.
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Displaying
the Printer
Alias in the
Printing
Interface

TEKLYNX CENTRAL can be configured to display only the
printer alias, which is assigned by the administrator when a
TEKLYNX printer driver is installed, in place of the driver name.
If this option is disabled, the driver name is displayed.

To display the printer alias in the printing interface:

1 Click the Configure Printing Interface link in the Printing
Interface section of the Command Center.

2 Log in using your credentials.
3 Click on the Options tab.

4 Select the Use Printer Alias check box to display the
printer alias in the printing interface instead of the driver
name.

5 Click Save.
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Testing the To test the printing interface:
Printing
Interface 1 Click the Launch Printing Interface link in the Printing

Interface section of the Command Center.

2 Enter a user name and password for a user with print
access from the ACPrintUser group.

3 Enterinformation based on your business process and click
Print. When you click Print, any changes that you have
made to the form variables are saved.

A message will appear stating that the print job has been
successfully sent to the server.

Using the The TEKLYNX CENTRAL printing interface can be accessed
Printing on mobile devices using Google Chrome and

Interface on a Internet Explorer.

Mobile

. To use the printing interface on a mobile device:
Device

1 In browser on the mobile device, enter the local
network path to the printing web page. This path is defined
during TEKLYNX CENTRAL installation.

2 Enter a user name and password for a user with print
access from the ACPrintUser group.

3 Enter information based on your business process and tap
Print.

Using the Workstation Install Module

The Workstation Install section of the Command Center allows
you to remotely install the label designer application on client
workstations.
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Installing 1 Click the Install Label Designer on Remote Workstation
Softwareona link in the Workstation Install section of the Command
Client Center.

Workstation

The TEKLYNX CENTRAL Remote Installation window
appears.

Back

TEKLYNX CENTRAL Remote Installation

Select target remote workstation. Requirements:

- specified user should have administrative privileges;

- prerequisites ((MET Framework 3.5, .MET Framework 4, Adobe Reader) should be installed;

- firewall should be tumed off;

- Printing Interface cliert site URL should be specified below i Chrome browser support is required.

[] Chrome Browser support

E.g.: hitp://WIN-TSVICOVAUKQ/THKCEN

|| | | Browse | | Instail

Figure 3-21 TEKLYNX CENTRAL Remote Installation window

2 Click Browse and locate the remote workstation. Select the
client workstation in the list.

Note: The user who is attempting to install the application
via TEKLYNX CENTRAL must be an administrator on the
remote workstation for the installation to be successful.

3 Click Install to begin the installation.

Installing You can also install the label designer and label manager
Client applications directly from the TEKLYNX CENTRAL DVD.
Applications

from the DVD 1 Onthe clle.nt worklstatlon, |.nse.rt the DVD and install the
Label Designer Client application.

2 |Install the Label Manager Client application from the DVD.
During the installation process, you will be asked to select
the LABEL ARCHIVE Server. Enter or select the name of
the server on which TEKLYNX CENTRAL is installed.
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3 Edit the CS.ini file, which is installed in C:\Documents and
Settings\All Users\Application Data\TeklynxX\CODESOFT.
For Windows Vista and 2008 users, this file is located in
C:\ProgramData\Teklynx\CODESOFT.

Add the line UMSSAVAILABLE=1 in the General section of
the file.

4 Launch CODESOFT. The application will launch in
evaluation mode.

5 Go to Tools > Users Management. The Users
Management window opens.

()

Users Management

[ Use User Management System [UM35)

After changing the settings wou must restart the program.

OK l [ Cancel

Figure 3-22 User Management window

6 Select the Use User Management System (UMSS)
option.

7 Inthe server address tcp://localhost:8989, replace
localhost with the name of the server on which TEKLYNX
CENTRAL is installed.

8 Click OK.

9 You will be prompted for a user name and password. Use
the user name and password of a TEKLYNX CENTRAL
administrator.

10 Restart CODESOFT for the changes to take effect.
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