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Connecting to Database Files

Database Connections window

Figure 1 
Database Connections window

The Database Connections window is used to connect the
software to the various database files that are to be used.
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Connect the Database Manager module to the 
database

Database Manager must be open in the Database
Connections window.

You can connect the Database Manager module to an
existing database or a new one.

To create a new database to connect to the Database
Manager module:

1 Go to File > Create new database.

2  Select dBase or Access database from the submenu.

A Save as dialog box will open, allowing you to specify a
name and location for the database file, and then click Save. 

The new database connection will be displayed in the
Database Connections window.

To connect an existing database to the Database Manager
module:

1 Go to File > Open.  

A File selection dialog box will open allowing you to browse
to and select the database of your choice.  

You can only select the following database types: 

Access (*.mdb)
Excel (*.xls)
Dbase(*.dbf)

Note
A wizard is available to help you connect the software 
to the most frequently used databases. Choose the 
format option that matches your database format. If the 
format required is not available, do the following: 
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1 Click Add. 

2  Select a database type from the list. 
- or -
Select Others.

3  Click Connection Setup.

4  Click the Provider tab on the dialog box.

5  Select the required provider.
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6  Click Next.

Note
The choice of provider changes according to the 
system’s type of database.

7  Click the Browse button.

8  Select a file. 

9  Click Open.



Connecting to Database Files Chapter 1 - 5
10  Click OK.

11  Click Next.

12  Enter a name for the connection.

13  Click Finish.
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Note
You can repeat this procedure as often as necessary to 
obtain the required number of connections. 

Modify the database connection parameters
Database Manager must be open in the Database
Connections window. The required connection must be
selected. 

1 Click Edit.

2  Make the required changes.

Remove a connection
Database Manager must be open in the Database
Connections window. The required connection must be
selected. 

1 Click Remove.
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Database File Structure

Database Structure window

The Database Structure window is used to manage the
structure of the databasefile. From this window, you can
add, modify, or delete tables and fields.
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Choose a database from the list of connections
Database Manager must be open in the Database
Structure window.

1 Click the Database drop-down list.

2  Click the required data.

Choose a table in a database
Database Manager must be open in the Database
Structure window. 

1 Click the Table drop-down list.

2  Click the required data.

Add a table to the active database
Database Manager must be open in the Database
Structure window. 

1 Click Add table.

2  Enter the name of the new table.

3  Click OK.
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You can also copy the structure of the table from a table that
already exists in the selected database. To do so: 

1 Select the Duplicate with option.

2  Click the drop-down list.

3  Click the required data.

4  Click OK.

Delete a table in the active database
Database Manager must be open in the Database
Structure window. 

1 Click the Table drop-down list.

2  Click the required data.
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3  Click Delete table.

View/hide active table’s data
Database Manager must be open in the Database
Structure window.

To review the active table's data, click View data.

Define a key field
Database Manager must be open in the Database
Structure window. 

1 Select the checkbox next to the required field.

2  Click Apply.

Define a field’s type of content
Database Manager must be open in the Database
Structure window. 

1 Click the required field in the Type column.

2  Click the drop-down list button.

3  Click the required data.
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4  Click Apply.

Define a field’s maximum size
Database Manager must be open in the Database
Structure window. 

1 Click the required field in the Length column.

2  Enter the required value.

3  Click Apply.

Allow an empty field
Database Manager must be open in the Database
Structure window. 

1 Select the Allow Null check box for the required field.
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2  Click Apply.
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Database Contents

Edit Database window

The Edit Database window is used to manage the contents
of the database file. From this window, you can, modify, or
delete data.  

These actions depend on the type of database. Excel file
records cannot be modified. 
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Select records according to their content

Use the content 
of a field to find 
a record

Database Manager must be open in the Edit Database
window. 

1 Click the drop-down list button.

2  Click the required data. 

3  Click the data input field.

4  Enter the required value in the data input field.

Select all identical 
records

Database Manager must be open in the Edit Database
window and at least one record must exist. 

1 Click the drop-down list button.

2  Click the required data.

3  Click the data input field.

4  Enter the required data in the data input field.
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5  Click the Select all button. 

Note
You can also specify the filter by clicking on the 
Check case button. 

Select an 
identical record

Database Manager must be open in the Edit Database
window and at least one record must have been found.
There must be several identical contents in the Search field. 

To select a record, use the search tool: click 1 (First), 2
(Previous), 3 (Next) or 4 (Following). 

1 2 3 4
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Find a record according to its row in the table
Database Manager must be open in the Edit Database
window. 

1 Click the search tool’s data input field. 

2  Enter the required data.

Create a new record
Database Manager must be open in the Edit Database
window. 

1 Click a field in the row marked with an asterisk. 

2  Enter the required values in the corresponding fields. 

3  Click Apply.

Duplicate a record
Database Manager must be open in the Edit Database
window.

1 Click or double-click a row or a series of rows to highlight
the selected records.

2  Right-click to view the context menu.

3  Select Duplicate selected record(s).

Modify a record
Database Manager must be open in the Edit Database
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window. 

1 Click on the data you want to modifiy.

2  Enter the required data. 

3  Click Apply.

Sort a series of records by alphanumerical order
Database Manager must be open in the Edit Database
window. There must be at least two records in the table. 

1 Click on the name of the field required.
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Note
To sort records in descending order, click the same 
field again. 

Delete a record
Database Manager must be open in the Edit Database
window. 

1 Click the database cursor for the required field. 

2  Right-click the database cursor for the required field. 

3  Click Delete Record in the context menu.
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Database Queries

Database Query window

The Database Query window is used to create and apply
various filters. 

Add a query
Database Manager must be open to the Fields tab in the
Database Query window. 
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1 Click Add query.

2  Enter a name for the query.

3  Click OK.

Select/deselect one or more fields
Database Manager must be open to the Fields tab in the
Database Query window.

To select or deselect one or more fields, click on the button
next to 1, 2, 3, or 4 in the navigation tool. 

  

Click Query.

Modify the order of fields selected
Database Manager must be open to the Fields tab in the
Database Query window.

1 Click the required field in the Ordered fields window.

2  Click the Up or Down arrow to reach the required data.  

1
2
3
4
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3  Click Query.

Note
For a better view of the query application, you can 
increase the size of the data display area by reducing 
the height of the Fields, Filter, and SQL Query tabs. 

Create a filter using predefined data
Database Manager must be open to the Filter tab in the
Database Query window.

1 Click the Add row button.

2  Click in the Field field.

3  Click the drop-down list button.

4  Click the required data.
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5  Click in the Operator field.

6  Click the drop-down list button.

7  Click the required value.
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8  Click in the Value field.

9  Enter the required value.

10  Click Query.

Table 1: Description of operator functions

Operator Lookup

= Equal to

<> Different from

> Greater than

>= Greater than or equal to

< Less than

<= Less than or equal to

NOT

IN

LIKE

NOT LIKE

BETWEEN

NOT BETWEEN
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Apply a logical operator to several filters
Database Manager must be open to the Filter tab in the
Database Query window. Several filters must exist. 

1 Click in the Logical field.

2  Click the drop-down list button.

3  Click the required data.

4  Click Query to apply and view the changes. 

Sort the list of filters
Database Manager must be open to the Filter tab in the
Database Query window. Several filters must exist.

1 Click the database cursor for the required field.

2  Click the Up or Down arrow to reach the required data.
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Remove a filter
Database Manager must be open to the Filter tab in the
Database Query window. At least one filter must exist. 

1 Click the database cursor for the required field. 

2  Click the Remove row button.

Modify a filter in SQL
Database Manager must be open to the SQL Query tab in
the Database Query window. At least one filter must exist.

1 Select the Modify the query in SQL language option to
activate the SQL Query and make manual changes. 
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2  Click Query.

Note
The filter can be created directly in SQL without having 
to use the Filter tab first. 

Choose an existing query in a database
Database Manager must be open in the Database Query
window.

1 Click the Query drop-down list.

2  Click the required data.

Note
The selected query can be modified later. 
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Printing

Print window

The Print window is used to select files for printing, to
assign printers, and to define various parameters before
printing is launched.



Chapter 5 - 28 Database Manager - User manual
Display options
Database Manager must be open in the Print window.

Click Settings.

Preview the document
Database Manager must be open in the Print window.

Click Preview.

Display the label design software
Database Manager must be open in the Print window.

Click Designer.

Select a document to be printed

Create a new 
label template 
for printing

Database Manager must be open in the Print window.

Click the Create labels wizard button.

6  Follow the wizard’s instructions.
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Note
Creating a label in relation to the database allows you to 
define exactly which elements are required to position 
each database field.

Select an 
existing label 
template

Database Manager must be open in the Print window.

1 Click the Open an existing document button.

2  Select a label file.

3  Click OK.

Note
The Field radio buttons in the Label name and Printer 
name groups of options allow you to choose the label 
or printer required, when label or printer is defined in 
one of the fields of the active database.

Select a printer
Database Manager must be open in the Print window. A
label template must be selected.

1 Click the Add or remove a printer button.

2  Select the printer required.

3  Click Validate.

Note
The last printer used is selected by default.

Configure the selected printer
Database Manager must be open in the Print window. A
label template and printer must be selected.
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1 Click the Printer settings button.

2  Adjust the required settings.

3  Click OK.

Select records to be printed

Selecting 
records 
manually

Database Manager must be open in the Print window.

1 Select the checkboxes next to the records required.

Note
The height of the data display grid can be modified by 
dragging the top of the window.
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Selecting 
records 
automatically

Database Manager must be open in the Print window.

1 Click the drop-down list button.

2  Click the data required.

3  Click the data input field.

4  Enter the data required.

5  Click the Select all button.

6  Click the Verify button.

Configure the print media
Database Manager must be open in the Print window. A
document must be selected.

1 Click on the Page setup button
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Display the selected printer’s properties
Database Manager must be open in the Print window.

1 Click the Page setup button.

2  Click Settings.

Define the number of printed pages according to a 
field

Database Manager must be open in the Print window and
a printer must be selected. Records to be printed must also
be selected.

1 Click the Quantity column drop-down list.

2  Select the data required.

3  Click the selected data’s drop-down list button.

4  Select the required value or enter a whole numeric value.

Note
This option allows a selection of labels to be printed 
according to numeric values defined in specific fields. 
Different criteria can be set:

•  SERIALQTY: Defines the number of times the label
series will be printed.

•  LABELCPY: Defines the number of times the label
selected will be printed.

•  PAGECPY: Defines the number of times the page of
labels will be printed.
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Launch printing
Database Manager must be open in the Print window. A
label template and printer must be selected. The records to
be printed must also be selected.

Click the Print records button.

Launch printing 
manually each 
time

Database Manager must be open in the Print window. A
label template and printer must be selected. The records to
be printed must also be selected.

1 Select the Display the print dialog box between each
record.

2  Click the Print records button.

Update variable with database
Database Manager must be open in the Print window. A
label template and printer must be selected. The records to
be printed must also be selected.

1 Select the Update variable with database.

2  Click the Print records button.

Merge Database 
attached to 
document

Database Manager must be open in the Print window. A
label template and printer must be selected. The records to
be printed must also be selected.

1 Select the Merge Database attached to document.

2  Click the Print records button.

Allow the 
database to be 
edited

Database Manager must be open in the Print window. A
label template and printer must be selected. The records to
be printed must also be selected.
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1 Select the Allow the database to be edited.

2  Click the Print records button.

Stop printing
Database Manager must be open in the Print window. A
label template and printer must be selected. The records to
be printed must also be selected. Printing must have already
been launched.

Click the Stop printing button.

Refresh database view
Database Manager must be open in the Print window. A
label template and printer must be selected. At least one
record must also be selected.

Click the Refresh database button.

Close a document
Database Manager must be open in the Print window. A
label template must be selected.

1 Click the Documents drop-down list.

2  Click he data required.

3  Click the Close current document button.
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