ADMINISTRATOR’S GUIDE
The information in this manual is not binding and may be modified without prior notice.

Supply of the software described in this manual is subject to a user license. The software may not be used, copied or reproduced on any medium whatsoever, except in accordance with this license.

No portion of this manual may be copied, reproduced or transmitted by any means whatsoever, for purposes other than the personal use of the buyer, unless written permission is obtained from Teklynx Newco SAS.

©2019 Teklynx Newco SAS,
All rights reserved.

Teklynx and its products are trademarks or registered trademarks of Teklynx Newco SAS. All other brands and product names are the trademarks of their respective owners.
# Table of Contents

**About this Manual** ........................................................................ v

Typographical Conventions ...................................................... v

**Chapter 1: Introduction** .......................................................... 1-1

Welcome! ...................................................................................... 1-1

**LABEL ARCHIVE Modules** .................................................. 1-2

  - LABEL ARCHIVE Server ................................................ 1-2
  - LABEL ARCHIVE Client ............................................... 1-2
  - LABEL ARCHIVE Web Module ....................................... 1-2

How It Works .............................................................................. 1-2

Product Description ................................................................. 1-3

**Chapter 2: LABEL ARCHIVE Server Installation** ................ 2-4

System Requirements .............................................................. 2-4

Installation .............................................................................. 2-5

  - Software License Activation ......................................... 2-19
  - LABEL ARCHIVE Web Module Configuration ............... 2-20

Uninstallation ........................................................................... 2-22

**LABEL ARCHIVE Repair** .................................................... 2-23

**LABEL ARCHIVE Modification (Add/Remove Features)** .... 2-23

Special Notes ........................................................................... 2-24

**Chapter 3: LABEL ARCHIVE Client Installation** ................. 3-26

System Requirements .............................................................. 3-26

Installation .............................................................................. 3-27

Uninstallation .......................................................................... 3-34

**LABEL ARCHIVE Client Repair** .......................................... 3-35

**Chapter 4: LABEL ARCHIVE User and Password Management** 4-36

Managing Users and Permissions .......................................... 4-36

  - Predefined User Profiles ............................................... 4-36

Changing the Administrator Password ................................. 4-38
Table of Contents

How to Update the Config File .............................................. 4-39
Adding and Configuring Active Directory Users ..................... 4-40
Active Directory ............................................................... 4-40
About this Manual

Typographical Conventions

This manual distinguishes between different types of information using the following conventions:

• Terms taken from the interface itself, such as commands, appear in **bold**.
• Keys appear in small caps, for example: “Press the SHIFT key.”
• Numbered lists mean there is a procedure to follow.
• When the conjunction -or- appears next to a paragraph, it means there is the choice of another procedure for carrying out a given task.
• When a menu command contains submenus, the menu name followed by the command to select appear in bold. Thus, “Go to **File > Open**” means choose the **File** menu, then choose the **Open** command.

⚠️ This symbol highlights important information on how a particular command or procedure works.

💡 Following this symbol, you will find hints and tips for optimizing tasks, speeding up commands, and so on.
CHAPTER 1

Introduction

Welcome!

Congratulations! You have just acquired a complete and secure product solution to store barcode labels, trace the history of design modifications and print events, manage label versions, and set up approval workflows.

LABEL ARCHIVE Server and Client applications run on your company’s network in conjunction with CODESOFT, and an optional Web module can also be used to provide limited access to external users.

The scalability of this product allows you to also install all components on your PC, and work in standalone mode like a simple desktop application.
LABEL ARCHIVE Modules

The LABEL ARCHIVE package contains several modules: LABEL ARCHIVE Server, LABEL ARCHIVE Client, and the LABEL ARCHIVE Web module.

LABEL ARCHIVE Server

LABEL ARCHIVE Server is a centralized database driven through a Windows® service. It establishes the connection with the different data sources, and processes all client requests: Check In, Check Out, Print History, Document Approval, etc. The Server also uses two subsystems to operate: UMSS (User Management System) and MSGS (Messaging System). UMSS and MSGS respectively perform user configuration and messaging functions.

LABEL ARCHIVE Client

The LABEL ARCHIVE Client is the add-in for the Label Designer application. When the user invokes LABEL ARCHIVE from the Label Designer, this add-in connects to the Server and checks user rights. If the connection is successful then the user is allowed to perform different document management actions such as Check In and Check Out, and is given access to the centralized label storage database. The actions allowed depend upon the security settings and permissions that have been granted to the group to which the user belongs.

LABEL ARCHIVE Web Module

The LABEL ARCHIVE Web Module is a Web application accessible from any Web browser on the Internet or an intranet. Upon successful user Web authentication, this module establishes a connection with LABEL ARCHIVE Server and gives access to limited functions including viewing documents and history records, and approving documents before delivery in production.

How It Works

LABEL ARCHIVE Server typically runs on a server machine. On the internal network, any client station that has a label designer and the LABEL ARCHIVE Client add-in can interact with the server at any time. All LABEL ARCHIVE components can also be installed on a single PC. In that case the system works in standalone mode, like a simple desktop application.
Product Description

LABEL ARCHIVE is designed to run on any computer running a supported Windows® operating system.

Your product includes the following components:

- DVD
- complete documentation
- a license agreement
- A Serial Number and password, which allows you to activate the license of LABEL ARCHIVE Server on your server machine

**Note**
If you have not purchased a license yet, you can still use LABEL ARCHIVE for 30 days. During this trial period you can install as many clients as you want, and the system will accept up to three simultaneous connections to the server. After the trial period you will need to purchase a license. All the work that was done during the trial period is kept in the database, and you can continue it after activation without any disruption.
CHAPTER 2

LABEL ARCHIVE Server Installation

System Requirements

The basic software and hardware requirements needed to run the LABEL ARCHIVE Server application are:

• A PC with Windows Server 2008 SP2/2008R2 SP1, 2012/2012R2, 2016, 2019 (all 64-bit)

• 2 GB RAM minimum (4-8 GBs recommended) and 1.2 Ghz processor

• A VGA monitor or better.

• Min resolution 1366x768

• A hard drive with at least 1.5 Gb of free disk space

• Microsoft® .NET Framework 4.6.1

• Supported database management systems (DBMS): SQL Server 2008/2008 R2/2012/2014/2016/2017 Oracle 11.2 or higher.

Note

SQL Server Express is recommended for demo purpose only. For the big data volumes and multiple users
it's recommended to use full SQL Server version.

Installation

Before running the installation program, check the configuration of your server machine.

LABEL ARCHIVE Server installation requires administration rights on the server machine. Please check that all needed permissions are granted, both at the operating system level, and at the DBMS level, as you will be installing new Windows services, copying program files, setting up a Web module on Internet Information Services (IIS), and creating new databases on your DBMS.

If you are installing the Web module, and your platform does not yet have Microsoft ® IIS installed, it is recommended that you install Microsoft .NET Framework 4.6.1 after IIS so that the ASP.NET service registration can be done automatically.

To install LABEL ARCHIVE Server:

Step 1 > Place the DVD in the appropriate disk drive.

The LABEL ARCHIVE DVD window should appear. Select LABEL ARCHIVE Server and click Install icon.

If the CD-ROM does not start up automatically, go to Start > My Computer and double-click on the LABEL ARCHIVE DVD.

If the DVD does not automatically open, go to Windows Explorer and locate the DVD drive letter and click on it to view its contents. Double-click on the Index.hta (or just “Index” if you have file extensions hidden) file located on the DVD.
The **Installation Wizard** window will appear.

![Installation Wizard window](Image)

*Figure 1* Installation Wizard window

**Step 2**  >  Click **Next**.
The License Agreement window will appear.

![Figure 2 License Agreement window](image)

**Step 3** > Read the license agreement. If you agree with the terms of license agreement, select *I accept the terms of the license agreement*.

**Step 4** > Click Next.
The **Destination Location** window will appear.

![Figure 3 Destination Location window](image)

**Step 5** > Choose the destination folder.

In this step, you are able to select which folder the files will be installed in. The default install folder is `C:\Program Files\Teklynx` and it is recommended that you do not change it.

**Step 6** > Click **Next**.
The **Select Features** window will appear.

![Select Features window](image)

**Figure 4** Select Features window

By default, the LABEL ARCHIVE Web module is not selected. To view and approve labels through a Web browser, select **LABEL ARCHIVE Web**.

**Step 7** > Click **Next**.
Step 8  >  Click Next.

The **UMSS and MSGS Servers** window will appear.

![UMSS and MSGS Servers window](image)

**Figure 5** UMSS and MSGS Servers window

If you are installing TEKLYNX software for the first time, select the **I want to install a new UMSS-MSGS module** option and follow the steps in the UMSS-MSGS installation wizard.

If you have previously installed TEKLYNX software, you may have an existing user management module installed. To check, go to Control Panel > Add/Remove Programs. If UMSS-MSGS appears in the program list, select the **I want to connect LABEL ARCHIVE to an existing UMSS-MSGS module in my company’s network** option.

Step 9  >  Click Next.
Step 10 > Click Next.

The Ready to Install window will appear.

![Ready to Install window](image)

**Figure 8** Ready to Install window

Step 11 > Finish the installation by clicking Install.

In the end of installation process Application Configuration tool will appear to let user create new / upgrade databases, enter credentials and specify LA Web settings.
You have successfully installed the LABEL ARCHIVE Server module.

**Software License Activation**

You can use LABEL ARCHIVE in trial mode for 30 days. After that period the server is blocked. Any connection attempt results in an error message "Maximum number of connections reached". To continue to use the software you must activate the license. Activation wizard is launched after installation.
**Note**

If you activate the license once the trial period is expired, you will need to reboot the LABEL ARCHIVE Server computer.

**LABEL ARCHIVE Web Module Configuration**

After installing the LABEL ARCHIVE Web module, you should verify the Web site settings:

**Step 1** > Go to Control Panel > Administrative Tools > Internet Information Services.

**Step 2** > In the navigation frame on the left, navigate to the Application Pools.

**Step 3** > Make sure LABEL ARCHIVE AppPool has been created automatically.

**Step 4** > Verify that the .NET version is set to 4.0.
Chapter 2 - 21

Administrator's Guide

**Figure 9** Pool Properties window
Uninstallation

To remove the different server components from your computer:

Step 1 > Go to Control Panel > Add or Remove Programs.

Step 2 > Select LABEL ARCHIVE Server and click on Change/Remove.

Step 3 > In the next window, select the Remove option and click Next.

![Figure 10 Modify, Repair, or Remove the Program window]

The uninstallation program will delete the installed components from your computer and optionally the databases if specified. You will be asked whether you want to also remove the UMSS-MSGS module. Please note that the UMSS-MSGS module is also used for other TEKLYNX products.
Chapter 2 - 23

LABEL ARCHIVE Repair

If the installed LABEL ARCHIVE Server components proved to be corrupted, you can fix them using the Repair mode (see Figure 12).

In this mode, the setup application will reprocess the installation of the different components. The installation settings that you entered during the last installation will be reused.

SQL Database: In this mode, the structure of SQL Database will be repaired (for example, if your SQL database structure was corrupted).

Oracle Database: In this mode, the structure of Oracle Database will be repaired (for example, if your Oracle database structure was corrupted).

Access Database: In this mode, the Access Database will be overwritten, but before starting the repair process, the setup will propose to create backup-files for your databases, and after the repair you will be able to replace the database.

LABEL ARCHIVE Modification (Add/Remove Features)

If you want to add components which were not previously installed, you can use the Modify mode (see Figure 12). In this mode, the setup application will propose to select the components to be installed.
**Special Notes**

- The administration user interfaces LABEL ARCHIVE Server and Client are created using the MMC (Microsoft Management Console) snap-in, so they can be manipulated like any standard MMC component in Windows.

- Full SQL Server is required to install the database on a computer that is different from the one that hosts the LABEL ARCHIVE Server processes and services.
• For SQL Server, make sure that remote connections are allowed (disallowed by default).

• If you have a firewall, you must unblock ports 8088 and 8989.

• LABEL ARCHIVE Server Windows service: The Server program is run through a Windows service named LABEL ARCHIVE Server, which is configured by default to start automatically. The service has a dependency link with the UMSS/MSGS Windows service, named TkxSvr Servers service. You can start and stop Windows services manually by using the standard Windows administration tool.

Before doing administration work on LABEL ARCHIVE Server (i.e., changing parameters and options, importing/exporting data, etc.), it is highly recommended to first ensure that all clients are disconnected. If you change some settings, you may then want to stop and restart the LABEL ARCHIVE Server Windows service for all changes to be effective.
CHAPTER 3

LABEL ARCHIVE Client Installation

System Requirements

The basic software and hardware requirements needed to run the LABEL ARCHIVE Client application are:

• A PC with Windows 7 SP1, Windows 8/8.1 and Windows 10 (all x32/x64).

• 2 GB RAM minimum (4-8 GBs recommended) and 1.2 Ghz processor

• A VGA monitor or better

• Min resolution 1366x768

• A hard drive with at least 1.5 Gb of free disk space

• Microsoft .NET Framework 4.6.1 (on DVD)

• TEKLYNX CODESOFT 2019
Chapter 3 - 27

Installation

Before running the installation program, check the configuration of your PC.

To install LABEL ARCHIVE Client:

**Step 1** > Place the DVD in the appropriate disk drive.

The LABEL ARCHIVE CD window should appear. Select **LABEL ARCHIVE Client** and click **Install** icon.

If the DVD does not start up automatically, go to **Start > My Computer** and double-click on the LABEL ARCHIVE DVD.

If the DVD does not automatically open, go to Windows Explorer and locate the DVD drive letter and click on it to view its contents. Double-click on the **index.hta** (or just “Index” if you have file extensions hidden) file located on the DVD.

The **Installation Wizard** window will appear.

---

**Figure 1** Installation Wizard window
Step 2 > Click Next.
The License Agreement window will appear.

Figure 2 License Agreement window

Step 3 > Read the license agreement. If you agree with the license agreement, select I accept the terms of the license agreement.

Step 4 > Click Next.
The **Customer Information** window will appear.

![Customer Information window](image)

**Figure 3** Customer Information window

**Step 5**  >  Enter the following customer information:

- User name
- Company name
- Who will be able to use this application (only you, or anyone who uses the computer)

**Step 6**  >  Click **Next**.
The **Destination Location** window will appear.

![Figure 4 Destination Location window](image)

**Step 7**  >  Choose the folder where the files will be installed.

In this step, you are able to select which folder the files will be installed in. The default install folder is `C:\Program Files\Teklynx\LABEL ARCHIVE Client\` and it is recommended that you do not change it.

**Step 8**  >  Click **Next**.
The **Select Features** window will appear.

![Select Features Window](image)

**Figure 5** Select features window

**Step 9** > Choose the client components from the list. In this step, you are able to select components that will be installed with LA Client. This includes Server, Client Administration snap-ins and UMSS-MSGS snap-in.

**Step 10** > Click **Next**.
The **LABEL ARCHIVE Server Settings** window will appear.

![LABEL ARCHIVE Server Settings Window](image)

**Figure 6** LABEL ARCHIVE Server Settings window

**Step 11** > Browse to and select the location of the LABEL ARCHIVE Server machine to which the client will connect.

**Step 12** > Browse to and select the location of the UMSS\MSGS Server machine to which the user will be authenticated.

**Step 13** > Click **Next**.
The **Start Installation** window will appear.

![Start Installation Window](image)

**Figure 7** Start Installation window

**Step 14** > If you are sure that the parameters/settings entered in previous steps are correct, click **Install**. You have successfully installed the LABEL ARCHIVE Client.

If you want to review or change any of the installation settings, click **Back** to return to the previous screens.
Uninstallation

To remove the **LABEL ARCHIVE Client** from your computer:

**Step 1** > Go to Control Panel > Add or Remove Programs.

**Step 2** > Select **LABEL ARCHIVE Client** and click Change.

**Step 3** > In the next window, select the **Remove** option and click Next.

![rcode]

**Figure 8** Repair or Remove the Program window

The uninstallation program will delete the installed components of **LABEL ARCHIVE Client** from your computer.
LABEL ARCHIVE Client Repair

If the installed LABEL ARCHIVE Client is corrupt, you can fix it using the Repair mode.

In this mode, the system will redo the installation of LABEL ARCHIVE Client. The installation settings that you entered during the last installation will be reused.
CHAPTER 4

LABEL ARCHIVE User and Password Management

Managing Users and Permissions

LABEL ARCHIVE uses the UMSS subsystem to manage all users and permissions. At any time, the administrator can create, modify, or delete users, passwords, and user groups. For more details about permissions management, please refer to the LABEL ARCHIVE User guide.

Predefined User Profiles

At install time, the system creates predefined user groups. These groups correspond to typical profiles that a company may need to use to manage the different user permissions for all LABEL ARCHIVE business processes.

Five different user groups are available:

- **ADMINISTRATORS**

  Administrators have all rights for LABEL ARCHIVE, and also on UMSS and MSGS subsystems. Their typical role is to have full IT responsibility of the entire system.

  A default Administrator user is provided. Its initial password is **admin**.

  Additional users can be created and assigned to the Administrators group.

- **MANAGERS**

  Managers' typical role is to be in charge of the business data and processes of LABEL ARCHIVE. Managers can define system settings, create approval workflows, or be required
to approve documents before delivery in production.

Compared to Administrators, Managers do not have permission to administrate the database or define workstation settings. They cannot perform operations like import DB, export DB, force undo check-out, DB archive, or manage workstations.

A default Manager user is provided. Its initial password is empty.

Additional users can be created and assigned to the Managers group.

• DESIGNERS

Designers' typical role is to be in charge of the creation and management of a document or a set of documents. Designers can create documents, modify documents, check-in new versions, submit documents for approval, and participate in approval processes.

Compared to Managers, Designers do not have permission to modify system settings, create or modify approval schemes, or modify categories.

A default Designer user is provided. Its initial password is empty.

Additional users can be created and assigned to the Designers group.

• PRINT USERS

Print Users' typical role is to open documents and print them in production.

Compared to Designers, Print Users do not have permission to modify documents, and they can only access documents that are in Final state.

Print Users can use the Runtime version of the label designer to carry on their activities.

A default PrintUser user is provided. Its initial password is empty.

Additional users can be created and assigned to the PrintUser group.
• CUSTOMERS

In some cases, documents may need to be approved by Customers before delivery in production.

Customers, therefore, are given minimum access to the system, including browsing their documents and all related details, and taking part in an approval workflow.

Customers can use the LABEL ARCHIVE Web module, through an Internet browser, and receive notifications by e-mail.

A default Customer user is provided. Its initial password is empty.

Additional users can be created and assigned to the Customers group.

You can freely modify, customize or delete the predefined groups, users and permissions, except for the Administrator.

Note

To view all permissions that are granted to a given User, select the related Group from the “User Groups” node in UMSS, and click on the Permission tab.

Default Administrator user

LABEL ARCHIVE has predefined Administrator user with default password admin. This password can be changed in UMSS Administration later.
Adding and Configuring Active Directory Users

**Active Directory**

Active Directory is a special-purposes database used to store non-dynamic data such as users, groups, and configuration data. By adding and configuring users in Active Directory, administrators can now automate LABEL ARCHIVE login using Windows authentication.

To add and configure an Active Directory User in LABEL ARCHIVE:

**Step 1**  > Launch the LABEL ARCHIVE Server.

**Step 2**  > Log in using a known user account, or use the default user name *Administrator* and the default password *admin*.

**Step 3**  > In the console tree on the left, select *LABEL ARCHIVE Administration > Settings > Functions*, and confirm that the *Allow different user connection* option is selected in the *Options and Functions* area.

**Note**

This is the default setting.
Step 4 > In the console tree on the left, select LABEL ARCHIVE Administration > LABEL ARCHIVE Server Settings and confirm that the Always prompt login option is not selected in the Connection area.

Note
This is the default setting.
Figure 2 Enabling automatic prompts at log in

Step 5  >  Close the LABEL ARCHIVE Administration.

Step 6  >  From the Start menu, select All Programs > Teklynx > UMSS-MSGS Servers Administration to launch UMSS.

Step 7  >  Log in using a known user account, or use the default user name Administrator and the default password admin.

Step 8  >  In the console tree on the left, right-click UMSS-MSGS Servers > UMSS > Users, and then select New > User.

Step 9  >  From the Authentication drop-down menu, select Windows.
Step 10 > Click the button.

Step 11 > Click Locations.

Step 12 > From the Locations area, select the domain network that the user is on, and click OK.

Step 13 > Enter the user’s last name in the Name field, and click Find Now.

Step 14 > From the Search results list, select the appropriate user and click OK.
Step 15 > In the User Properties - New dialog box, select the User tab and do the following:

- Enter the user's first name in the First name field.
- Enter the user's last name in the Last name field.
- If desired, enter the user's phone, mobile and e-mail information in the areas provided.

**Note**
Because the user's passwords are being managed by the Windows account, the User may change password, User must change password, and Locked options aren’t available.
Figure 5 Adding user information

**Step 16** > From the **Group memberships** tab, double-click to select the groups that the user should belong to, and click **OK**.
Step 17 > From the File menu, select Save to save the MMC (Microsoft Management Console) file.

If prompted to update MMC, click Yes.

Step 18 > Launch CODESOFT.

Step 19 > From the File menu, select LABEL ARCHIVE > Connect to automatically connect to LABEL ARCHIVE.
Note
If you launch the LABEL ARCHIVE Administration or the LABEL ARCHIVE Server, you will be prompted to enter a username and password. To log in without having to enter them, select the Use Windows Authentication check box and click OK.

Figure 7 Enabling Windows authentication