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About this Manual

Typographical This manual distinguishes between different types of
Conventions information using the following conventions:

« Terms taken from the interface itself, such as
commands, appear in bold.

» Keys appear in small caps, for example: “Press the
SHIFT key.”

* Numbered lists mean there is a procedure to follow.

* When the conjunction -or- appears next to a
paragraph, it means there is the choice of another
procedure for carrying out a given task.

* When a menu command contains submenus, the
menu name followed by the command to select appear
in bold. Thus, “Go to File > Open” means choose the
File menu, then choose the Open command.

This symbol highlights important information on

s

how a particular command or procedure works.

for optimizing tasks, speeding up commands, and

Following this symbol, you will find hints and tips
; ; So on.
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Introduction

Welcome!

Congratulations! You have just acquired a complete and
secure product solution to store barcode labels, trace the
history of design modifications and print events, manage
label versions, and set up approval workflows.

LABEL ARCHIVE Server and Client applications run on your
company's network in conjunction with CODESOFT, and an
optional Web module can also be used to provide limited
access to external users.

The scalability of this product allows you to also install all
components on your PC, and work in standalone mode like
a simple desktop application.
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LABEL ARCHIVE Modules

LABEL
ARCHIVE Server

LABEL
ARCHIVE Client

LABEL
ARCHIVE Web
Module

How It Works

The LABEL ARCHIVE package contains several modules:
LABEL ARCHIVE Server, LABEL ARCHIVE Client, and the
LABEL ARCHIVE Web module.

LABEL ARCHIVE Server is a centralized database driven
through a Windows® service. It establishes the connection
with the different data sources, and processes all client
requests: Check In, Check Out, Print History, Document
Approval, etc. The Server also uses two subsystems to
operate: UMSS (User Management System) and MSGS
(Messaging System). UMSS and MSGS respectively
perform user configuration and messaging functions.

The LABEL ARCHIVE Client is the add-in for the Label
Designer application. When the user invokes LABEL
ARCHIVE from the Label Designer, this add-in connects to
the Server and checks user rights. If the connection is
successful then the user is allowed to perform different
document management actions such as Check In and
Check Out, and is given access to the centralized label
storage database. The actions allowed depend upon the
security settings and permissions that have been granted to
the group to which the user belongs.

The LABEL ARCHIVE Web Module is a Web application
accessible from any Web browser on the Internet or an
intranet. Upon successful user Web authentication, this
module establishes a connection with LABEL ARCHIVE
Server and gives access to limited functions including
viewing documents and history records, and approving
documents before delivery in production.

LABEL ARCHIVE Server typically runs on a server machine.
On the internal network, any client station that has a label
designer and the LABEL ARCHIVE Client add-in can
interact with the server at any time. All LABEL ARCHIVE
components can also be installed on a single PC. In that
case the system works in standalone mode, like a simple
desktop application.
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Product Description

LABEL ARCHIVE is designed to run on any computer
running a supported windows® operating system.

Your product includes the following components:
- DVD
« complete documentation
» alicense agreement

 an activation code, which allows you to activate the
license of LABEL ARCHIVE Server on your server
machine

If you have not purchased an activation code yet, you
can still use LABEL ARCHIVE for 30 days. During this
trial period you can install as many clients as you want,
and the system will accept up to three simultaneous
connections to the server. After the trial period you will
need to purchase an activation code. All the work that
was done during the trial period is kept in the database,
and you can continue it after activation without any
disruption.
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LABEL ARCHIVE Server
Installation

System Requirements

The basic software and hardware requirements needed to
run the LABEL ARCHIVE Server application are:

* A PC with Windows Server 2008/2008R2,
2012/2012R2, 2016.

* 1 GB RAM minimum (2-4 GBs recommended) and
1.2 Ghz processor

* A VGA monitor or better.

Min resolution 1366x768

* A hard drive with at least 500 MB of free disk space

« Microsoft® .NET Framework 3.5 SP1, 4.5.2

Supported database management systems (DBMS):
SQL Server 2008/2008 R2/2012/2014/2016
Oracle 10g or higher.

SQL Server Express is recommended for demo purpose
only. For the big data volumes and multiple users
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Installation

it's recommended to use full SQL Server version.

Before running the installation program, check the
configuration of your server machine.

LABEL ARCHIVE Server installation requires administration
rights on the server machine. Please check that all needed
permissions are granted, both at the operating system level,
and at the DBMS level, as you will be installing new
Windows services, copying program files, setting up a Web
module on Internet Information Services (IIS), and creating
new databases on your DBMS.

If you are installing the Web module, and your

! platform does not yet have Microsoft ® IIS
installed, it is recommended that you install
Microsoft .NET Framework 3.5/4.0 after IS so that
the ASP.NET service registration can be done
automatically.

To install LABEL ARCHIVE Server:
Step 1 > Place the DVD in the appropriate disk drive.

The LABEL ARCHIVE DVD window should appear. Select
LABEL ARCHIVE Server and click Install icon.

If the CD-ROM does not start up automatically, go to Start
> My Computer and double-click on the LABEL ARCHIVE
DVD.

If the DVD does not automatically open, go to Windows
Explorer and locate the DVD drive letter and click on it
to view its contents. Double-click on the Index.hta (or just

“Index” if you have file extensions hidden) file located on
the DVD.
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The Installation Wizard window will appear.

LABEL ARCHIVE Server 2018 x|

‘Welcome to the InstallShield Wizard for LABEL
ARCHIVE Server 2018

The InstaliShield Wizard will install LABEL ARCHIVE
Server 2018 on your computer. To continue, click Next.

< Back | Next > I Cancel

Figure 1 Installation Wizard window

Step 2 > Click Next.
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The License Agreement window will appear.

License Agreement
Please read the following license agreement carefully.

Teklynx Newco SAS Software License Agreement =

Teklynx Newco SAS (hereafter Teklynx ) or its affiliated companies hereby
grants you a non-exclusive, nontransferable license to use this software and
the accompanying documentation according to the following terms:

LICENSE GRANT - You may

1) install and use the sofiware on the number of computers covered by
invoices for this license from Teklynx, which are hereby incorporated by
reference; .

() | accept the terms of the license agreement

@ | do nat accept the terms of the license agreement

Figure 2 License Agreement window

Step 3 > Read the license agreement. If you agree with the
terms of license agreement, select | accept the terms of
the license agreement.

Step 4 > Click Next.
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The Destination Location window will appear.

Choose Destination Location
Select folder where setup will install files.

Setup will install LABEL ARCHIVE Server in the following folder.

Ta install to this folder, click Next. To install to a different folder, click Browse and select
another folder.

Destination Folder

C:\Program Files (+8B1\Tekiyni

[ < Back ][ Next > ][ Cancel ]

Figure 3 Destination Location window

Step 5 > Choose the destination folder.

In this step, you are able to select which folder the files will
be installed in. The default install folder is C:\Program
Files\Teklynx\ and it is recommended that you do not
change it.

Step 6 > Click Next.
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The Select Features window will appear.

Select the features you want to install, and deselect the features you do not want to install.

I LABEL Al i~ Description
[TJLABEL ARCHIVE Web Provides label management
[JLABEL ARCHIVE Backup services

51.61 MB of space required on the C drive
2967.94 MB of space available on the C drive

InstallShield

< Back Next > l Cancel I

Figure 4 Select Features window

By default, the LABEL ARCHIVE Web module is not
selected. To view and approve labels through a Web
browser, select LABEL ARCHIVE Web.

Step 7 > Click Next.
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The Application Services window will appear.

By default the application service iz logged on as LocalSystem account.

I Define Service User account

Uzer:
I Browse |
Password:

|ristallShisld

< Back | Mest > I Cancel

Figure 5 Application Services user window

Step 8 > Define user account.

It's possible to define user account under which LA
services will run. By default it's LocalSystem account.

Step 9 > Click Next.
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The UMSS and MSGS Servers window will appear.

UMSS and MSGS Servers
Specify the settings for UMSS and MSGS Servers

Connecting Label Archive to the User Security module (UMSS) and Messaging Service module
(MSGS)

@) | want to install a new UMSS-MSGS module

- | want to connect Label Archive to an existing UMSS-MSGS module in my company's
= network

TKXWINT-64 Browse

[ < Back ][ Next > ][ Cancel

Figure 6 UMSS and MSMG Servers window

If you are installing TEKLYNX software for the first time,
select the | want to install a new UMSS-MSGS module
option and follow the steps in the UMSS-MSGS installation
wizard.

If you have previously installed TEKLYNX software, you
may have an existing user management module installed.
To check, go to Control Panel > Add/Remove Programs.
If UMSS-MSGS appears in the program list, select the |
want to connect LABEL ARCHIVE to an existing
UMSS-MSGS module in my company’s network option.

Step 10 > Click Next.
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The Web Site Settings window will appear.

Please select the web site on which you want to deploy LABEL ARCHIVE Web:

Default Web Site v

g‘» < Back [ Next> J [ Cancel |

Figure 7 Web Site Settings window

Step 11 > Select the Web site on which you want to run the
LABEL ARCHIVE Web module.
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Step 12 > Click Next.

The Virtual Directory Settings window will appear.

Please specify the settings for virtual directory of the web site:

Name: |

Path: \Program Files\Teklyrx\Label Archive \Web

l < Back Newt > [ Cancel \

Figure 8 Virtual Directory Settings window

Step 13 > Enter the name of the Web site’s virtual
directory.
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Step 14 > Click Next.
The Ready to Install window will appear.

Ready to Install the Program
The wizard is ready to begin installation.

Click Install to begin the installation.

If you want to review or change any of your installation settings, click Back. Click Cancel to exit
the wizard.

[ < Back ][ Install ][ Cancel

Figure 9 Ready to Install window

Step 15 > Finish the installation by clicking Install.

In the end of installation process Database configuration tool
will appear to let user create new / upgrade database and
enter credentials.
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o]
Application Selection
Specify application for further corfiguration
ication Selection =] Applications
“'"’_' ' O umss
Action selection I MsGs
Database type selection LABEL ARCHIVE
LABEL ARCHIVE
Ready
Progress
Complete
<Back |[ Net> | cance |
=1
Action selection
Select iate action to confi datab
Application Selection & Create/Update database
Action selection
Database type selection {7 Delete databzse
LABEL ARCHIVE
Ready {7 Save database connection options
Progress €% Skip database configuration
Complete
Create/Update database
Creates new or updates existing database with saving connection
options.
Use if automatic database creation is a prefemrable solution.
<Back [[ Net> | Cancel
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Software License
Activation

T S — =10l x|

Database type selection
Specify type of server database.

Application Selection
Action selection
Database type selection | { Oracle
LABEL ARCHIVE
Ready

Progress
Complete

¢ SQL Server

< Back | Next > Cancel

_loix]

LABEL ARCHIVE
Select database connection options.

flopkcaton >cection Server name: [[Local)\SQLEXPRESS =
Action selection

Database type selection
LABEL ARCHIVE Authentication: |Windows Authentication =l

Database name: JLABELARCHIVE

Ready User name [TRXWIN-64\TestAdmin

Progress
Complete

Password l

<Back | [ Next> Cancel |

You have successfully installed the LABEL ARCHIVE
Server module.

You can use LABEL ARCHIVE in trial mode for 30 days.
After that period the server is blocked. Any connection
attempt results in an error message “Maximum number of
connections reached”. To continue to use the software you
must activate the license. Activation wizard is launched
after installation.
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LABEL ARCHIVE
Web Module
Configuration

If you activate the license once the trial period is
expired, you will need to reboot the LABEL ARCHIVE
Server computer.

After installing the LABEL ARCHIVE Web module, you
should verify the Web site settings:

Step 1 > Go to Control Panel > Administrative Tools >
Internet Information Services.

Step 2 > In the navigation frame on the left, navigate to the
Application Pools.

Step 3 > Make sure LABEL ARCHIVE AppPool has been
created automatically.

Step 4 > Verify that the .NET version is set to 4.0.
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# | QQI Application Pools
=195 WIN-TAEGFLAQBBQ (WIN-IAEG, ) ) ) o o ) _
(2 Bppication Bools This page lets you view and manage the list of application pools on the server, Application pools are associated with worker proces:
Lo applications, and provide isolation among different applications.
[ 8] Sites
=148 Default Web Site Filter: v 00co -~ Ghshowall | Groupby: No Grouping M
. f::"Et-':"e"t Hame = [ status [ MET Frame... [ Managed Pipeli... | Identity | applications [
Q;ASP.NET v4.0 Started v4.0 Integrated ApplicationPoollden... 0
QASP.NET v4.0 Classic Started v4.0 Classic ApplicationPoollden... 0
chassic .MET AppPaol Started v2.0 Classic ApplicationPoollden... 0
QDefauItAppPool Started v2.0 Integrated ApplicationPoollden... 1
@LABEL ARCHIYE AppPool Started v4.0 Integrated LocalSystem 1
Edit Application 1l 21|
Mame:
|LABEL ARCHIVE AppPool
(MET Framework version:
| NET Framework v4.0.30319 =
Managed pipeline mode:
IIntegrated o I
IV Start application pool immediately
|

Figure 10 Pool Properties window
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Uninstallation

To remove the different server components from your
computer:

Step 1> Goto Control Panel > Add or Remove Programs.

Step 2 > Select LABEL ARCHIVE Server and click on
Change/Remove.

Step 3 > In the next window, select the Remove option and
click Next.

Welcome
Modify, repair, or remove the program.

Welcome to the LABEL ARCHIVE Server Setup Maintenance program. This program lets you
modify the current installation. Click one of the options below.

Q@ Modify
i
Select new program features to add or select currently installed features to
st emove.
©) Repair

Reinstall all program features installed by the previous setup.

) Remove
Euqf I Remove all installed features.

< Back [ Next > ][ Cancel ]

Figure 11 Modify, Repair, or Remove the Program window

The uninstallation program will delete the installed
components from your computer and optionally the
databases if specified. You will be asked whether you want
to also remove the UMSS-MSGS module. Please note that
the UMSS-MSGS module is also used for other TEKLYNX
products.
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LABEL ARCHIVE Repair

If the installed LABEL ARCHIVE Server components proved
to be corrupted, you can fix them using the Repair mode
(see Figure 12).

In this mode, the setup application will reprocess the
installation of the different components. The installation
settings that you entered during the last installation will be
reused.

SQL Database: In this mode, the structure of SQL
Database will be repaired (for example, if your SQL
database structure was corrupted).

Oracle Database: In this mode, the structure of Oracle
Database will be repaired (for example, if your Oracle
database structure was corrupted).

Access Database: In this mode, the Access Database will
be overwritten, but before starting the repair process, the

setup will propose to create backup-files for your databases,
and after the repair you will be able to replace the database.

LABEL ARCHIVE Modification (Add/Remove
Features)

If you want to add components which were not previously
installed, you can use the Modify mode (see Figure 12). In
this mode, the setup application will propose to select the
components to be installed.



LABEL ARCHIVE Server Installation Chapter 2 - 24

Select Features
Select the features setup will install.

Select the features you want to install, and deselect the features you do not want to install

I LAEEL SRCHIVE Serve] Description
[ JLABEL ARCHIVE Web Provides label management

Services

0.00 MB of space required on the C drive
19544.43 MB of space available on the C drive

[ < Back ][ Next > J[ Cancel ]

Figure 12 Select Features window

Special Notes

* The administration user interfaces LABEL ARCHIVE
Server and Client are created using the MMC
(Microsoft Management Console) snap-in, so they
can be manipulated like any standard MMC
component in Windows.

» Full SQL Server is required to install the database on
a computer that is different from the one that hosts
the LABEL ARCHIVE Server processes and
services.
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» For SQL Server, make sure that remote

connections are allowed (disallowed by default).

If you have a firewall, you must unblock ports 8088
and 8989.

LABEL ARCHIVE Server Windows service: The
Server program is run through a Windows service
named LABEL ARCHIVE Server, which is configured
by default to start automatically. The service has a
dependency link with the UMSS/MSGS Windows
service, named TkxSvr Servers service. You can
start and stop Windows services manually by using
the standard Windows administration tool.

Before doing administration work on LABEL
ARCHIVE Server (i.e., changing parameters and
options, importing/exporting data, etc.), it is highly
recommended to first ensure that all clients are
disconnected. If you change some settings, you
may then want to stop and restart the LABEL
ARCHIVE Server Windows service for all changes
to be effective.
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LABEL ARCHIVE Client
Installation

System Requirements

The basic software and hardware requirements needed to
run the LABEL ARCHIVE Client application are:

* A PC with Windows Vista SP2, Windows 7 SP1,
Windows 8/8.1 and Windows 10.

* 1 GB RAM minimum (2-4 GBs recommended) and
1.2 Ghz processor

* A VGA monitor or better
* Min resolution 1366x768
* A hard drive with at least 500 MB of free disk space
» Microsoft .NET Framework 3.5 SP1, 4.5.2 (on DVD)

* TEKLYNX CODESOFT 2018
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Installation

Before running the installation program, check the
configuration of your PC.

To install LABEL ARCHIVE Client:
Step 1 > Place the DVD in the appropriate disk drive.

The LABEL ARCHIVE CD window should appear. Select
LABEL ARCHIVE Client and click Install icon.

If the DVD does not start up automatically, go to Start
> My Computer and double-click on the LABEL ARCHIVE
DVD.

If the DVD does not automatically open, go to Windows
Explorer and locate the DVD drive letter and click on it
to view its contents. Double-click on the Index.hta (or just

“Index” if you have file extensions hidden) file located on
the DVD.

The Installation Wizard window will appear.

LABEL ARCHIVE Client 2018 x|

Welcome to the InstallShield Wizard for LABEL
ARCHIVE Client 2018

The InstallShield \wWizard will install LABEL ARCHIVE Client
2018 on your computer. To continue, click Next.

< Back | Next > I Cancel

Figure 1 Installation Wizard window
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Step 2 > Click Next.
The License Agreement window will appear.

License Agreement
Please read the following license agreement carefully.

Teklynx Newco SAS Software License Agreement &
Teklynx Newco SAS (hereafter “Teklynx ") or its affiliated companies hereby T
grants you a non-exclusive, nontransferable license to use this software and
the accompanying documentation according to the following terms:

LICENSE GRANT - You may

1) install and use the software on the number of computers covered by
invoices for this license from Teklynx, which are hereby incorporated by
reference; -

A vimn A A nainnit Hh Ao n fRansca. Ak B abams el st in s oA i enbs nEvad i an

@) | accept the terms of the license agreement

() | do not accept the terms of the license agreement

[ < Back ][ Next > ][ Cancel ]

Figure 2 License Agreement window

Step 3 > Read the license agreement. If you agree with the
license agreement, select | accept the terms of the license
agreement.

Step 4 > Click Next.
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The Customer Information window will appear.

Customer Information
Please enter your information.

User Name:

Windows User

Company Name:

ABC Company

Install this application for:

© Anyone who uses this computer (all users)

) Only for me Mwindows User)

[ < Back l[ Next > ][ Cancel ]

Figure 3 Customer Information window

Step 5 > Enter the following customer information:
* User name
« Company name

* Who will be able to use this application (only you, or
anyone who uses the computer)

Step 6 > Click Next.
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The Destination Location window will appear.

Choose Destination Location
Select folder where setup will install files.

Setup will install LABEL ARCHIVE Client 2012 in the following folder.

Ta install to this folder, click Next. To install to a different folder, click Browse and select
another folder.

Destination Folder

£:\Program Files (x86)T eklyrues

[ < Back J[ Next > ][ Cancel J

Figure 4 Destination Location window

Step 7 > Choose the folder where the files will be installed.

In this step, you are able to select which folder the files will
be installed in. The default install folder is C:\Program
Files\Teklynx\LABEL ARCHIVE Client\ and it is
recommended that you do not change it.

Step 8 > Click Next.
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The Select Features window will appear.

Select the features you want to install, and deselect the features you do not want to install.

LABEL ARCHIVE Client [+ Description
=)W LABEL ARCHIVE Client Administration
[WILABEL ARCHIVE Server Snap-in
[VILABEL ARCHIVE Client Snap-in
[WIUMSS-MSGS Client Snap-in

8.24 MB of space required on the C drive
2872.50 MB of space available on the C diive

InstallShield

< Back Next > I Cancel

Figure 5 Select features window

Step 9 > Choose the client components from the list.
In this step, you are able to select components that will
be installed with LA Client. This includes Server, Client

Administration snap-ins and UMSS-MSGS snap-in.

Step 10 > Click Next.
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The LABEL ARCHIVE Server Settings window will
appear.

LABEL ARCHIVE Server Settings
Specify LABEL ARCHIVE Server Settings

Select the address of LABEL ARCHIVE Server:

LaS: (Local)
Select the address of UMSS\MSGS Server:
UMSSAMSGS: [Local) Browse
r IS hield
[ < Back ][ Next > ] [ Cancel

Figure 6 LABEL ARCHIVE Server Settings window
Step 11 > Browse to and select the location of the LABEL
ARCHIVE Server machine to which the client will connect.
Step 12 > Browse to and select the location of the
UMSS\MSGS Server machine to which the user will be

authenticated.

Step 13 > Click Next.
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The Start Installation window will appear.

Ready to Install the Program
The wizard is ready to begin installation.

Click Install to begin the installation.

If you want to review or change any of your installation settings, click Back. Click Cancel to exit
the wizard.

[ < Back ][ Install J[ Cancel }

Figure 7 Start Installation window

Step 14 > If you are sure that the parameters/settings
entered in previous steps are correct, click Install. You have
successfully installed the LABEL ARCHIVE Client.

If you want to review or change any of the installation
settings, click Back to return to the previous screens.
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Uninstallation

To remove the LABEL ARCHIVE Client from your
computer:

Step 1 > Goto Control Panel > Add or Remove Programs.

Step 2 > Select LABEL ARCHIVE Client and click
Change.

Step 3 > In the next window, select the Remove option and
click Next.

‘WwWelcome to the LABEL ARCHIVE Client 2018 Setup Maintenance program. This program lets
you modify the curent installation. Click one of the options below.

®) Modify
Select new program features to add or select curently installed features ta
Temove.

() Fepair

ﬁ Reinztall all program features installed by the previous setup.

() Remaove

@ Femove all installed features.

InztallShield

< Back | Mest > || Cancel |

Figure 8 Repair or Remove the Program window

The uninstallation program will delete the installed
components of LABEL ARCHIVE Client from your
computer.
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LABEL ARCHIVE Client Repair

If the installed LABEL ARCHIVE Client is corrupt, you can
fix it using the Repair mode.

In this mode, the system will redo the installation of LABEL
ARCHIVE Client. The installation settings that you entered
during the last installation will be reused.
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Password Management

Managing Users and Permissions

Predefined User
Profiles

* ADMINISTRATORS

* MANAGERS

LABEL ARCHIVE uses the UMSS subsystem to manage all
users and permissions. At any time, the administrator can
create, modify, or delete users, passwords, and user
groups. For more details about permissions management,
please refer to the LABEL ARCHIVE User guide.

At install time, the system creates predefined user groups.
These groups correspond to typical profiles that a company
may need to use to manage the different user permissions
for all LABEL ARCHIVE business processes.

Five different user groups are available:

Administrators have all rights for LABEL ARCHIVE, and also
on UMSS and MSGS subsystems. Their typical role is to
have full IT responsibility of the entire system.

A default Administrator user is provided. Its initial password
is admin.

Additional users can be created and assigned to the
Administrators group.

Managers’ typical role is to be in charge of the business data
and processes of LABEL ARCHIVE. Managers can define
system settings, create approval workflows, or be required
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* DESIGNERS

* PRINT USERS

to approve documents before delivery in production.

Compared to Administrators, Managers do not have
permission to administrate the database or define
workstation settings. They cannot perform operations like
import DB, export DB, force undo check-out, DB archive, or
manage workstations.

A default Manager user is provided. Its initial password is
empty.

Additional users can be created and assigned to the
Managers group.

Designers’ typical role is to be in charge of the creation and
management of a document or a set of documents.
Designers can create documents, modify documents,
check-in new versions, submit documents for approval, and
participate in approval processes.

Compared to Managers, Designers do not have permission
to modify system settings, create or modify approval
schemes, or modify categories.

A default Designer user is provided. Its initial password is
empty.

Additional users can be created and assigned to the
Designers group.

Print Users’ typical role is to open documents and print them
in production.

Compared to Designers, Print Users do not have permission
to modify documents, and they can only access documents
that are in Final state.

Print Users can use the Runtime version of the label
designer to carry on their activities.

A default PrintUser user is provided. Its initial password is
empty.

Additional users can be created and assigned to the
PrintUser group.
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* CUSTOMERS

In some cases, documents may need to be approved by
Customers before delivery in production.

Customers, therefore, are given minimum access to the
system, including browsing their documents and all related
details, and taking part in an approval workflow.

Customers can use the LABEL ARCHIVE Web module,
through an Internet browser, and receive notifications by
e-mail.

A default Customer user is provided. Its initial password is
empty.

Additional users can be created and assigned to the
Customers group.

predefined groups, users and permissions, except

You can freely modify, customize or delete the
; for the Administrator.

To view all permissions that are granted to a given User,
select the related Group from the “User Groups” node
in UMSS, and click on the Permission tab.

Default Administrator user

LABEL ARCHIVE has predefined Administrator user with
default password admin. This password can be changed in
UMSS Administration later.
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Adding and Configuring Active Directory Users

Active Directory

Active Directory is a special-purposes database used to
store non-dynamic data such as users, groups, and
configuration data. By adding and configuring users in
Active Directory, administrators can now automate LABEL
ARCHIVE login using Windows authentication.

To add and configure an Active Directory User in LABEL
ARCHIVE:

Step 1 > Launch the LABEL ARCHIVE Server.

Step 2 > Login using a known user account, or use the
default user name Administrator and the default password
admin.

Step 3 > In the console tree on the left, select LABEL
ARCHIVE Server Administration > Settings > Functions,
and confirm that the Allow different user connection
option is selected in the Options and Functions area.

This is the default setting.
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Figure 1 Setting LABEL ARCHIVE administrative options

Step 4 > Close the LABEL ARCHIVE Server.

Step 5 > Launch the LABEL ARCHIVE Client.

Step 6 > Log in using a known user account, or use the
default user name Administrator and the default password
admin.

Step 7 > In the console tree on the left, select LABEL
ARCHIVE Client Administrator > Client configuration,
and confirm that the Always prompt login option is not
selected in the Connection area.

This is the default setting.
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Figure 2 Enabing automatic prompts at log in

Step 8 > Close the LABEL ARCHIVE Client.

Step 9 > From the Start menu, select All Programs >
Teklynx > UMSS-MSGS Servers Administration to
launch UMSS.

Step 10 > Log in using a known user account, or use the
default user name Administrator and the default password
admin.

Step 11 > In the console tree on the left, right-click UMSS-
MSGS Servers > UMSS > Users, and then select New >
User.

Step 12 > From the Authentication drop-down menu,
select Windows.
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Step 13 > Clickthe _.. | button.

Step 14 > Click Locations.

Step 15 > From the Locations area, select the domain
network that the user is on, and click OK.

Locations o x|

Select the location you want to search.

Locations:

1 GHOS2126 (local)

SRR bic (Domain)

oK Cancel |
2

Figure 3 Selecting the domain network

Step 16 > Enter the user's last name in the Name field, and
click Find Now.

Step 17 > From the Search results list, select the
appropriate user and click OK.
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Figure 4 Searching for users

Step 18 > Inthe User Properties - New dialog box, select

the User tab and do the following:

* Enter the user's first name in the First name field.

« Enter the user's last name in the Last name field.

« If desired, enter the user's phone, mobile and e-mail

information in the areas provided.

Because the user's passwords are being managed by
the Windows account, the User may change password,
User must change password, and Locked options aren't

available.
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Figure 5 Adding user information

Step 19 > From the Group memberships tab, double-click
to select the groups that the user should belong to, and click
OK.
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Figure 6 Defining group memberships

Step 20 > From the File menu, select Save to save the
MMC (Microsoft Management Console) file.

If prompted to update MMC, click Yes.

Step 21 > Launch CODESOFT.

Step 22 > From the File menu, select LABEL ARCHIVE >
Connect to automatically connect to LABEL ARCHIVE.
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If you launch the LABEL ARCHIVE Client or the LABEL
ARCHIVE Server, you will be prompted to enter a
username and password. To log in without having to
enter them, select the Use Windows Authentication
check box and click OK.

A LABEL ARCHIVE Client administration login (=34
™ Use Windows Authentication
User IManager
Password ™ Change

OK ] Cancel

Figure 7 Enabling Windows authentication
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