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About this Manual

Typographical 
Conventions

This manual distinguishes between different types of
information using the following conventions:

• Terms taken from the interface itself, such as
commands, appear in bold.

• Keys appear in small caps, for example: “Press the
SHIFT key.”

• Numbered lists mean there is a procedure to follow.
• When the conjunction -or- appears next to a

paragraph, it means there is the choice of another
procedure for carrying out a given task.

• When a menu command contains submenus, the
menu name followed by the command to select appear
in bold. Thus, “Go to File > Open” means choose the
File menu, then choose the Open command.

This symbol highlights important information on 
how a particular command or procedure works.

Following this symbol, you will find hints and tips
for optimizing tasks, speeding up commands, and
so on.
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Introduction

Welcome!

Congratulations! You have just acquired a complete and 
secure product solution to store barcode labels, trace the 
history of design modifications and print events, manage 
label versions, and set up approval workflows.

LABEL ARCHIVE Server and Client applications run on your 
company's network in conjunction with CODESOFT, and an 
optional Web module can also be used to provide limited 
access to external users.

The scalability of this product allows you to also install all 
components on your PC, and work in standalone mode like 
a simple desktop application.
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LABEL ARCHIVE Modules

The LABEL ARCHIVE package contains several modules: 
LABEL ARCHIVE Server, LABEL ARCHIVE Client, and the 
LABEL ARCHIVE Web module.

LABEL 
ARCHIVE Server

LABEL ARCHIVE Server is a centralized database driven 
through a Windows® service. It establishes the connection 
with the different data sources, and processes all client 
requests: Check In, Check Out, Print History, Document 
Approval, etc. The Server also uses two subsystems to 
operate: UMSS (User Management System) and MSGS 
(Messaging System). UMSS and MSGS respectively 
perform user configuration and messaging functions.

LABEL 
ARCHIVE Client

The LABEL ARCHIVE Client is the add-in for the Label 
Designer application. When the user invokes LABEL 
ARCHIVE from the Label Designer, this add-in connects to 
the Server and checks user rights. If the connection is 
successful then the user is allowed to perform different 
document management actions such as Check In and 
Check Out, and is given access to the centralized label 
storage database. The actions allowed depend upon the 
security settings and permissions that have been granted to 
the group to which the user belongs. 

LABEL 
ARCHIVE Web 
Module

The LABEL ARCHIVE Web Module is a Web application 
accessible from any Web browser on the Internet or an 
intranet. Upon successful user Web authentication, this 
module establishes a connection with LABEL ARCHIVE 
Server and gives access to limited functions including 
viewing documents and history records, and approving 
documents before delivery in production.

How It Works
LABEL ARCHIVE Server typically runs on a server machine. 
On the internal network, any client station that has a label 
designer and the LABEL ARCHIVE Client add-in can 
interact with the server at any time. All LABEL ARCHIVE 
components can also be installed on a single PC. In that 
case the system works in standalone mode, like a simple 
desktop application.
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Product Description

LABEL ARCHIVE is designed to run on any computer 
running a supported Windows® operating system.

Your product includes the following components:

•  a CD-ROM

•  complete documentation

•  a license agreement

•  an activation code, which allows you to activate the 
license of LABEL ARCHIVE Server on your server 
machine

Note

If you have not purchased an activation code yet, you 
can still use LABEL ARCHIVE for 30 days. During this 
trial period you can install as many clients as you want, 
and the system will accept up to three simultaneous 
connections to the server. After the trial period you will 
need to purchase an activation code. All the work that 
was done during the trial period is kept in the database, 
and you can continue it after activation without any 
disruption.
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LABEL ARCHIVE Server 
Installation

System Requirements

The basic software and hardware requirements needed to 
run the LABEL ARCHIVE Server application are:

•  A PC with Windows Server 2008/2008R2, 
Windows Server 2012/2012R2. 

•  1 GB RAM minimum (2-4 GBs recommended) and 
1 Ghz processor

•  A VGA monitor or better

•  A hard drive with at least 500 MB of free disk space

•  Microsoft® .NET Framework 3.5 SP1

•  Microsoft® Data Access Components (MDAC) 2.8

•  Supported database management systems (DBMS): 
Microsoft® Access, SQL Server 2008/2008 R2/2012 
and Oracle 11 or higher.

Note

Access and SQL Server Express are not recommended 
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for a configuration with multiple clients.

Installation

Before running the installation program, check the 
configuration of your server machine.

LABEL ARCHIVE Server installation requires administration 
rights on the server machine. Please check that all needed 
permissions are granted, both at the operating system level, 
and at the DBMS level, as you will be installing new 
Windows services, copying program files, setting up a Web 
module on Internet Information Services (IIS), and creating 
new databases on your DBMS.

To install LABEL ARCHIVE Server:

Step 1  >  Place the CD-ROM in the appropriate disk drive.

The LABEL ARCHIVE CD window should appear. Select 
LABEL ARCHIVE Server and click Install.

If the CD-ROM does not start up automatically, go to Start 
> My Computer and double-click on the LABEL ARCHIVE 
CD-ROM.

If the CD does not automatically open, go to Windows 
Explorer and locate the CD-ROM drive letter and click on it 
to view its contents. Double-click on the Index.hta (or just 
“Index” if you have file extensions hidden) file located on
the CD.

If you are installing the Web module, and your 
platform does not yet have Microsoft ® IIS 
installed, it is recommended that you install 
Microsoft .NET Framework 3.5 after IIS so that the 
ASP.NET service registration can be done 
automatically.
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The Installation Wizard window will appear.

Figure 1 Installation Wizard window

Step 2  >  Click Next.
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The License Agreement window will appear.

Figure 2 License Agreement window

Step 3  >  Read the license agreement. If you agree with the 
terms of license agreement, select I accept the terms of 
the license agreement.

Step 4  >  Click Next.
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The Destination Location window will appear.

Figure 3 Destination Location window

Step 5  >  Choose the destination folder.

In this step, you are able to select which folder the files will 
be installed in. The default install folder is C:\Program 
Files\Teklynx\ and it is recommended that you do not 
change it.

Step 6  >  Click Next.
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The Select Features window will appear.

Figure 4 Select Features window

By default, the LABEL ARCHIVE Web module is not 
selected. To view and approve labels through a Web 
browser, select LABEL ARCHIVE Web.

Step 7  >  Click Next.
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The Database Type window will appear.  

Figure 5 Database Type window

Step 8  >  Select the database type.

There are three database options to choose from: Access, 
SQL, and Oracle. Based on which option you select, 
perform the following:

SQL: Click Next and continue to Step 9.

Oracle: Click Next and skip to Step 11.

Access: Click Next and skip to Step 20.
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Step 9  >  If you selected SQL:

The SQL Authentication window will appear. 

Figure 6 SQL Authentication window

You will be asked to enter the instance of the desired SQL 
Server. Choose the server from the drop-down menu or 
search for a specific location by clicking Browse. After all 
the fields are filled out, click Next.

During LABEL ARCHIVE Server installation, the wizard 
may display several possible Database Servers. For 
example:

•  (Local)/DB Instance name

•  (Workstation name)/DB Instance name

You must select an item that contains a workstation name 
to ensure a correct connection.

Step 10  >  Click Next.
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Step 11  >  If you selected Oracle:

The Oracle Script Selection window will appear.

Figure 7 Oracle Script Selection window

Step 12  >  Select an installation mode. Depending on which 
option you select, perform the following:

•  Run database script automatically: Click Next and 
continue to Step 13.

•  Run database script manually: Click Next and skip 
to Step 16.
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Step 13  >  If you selected Run database automatically:

The Database Connection Properties window will appear. 

Figure 8 Database Connection Properties window

Step 14  >  You will be prompted to enter the following 
information: 

•  Datasource

•  User ID

•  Password of your Oracle database. 

Step 15  >  Click Next and continue to Step 22. 
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Step 16  >  If you selected Run database script manually:

The Manual Database Information window will appear.

Figure 9 Manual Database Information window

This window displays SQL script text that you can use in 
order to set up an Oracle Database.

Step 17  >  Click Next.
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The Oracle Connection Properties window will appear.  

Figure 10 Oracle Connection Properties window

Step 18  >  Fill out the three fields shown with the following 
information about the created Oracle database:

•  Datasource

•  User ID

•  Password 

Step 19  >  Click Next and continue to Step 20.
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The UMSS and MSGS Servers window will appear.

Figure 11  UMSS and MSMG Servers window

If you are installing TEKLYNX software for the first time, 
select the I want to install a new UMSS-MSGS module 
option and follow the steps in the UMSS-MSGS installation 
wizard.

If you have previously installed TEKLYNX software, you 
may have an existing user management module installed. 
To check, go to Control Panel > Add/Remove Programs. 
If UMSS-MSGS appears in the program list, select the I 
want to connect LABEL ARCHIVE to an existing 
UMSS-MSGS module in my company’s network option.

Step 20  >  Click Next.
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The Web Site Settings window will appear.

Figure 12 Web Site Settings window

Step 21  >  Select the Web site on which you want to run the 
LABEL ARCHIVE Web module.
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Step 22  >  Click Next.

The Virtual Directory Settings window will appear.

Figure 13 Virtual Directory Settings window

Step 23  >  Enter the name of the Web site’s virtual 
directory.
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Step 24  >  Click Next.

The Ready to Install window will appear.

Figure 14 Ready to Install window

Step 25  >  Finish the installation by clicking Install. 

You have successfully installed the LABEL ARCHIVE 
Server module.

Software License 
Activation

You can use LABEL ARCHIVE in trial mode for 30 days. 
After that period the server is blocked. Any connection 
attempt results in an error message “Maximum number of 
connections reached,” and if you stop the LABEL ARCHIVE 
Windows service, you will not be able to restart it again. To 
continue to use the software you must activate the license. 

To activate the software license:

Step 1  >  Launch the Activation Wizard from C:\Program
Files\Teklynx\Label Archive Server\UpgradeWizard.exe. A
wizard is displayed.

Step 2  >  Choose Activate and follow the wizard screens. 
You will need to enter the serial number and password that 
was provided to you when you purchased the software.
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Note

If you activate the license once the trial period is 
expired, you will need to reboot the LABEL ARCHIVE 
Server computer.

LABEL ARCHIVE 
Web Module 
Configuration

After installing the LABEL ARCHIVE Web module, you 
should verify the Web site settings:

Step 1  >  Go to Control Panel > Administrative Tools >
Internet Information Services.

Step 2  >  In the navigation frame on the left, navigate to the 
Web virtual directory folder (i.e., (local computer)\Web 
Sites\Default Web Site\LAS).

Step 3  >  Right-click on the Web virtual directory folder (i.e., 
the LAS folder) and select Properties.

Step 4  >  Click on the ASP.NET tab.

Step 5  >  Verify that the ASP.NET version is set to 
2.0.50727.
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Figure 15 Web Site Properties window
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Uninstallation

To remove the different server components from your 
computer:

Step 1 > Go to Control Panel > Add or Remove Programs.

Step 2  >  Select LABEL ARCHIVE Server and click on 
Change/Remove.

Step 3  >  In the next window, select the Remove option and 
click Next.

Figure 16 Modify, Repair, or Remove the Program window

The uninstallation program will delete the installed 
components from your computer and optionally the 
databases if specified. You will be asked whether you want 
to also remove the UMSS-MSGS module.  Please note that 
the UMSS-MSGS module is also used for other TEKLYNX 
products.



Chapter 2 - 23 Administrator’s Guide

LABEL ARCHIVE Repair

If the installed LABEL ARCHIVE Server components proved 
to be corrupted, you can fix them using the Repair mode 
(see Figure 12).

In this mode, the setup application will reprocess the 
installation of the different components. The installation 
settings that you entered during the last installation will be 
reused.

SQL Database: In this mode, the structure of SQL 
Database will be repaired (for example, if your SQL 
database structure was corrupted). 

Oracle Database: In this mode, the structure of Oracle 
Database will be repaired (for example, if your Oracle 
database structure was corrupted). 

Access Database: In this mode, the Access Database will 
be overwritten, but before starting the repair process, the 
setup will propose to create backup-files for your databases, 
and after the repair you will be able to replace the database.

LABEL ARCHIVE Modification (Add/Remove 
Features)

If you want to add components which were not previously 
installed, you can use the Modify mode (see Figure 12). In 
this mode, the setup application will propose to select the 
components to be installed.
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Figure 17 Select Features window

Special Notes

•  The administration user interfaces LABEL ARCHIVE 
Server and Client are created using the MMC 
(Microsoft Management Console) snap-in, so they 
can be manipulated like any standard MMC 
component in Windows.

•  Full SQL Server is required to install the database on 
a computer that is different from the one that hosts 
the LABEL ARCHIVE Server processes and 
services.

•  Remote SQL Server running on Windows 2000 
should have Service Pack 4 installed. 

•  If you install LABEL ARCHIVE with the Access 
database, the database is protected by a password, 
initially set to tkllas. To replace it with a new 
password, edit the TkxArv.server.config file. This 
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file is located in the installation directory. Once the 
file is opened, type the new password in the 
following xml section:

<configuration>, then <TkxArv.DataAdapters>, 
<DataAdapter name="oledb"....Password=  
newpassword>. Then stop/start the Label Archive 
Server Windows service.

•  For SQL Server 2005, make sure that remote 
connections are allowed (disallowed by default).

•  If you have a firewall, you must unblock ports 8088 
and 8989.

•  LABEL ARCHIVE Server Windows service: The 
Server program is run through a Windows service 
named LABEL ARCHIVE Server, which is configured 
by default to start automatically. The service has a 
dependency link with the UMSS/MSGS Windows 
service, named TkxSvr Servers service. You can 
start and stop Windows services manually by using 
the standard Windows administration tool.

Before doing administration work on LABEL 
ARCHIVE Server (i.e., changing parameters and 
options, importing/exporting data, etc.), it is highly 
recommended to first ensure that all clients are 
disconnected. If you change some settings, you 
may then want to stop and restart the LABEL 
ARCHIVE Server Windows service for all changes 
to be effective.
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LABEL ARCHIVE Client 
Installation

System Requirements

The basic software and hardware requirements needed to 
run the LABEL ARCHIVE Client application are:

•  A PC with Windows Vista SP2, Windows 7 SP1, 
Windows 8 and Windows 8.1

•  1 GB RAM minimum (2-4 GBs recommended) and 
1 Ghz processor

•  A VGA monitor or better

•  A hard drive with at least 500 MB of free disk space

•  Microsoft .NET Framework 3.5 SP1

•  TEKLYNX CODESOFT
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Installation

Before running the installation program, check the 
configuration of your PC.

To install LABEL ARCHIVE Client:

Step 1  >  Place the CD-ROM in the appropriate disk drive.

The LABEL ARCHIVE CD window should appear. Select 
LABEL ARCHIVE Client and click Install.

If the CD-ROM does not start up automatically, go to Start 
> My Computer and double-click on the LABEL ARCHIVE 
CD-ROM.

If the CD does not automatically open, go to Windows 
Explorer and locate the CD-ROM drive letter and click on it 
to view its contents. Double-click on the Index.hta (or just 
“Index” if you have file extensions hidden) file located on
the CD.

The Installation Wizard window will appear.

Figure 1 Installation Wizard window
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Step 2  >  Click Next.

The License Agreement window will appear.

Figure 2 License Agreement window

Step 3  >  Read the license agreement. If you agree with the 
license agreement, select I accept the terms of the license 
agreement.

Step 4  >  Click Next.
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The Customer Information window will appear.

Figure 3 Customer Information window

Step 5  >  Enter the following customer information:

•  User name

•  Company name

•  Who will be able to use this application (only you, or 
anyone who uses the computer)

Step 6  >  Click Next.
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The Destination Location window will appear.

Figure 4 Destination Location window

Step 7  >  Choose the folder where the files will be installed.

In this step, you are able to select which folder the files will 
be installed in. The default install folder is C:\Program 
Files\Teklynx\LABEL ARCHIVE Client\ and it is 
recommended that you do not change it.

Step 8  >  Click Next.
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The LABEL ARCHIVE Server Settings window will 
appear.

Figure 5 LABEL ARCHIVE Server Settings window

Step 9  >  Browse to and select the location of the LABEL 
ARCHIVE Server machine to which the client will connect.

Step 10  >  Browse to and select the location of the 
UMSS\MSGS Server machine to which the user will be 
authenticated.

Step 11  >  Click Next.
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The Start Installation window will appear.

Figure 6 Start Installation window

Step 12  >  If you are sure that the parameters/settings 
entered in previous steps are correct, click Install. You have 
successfully installed the LABEL ARCHIVE Client.

If you want to review or change any of the installation 
settings, click Back to return to the previous screens.
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Uninstallation

To remove the LABEL ARCHIVE Client from your 
computer:

Step 1 > Go to Control Panel > Add or Remove Programs.

Step 2  >  Select LABEL ARCHIVE Client and click  
Change/Remove.

Step 3  >  In the next window, select the Remove option and 
click Next.

Figure 7 Repair or Remove the Program window

The uninstallation program will delete the installed 
components of LABEL ARCHIVE Client from your 
computer.
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LABEL ARCHIVE Client Repair

If the installed LABEL ARCHIVE Client is corrupt, you can 
fix it using the Repair mode.

In this mode, the system will redo the installation of LABEL 
ARCHIVE Client. The installation settings that you entered 
during the last installation will be reused.
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LABEL ARCHIVE User and 
Password Management

Managing Users and Permissions

LABEL ARCHIVE uses the UMSS subsystem to manage all 
users and permissions. At any time, the administrator can 
create, modify, or delete users, passwords, and user 
groups. For more details about permissions management, 
please refer to the LABEL ARCHIVE User guide.

Predefined User 
Profiles

At install time, the system creates predefined user groups. 
These groups correspond to typical profiles that a company 
may need to use to manage the different user permissions   
for all LABEL ARCHIVE business processes.

Five different user groups are available:

• ADMINISTRATORS Administrators have all rights for LABEL ARCHIVE, and also 
on UMSS and MSGS subsystems. Their typical role is to 
have full IT responsibility of the entire system. 

A default Administrator user is provided. Its initial password 
is admin. 

Additional users can be created and assigned to the 
Administrators group.

• MANAGERS Managers’ typical role is to be in charge of the business data 
and processes of LABEL ARCHIVE. Managers can define 
system settings, create approval workflows, or be required 
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to approve documents before delivery in production.

Compared to Administrators, Managers do not have 
permission to administrate the database or define 
workstation settings. They cannot perform operations like 
import DB, export DB, force undo check-out, DB archive, or 
manage workstations.

A default Manager user is provided. Its initial password is 
empty.

Additional users can be created and assigned to the 
Managers group.

• DESIGNERS Designers’ typical role is to be in charge of the creation and 
management of a document or a set of documents. 
Designers can create documents, modify documents, 
check-in new versions, submit documents for approval, and 
participate in approval processes.

Compared to Managers, Designers do not have permission 
to modify system settings, create or modify approval 
schemes, or modify categories.

A default Designer user is provided. Its initial password is 
empty.

Additional users can be created and assigned to the 
Designers group.

• PRINT USERS Print Users’ typical role is to open documents and print them 
in production.

Compared to Designers, Print Users do not have permission 
to modify documents, and they can only access documents 
that are in Final state.

Print Users can use the Runtime version of the label 
designer to carry on their activities.

A default PrintUser user is provided. Its initial password is 
empty.

Additional users can be created and assigned to the 
PrintUser group.
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• CUSTOMERS In some cases, documents may need to be approved by 
Customers before delivery in production.

Customers, therefore, are given minimum access to the 
system, including browsing their documents and all related 
details, and taking part in an approval workflow.

Customers can use the LABEL ARCHIVE Web module, 
through an Internet browser, and receive notifications by 
e-mail.

A default Customer user is provided. Its initial password is 
empty.

Additional users can be created and assigned to the 
Customers group.

Note

To view all permissions that are granted to a given User, 
select the related Group from the “User Groups” node 
in UMSS, and click on the Permission tab.

Changing the Administrator Password

The predefined Administrator user is also used by the 
LABEL ARCHIVE system itself.

Its initial password is admin. If you change this password, 
you will also need to manually change the configuration file 
of LABEL ARCHIVE Server.

You can freely modify, customize or delete the 
predefined groups, users and permissions, except 
for the Administrator.

After such an operation, if you do not update the 
LABEL ARCHIVE Server configuration file 
accordingly, the system will not work properly.
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How to Update 
the Config File

The configuration file to be updated is called 
TkxArv.server.config. It is located in the installation 
directory.

Once you have opened TkxArv.server.config, go to the 
following xml section: <configuration>, then <tkxsvr>, 
<clients>, <umss>, <client>.

You will find the <logonconfig> tag, which has the following 
elements: defaultusername (Administrator), and 
defaultpasswordhash, (hash for 'admin' password).

Replace the old password hash value with the new 
password hash value.

The password hash value is stored in the UMSS ‘USERS’ 
database table, within the ‘PASSWORDHASH’ field.

Once the replacement is done (using copy/paste), you must 
restart the LABEL ARCHIVE Server Windows service.

Note

Through proper management of security and access
rights on the databases and the server system, you can
ensure that only authorized users can perform such
operations.

Note

You can also create additional users and give them
administrator rights, by assigning them to the
Administrators group.
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Adding and Configuring Active Directory Users

Active Directory Active Directory is a special-purposes database used to 
store non-dynamic data such as users, groups, and 
configuration data. By adding and configuring users in 
Active Directory, administrators can now automate LABEL 
ARCHIVE login using Windows authentication.

To add and configure an Active Directory User in LABEL 
ARCHIVE:

Step 1  >  Launch the LABEL ARCHIVE Server.

Step 2  >  Log in using a known user account, or use the 
default user name Administrator and the default password 
admin.

Step 3  >  In the console tree on the left, select LABEL 
ARCHIVE Server Administration > Settings > Functions, 
and confirm that the Allow different user connection 
option is selected in the Options and Functions area.

Note

This is the default setting.
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Figure 1 Setting LABEL ARCHIVE administrative options

Step 4  >  Close the LABEL ARCHIVE Server.

Step 5  >  Launch the LABEL ARCHIVE Client.

Step 6  >  Log in using a known user account, or use the 
default user name Administrator and the default password 
admin.

Step 7  >  In the console tree on the left, select LABEL 
ARCHIVE Client Administrator > Client configuration, 
and confirm that the Always prompt login option is not 
selected in the Connection area.

Note

This is the default setting.
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Figure 2 Enabing automatic prompts at log in

Step 8  >  Close the LABEL ARCHIVE Client.

Step 9  >  From the Start menu, select All Programs > 
Teklynx > UMSS-MSGS Servers Administration to 
launch UMSS.

Step 10  >  Log in using a known user account, or use the 
default user name Administrator and the default password 
admin.

Step 11  >  In the console tree on the left, right-click UMSS-
MSGS Servers > UMSS > Users, and then select New > 
User.

Step 12  >  From the Authentication drop-down menu, 
select Windows.
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Step 13  >  Click the  button.

Step 14  >  Click Locations.

Step 15  >  From the Locations area, select the domain 
network that the user is on, and click OK.

Figure 3 Selecting the domain network

Step 16  >  Enter the user's last name in the Name field, and 
click Find Now.

Step 17  >  From the Search results list, select the 
appropriate user and click OK.
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Figure 4 Searching for users

Step 18  >  In the User Properties - New dialog box, select 
the User tab and do the following:

•  Enter the user's first name in the First name field.

•  Enter the user's last name in the Last name field.

•  If desired, enter the user's phone, mobile and e-mail 
information in the areas provided. 

Note

Because the user's passwords are being managed by 
the Windows account, the User may change password, 
User must change password, and Locked options aren't 
available.
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Figure 5 Adding user information

Step 19  >  From the Group memberships tab, double-click 
to select the groups that the user should belong to, and click 
OK. 
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Figure 6 Defining group memberships

Step 20  >  From the File menu, select Save to save the 
MMC (Microsoft Management Console) file.

If prompted to update MMC, click Yes.

Step 21  >  Launch CODESOFT.

Step 22  >  From the File menu, select LABEL ARCHIVE > 
Connect to automatically connect to LABEL ARCHIVE.
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Note

If you launch the LABEL ARCHIVE Client or the LABEL 
ARCHIVE Server, you will be prompted to enter a 
username and password. To log in without having to 
enter them, select the Use Windows Authentication 
check box and click OK.

Figure 7 Enabling Windows authentication
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