The information in this manual is not binding and may be modified without prior notice.

Supply of the software described in this manual is subject to a user license. The software may not be used, copied or reproduced on any medium whatsoever, except in accordance with this license.

No portion of this manual may be copied, reproduced or transmitted by any means whatsoever, for purposes other than the personal use of the buyer, unless written permission is obtained from Braton Groupe sarl.

© 2003 Braton Groupe sarl. All rights reserved.

TEKLYNX and its products are trademarks or registered trademarks of Braton Groupe sarl or its affiliated companies. All other brands and product names are the trademarks of their respective owners.

Rev – 12/03
Table of Contents

About this Manual ......................................................... iii

Chapter 1: Introduction ................................................. 1-1
Welcome! ............................................................. 1-1
System Requirements .................................................. 1-1
Product Components .................................................. 1-2
Software Security Key ............................................... 1-2
Single User Installation ............................................. 1-3
Network Installation .................................................. 1-3
Viewing the Readme File ............................................ 1-4
Registering Your Software .......................................... 1-5
Technical Support .................................................... 1-5
Help ................................................................. 1-5

Chapter 2: Getting Started ............................................. 2-1
Starting the Program .................................................. 2-1
Exploring the Main Window ........................................ 2-1
  Menu Bar ......................................................... 2-1
  Style Bar ......................................................... 2-2
  Server Bar ....................................................... 2-3
  Drawtools Bar ................................................... 2-3
  Float Bar ......................................................... 2-5
  Status Bar ....................................................... 2-6
  Rulers ........................................................... 2-6
  Rotation Button ............................................... 2-6
  Design Area Display Settings ................................ 2-6
Printer Setup ......................................................... 2-7
  Installing a Thermal/Thermal Transfer Printer .............. 2-7
  Selecting a Printer ............................................. 2-9
  Removing a Printer ............................................. 2-9

Chapter 3: Designing Labels .......................................... 3-1
Creating a New Label ................................................ 3-1
Opening an Existing Label ........................................ 3-2
Adding Objects to the Label ....................................... 3-3
  Adding Text .................................................... 3-3
  Adding a Paragraph ........................................... 3-5
  Adding a Bar Code ............................................ 3-8
  Adding a 2D Bar Code ........................................ 3-10
  Adding a Picture .............................................. 3-11
Quick Start Guide

Adding an OLE Object ............................................. 3-13
Adding a Box ...................................................... 3-14
Adding a Line ....................................................... 3-14
Adding a Shape ..................................................... 3-15
Working with Placed Objects ..................................... 3-16
  Moving an Object on the Label ................................. 3-16
  Sizing an Object on the Label ................................ 3-16
For More Information on Designing Labels ..................... 3-16

Chapter 4: Data Sources ........................................... 4-1

What is a Data Source? ............................................. 4-1
Types of Data Sources ............................................ 4-2

Chapter 5: Creating Your First Label ............................. 5-1

Introduction ......................................................... 5-1
Designing a Product Label (Basic) ............................... 5-1
  Selecting a Printer ............................................... 5-2
  Label Setup ....................................................... 5-3
  Adding Text ....................................................... 5-4
  Adding a Line ..................................................... 5-6
  Positioning Objects on the Label ............................. 5-6
  Adding a Picture ................................................ 5-6
  Adding a Pick List Field ...................................... 5-8
  Adding a Bar Code .............................................. 5-11
  Adding a Date Stamp .......................................... 5-12
  Printing the Label .............................................. 5-13
Designing an Inventory Label (Advanced) ....................... 5-14
  Adding a dBase Text Field .................................... 5-15
  Adding a Hidden Field ....................................... 5-18
  Adding Lines ..................................................... 5-19
  Adding a Serial Number ..................................... 5-20
  Adding Linked Fields ....................................... 5-21
  Adding a dBase Picture Field ............................... 5-23
  Positioning Objects on the Label .......................... 5-24
  Printing the Label ............................................ 5-25

Index ................................................................. I-1
About this Manual

This manual is designed to provide you with the basic information you need to install the software, set up a printer and design a label. More in-depth information on these topics and other more advanced topics can be found in the online Help.

Typographical Conventions

This manual uses the following conventions to distinguish between different types of information:

- Terms taken from the interface itself, such as menu names, commands, and button names appear in **bold**.
- Keys appear in uppercase, as in the following example:
  “Press the SHIFT key.”
- Numbered lists indicate a procedure to follow.
- The sequence for selecting a command from a menu will be described, but a button is also available for many functions.
- Angle brackets `< >` indicate system setup information that must be entered by keyboard. Enter only the information, not the brackets.

About Your Software

Depending on the edition of the software you are using, different features are available. Although all features are described in this manual, they may not be available in your edition of the software.
Introduction

Welcome!

Congratulations on your purchase of this label design software. The wide range of features in the software allows you to create virtually any label and print to any of more than 1000 printers. Text, one- and two-dimensional bar codes, graphics, shapes and other objects are easy to add through the intuitive user interface.

System Requirements

The basic software and hardware requirements needed to run the label design software are similar to those of most applications running on Microsoft Windows:

- IBM-compatible PC, 486 or better
- Microsoft Windows 95, Windows 98, Windows Me, Windows NT 4.0, Windows 2000 or Windows XP
- 16 MB RAM with Windows 95 (32 MB recommended)
- 32 MB RAM with Windows 98 or Windows Me (64 MB recommended)
- 64 MB RAM with Windows NT 4.0, Windows 2000 or Windows XP (128 MB recommended)
- VGA monitor or better
- Hard drive with at least 50 MB free disk space
- CD-ROM drive
### Product Components

Your label design software is packaged with the following components:

- CD-ROM
- Documentation appropriate to the version you purchased
- A license agreement and registration card
- Software security key

### Software Security Key

The software includes a security key that must be installed on a PC to run the software. The security key is a small device that contains information about the software version and the number of users that are authorized to run the label design software.

The software security key is easy to use — simply connect it to your parallel port or USB port before launching the software. If a printer will be attached to the same port, connect the printer cable to the security key. The printer may need to be powered on before the key is recognized.

![Parallel port/DB25 female connector](image)

**Figure 1-1** Connecting the security key to the parallel port

![USB Key](image)

**Figure 1-2** Connecting the security key to the USB port
Without the software security key, the program will run as a Demo version and will place a demo message on all labels printed with the software.

**Single User Installation**

1. Attach the software security key as directed in the *Software Security Key* section on page 1-2.

2. Insert the CD.

   The CD’s opening screen will appear. (If the CD does not automatically open, on the taskbar, click the **Start** button, and then click **Run**. Type the letter of the CD-ROM drive followed by **CDSetup.exe** (e.g., `D:\CDSetup.exe`).

3. On the opening screen of the CD, select the product to install and then click the **Run/Install** button.

4. Follow the instructions displayed on the screen to select and install the software.

**Network Installation**

Follow the guidelines below when installing a multi-user/network version of the label design software:

- The label design software must be installed on a server along with the License Manager application. Any workstation that will run the label design software must also have the software installed locally.

- The security key must be attached to the server. Only one security key is included with a network version of the software, pre-programmed with the number of licenses purchased.

- The software directory must be shared and mapped allowing full read/write access to all potential users. This is necessary for the network License Manager.

**Note**

The License Manager application is not compatible with Novell systems, so Novell network users must designate a Windows workstation to be the key server.
To install a network/multi-user version of the label design software:

1. Select one computer on the network to act as the key server. It can be the network file server, or any of the workstations. Install the label design software and the security key on this machine to load the necessary files. This machine must be running in order for the users to access the label design software.

2. Run the LVLICENSEMANAGER.EXE application found in the program’s root directory. This file is needed only on the machine that has the key attached. The License Manager application allows many users to access the label design software at the same time, from anywhere on the network. When users are logged onto the program, their user names will appear in the License Manager window, so administrators can keep track of who is using the program.

3. Install the software on each workstation where the label design software will be used. Through Windows, map the network drive where the label design software is installed. Refer to your Windows documentation or ask your system administrator for the necessary instructions.

4. For each installation, run the label design software, select Configuration from the Options menu, and then click on the Network tab. Check the Network Key box, and use the ... button or Auto Find... button to specify the location of the SYSTEM\LICENSE directory, found on the mapped drive established in step 3.

5. Shut down and restart the label design software to complete the network installation.

Viewing the Readme File

The Readme.txt file delivered and installed with the software contains information about the most recent changes and updates to the label design software that were made after this manual was printed. This information supersedes what is contained in this manual.
Registering Your Software

Registering your software makes you eligible for technical support from your supplier and pre-release information on new products and enhancements. To register your software, fill out the registration card included in the product package and return it to the address provided.

Technical Support

Online support is available free of charge at www.teklynx.com under SERVICE & SUPPORT. For phone support, please contact your label design software supplier.

Help

Complete documentation is available through the online Help. Press F1 to display the Help contents at any time or select Help from the program’s Help menu. Context-sensitive Help is available from within many dialog boxes by clicking the Help button.
Getting Started

This chapter is designed to familiarize you with the main features of the user interface, help you configure the interface to meet your needs, and set up a printer in preparation for printing labels.

Starting the Program

1. On the Windows taskbar, click the Start button, and then point to Programs.
2. Locate the label design software group in the list of available programs and point to it using your mouse.
3. Click on the label design software listing to launch it.

Exploring the Main Window

This section presents a general overview of the main interface elements as they appear in the main label design window.

Menu Bar

The Menu Bar is composed of eight command menus: File, Edit, Draw, View, Tools, Options, Server, and Help.

To open a menu:

1. Using the mouse, click on the menu name to display its list of commands.
2. Click the desired command.
The **Style Bar** contains a variety of tool buttons that are used to open and save labels, print labels and control other label design display and setup properties. Many of the Style Bar functions are also available from the **File** menu.

<table>
<thead>
<tr>
<th>Button</th>
<th>Tool Name</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="folder" /></td>
<td>New</td>
<td>Create a new, blank label.</td>
</tr>
<tr>
<td><img src="image" alt="folder" /></td>
<td>Open</td>
<td>Open an existing label design file.</td>
</tr>
<tr>
<td><img src="image" alt="folder" /></td>
<td>Save</td>
<td>Save changes made to the currently open label.</td>
</tr>
<tr>
<td><img src="image" alt="printer" /></td>
<td>Print</td>
<td>Print the currently open label design.</td>
</tr>
<tr>
<td><img src="image" alt="grid" /></td>
<td>Snap to Grid</td>
<td>Enable the label design grid that forces objects to line up according to the grid settings.</td>
</tr>
<tr>
<td><img src="image" alt="zoom_in" /></td>
<td>Zoom In</td>
<td>Increase magnification, making it easier to view small objects on the label.</td>
</tr>
<tr>
<td><img src="image" alt="zoom_out" /></td>
<td>Zoom Out</td>
<td>Decrease magnification, allowing a larger portion of the label to be viewed.</td>
</tr>
<tr>
<td><img src="image" alt="name" /></td>
<td>Name Mode</td>
<td>Display fields using their field names.</td>
</tr>
<tr>
<td><img src="image" alt="xxx" /></td>
<td>XXX Mode</td>
<td>Display the maximum length of a field (using Xs).</td>
</tr>
<tr>
<td><img src="image" alt="value" /></td>
<td>Value Mode</td>
<td>Display the value of a field (or a sample value for database fields).</td>
</tr>
<tr>
<td><img src="image" alt="help" /></td>
<td>Help</td>
<td>Access the online Help.</td>
</tr>
</tbody>
</table>
**Server Bar**

The **Server Bar** contains tool buttons that activate several advanced data integration features available in this label design software. The Server Bar functions are also available from the **Server** menu.

<table>
<thead>
<tr>
<th>Button</th>
<th>Tool Name</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image1" alt="icon" /></td>
<td>DataWatch Server</td>
<td>Monitor a linked database for additions. When it detects new records, it launches printing.</td>
</tr>
<tr>
<td><img src="image2" alt="icon" /></td>
<td>DDE Server</td>
<td>Import data from an outside source for use in your labels.</td>
</tr>
<tr>
<td><img src="image3" alt="icon" /></td>
<td>Command File</td>
<td>Execute command files for automatic label printing.</td>
</tr>
<tr>
<td><img src="image4" alt="icon" /></td>
<td>Label Select</td>
<td>Print various label formats to different printers based on a database key field.</td>
</tr>
</tbody>
</table>

**Drawtools Bar**

The **Drawtools Bar** allows you to add text, bar codes, pictures and other objects to your label design. The Drawtools Bar functions are also available from the **Draw** menu.

<table>
<thead>
<tr>
<th>Button</th>
<th>Tool Name</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image5" alt="icon" /></td>
<td>Add Text</td>
<td>Add a text field.</td>
</tr>
<tr>
<td><img src="image6" alt="icon" /></td>
<td>Add Paragraph</td>
<td>Add a paragraph field.</td>
</tr>
<tr>
<td><img src="image7" alt="icon" /></td>
<td>Add Bar Code</td>
<td>Add a bar code field.</td>
</tr>
</tbody>
</table>
(Table continued from previous page)

<table>
<thead>
<tr>
<th>Button</th>
<th>Tool Name</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Add 2D Bar Code" /></td>
<td>Add 2D Bar Code</td>
<td>Add a 2D bar code field.</td>
</tr>
<tr>
<td><img src="image" alt="Add Picture" /></td>
<td>Add Picture</td>
<td>Add a picture field.</td>
</tr>
<tr>
<td><img src="image" alt="Add OLE Object" /></td>
<td>Add OLE Object</td>
<td>Create a new OLE object or select an existing file to place in the label.</td>
</tr>
<tr>
<td><img src="image" alt="Add Box" /></td>
<td>Add Box</td>
<td>Add a box or rectangle.</td>
</tr>
<tr>
<td><img src="image" alt="Add Line" /></td>
<td>Add Line</td>
<td>Add a line.</td>
</tr>
<tr>
<td><img src="image" alt="Add Shape" /></td>
<td>Add Shape</td>
<td>Select from several categories of shapes, signs and symbols commonly used on label designs.</td>
</tr>
</tbody>
</table>
**Float Bar**

The **Float Bar**, if enabled, appears when you select an object or objects on the current label. The Float Bar tool buttons are used to position objects on the label in relation to each other. The Float Bar functions are also available from the **View** menu.

<table>
<thead>
<tr>
<th>Button</th>
<th>Tool Name</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Button" /></td>
<td><strong>Align Left</strong></td>
<td>Align selected objects with the left edge of the left-most object selected.</td>
</tr>
<tr>
<td><img src="image" alt="Button" /></td>
<td><strong>Align Right</strong></td>
<td>Align selected objects with the right edge of the right-most object selected.</td>
</tr>
<tr>
<td><img src="image" alt="Button" /></td>
<td><strong>Align Top</strong></td>
<td>Align selected objects with the top edge of the top-most object selected.</td>
</tr>
<tr>
<td><img src="image" alt="Button" /></td>
<td><strong>Align Bottom</strong></td>
<td>Align selected objects with the bottom edge of the bottom-most object selected.</td>
</tr>
<tr>
<td><img src="image" alt="Button" /></td>
<td><strong>Center Vertically</strong></td>
<td>Center selected objects vertically.</td>
</tr>
<tr>
<td><img src="image" alt="Button" /></td>
<td><strong>Center Horizontally</strong></td>
<td>Center selected objects horizontally.</td>
</tr>
<tr>
<td><img src="image" alt="Button" /></td>
<td><strong>Equal Space Vertically</strong></td>
<td>Equally space selected objects vertically.</td>
</tr>
<tr>
<td><img src="image" alt="Button" /></td>
<td><strong>Equal Space Horizontally</strong></td>
<td>Equally space selected objects horizontally.</td>
</tr>
</tbody>
</table>
Status Bar

The **Status Bar** is located at the bottom of the design screen. The left side of the Status Bar serves as a message area that gives instructions and information as to what you are expected to do next. Other informational status indicators displayed from left to right include the name of the selected printer, the communication port to which it is connected, and the coordinates of the current cursor position.

![Figure 2-1 The Status Bar](image)

Rulers

Two **Rulers** (at the left and top of design area) help you to position fields on the label. Rulers appear in the currently selected units of measure (inches or millimeters).

Rotation Button

The **Rotation Button** is located in the top-left corner of the design area, where the two rulers meet. When designing a label that prints sideways, the Rotation Button allows you to rotate the view of the label so you can more easily design the label in a normal view. You can rotate the view 0, 90, 180, or 270 degrees relative to the print orientation. This affects only the display of the label, not printing.

Design Area Display Settings

The **Display** tab enables you to change program settings to customize your label design environment. Settings included on this tab include language selection, units of measure, display of the grid, ruler colors, etc.

- **To change the display settings:**
  
  1. On the **Options** menu, click **Configuration**, and then click the **Display** tab.
  
  2. Configure the display settings as appropriate for your label design application.
Printer Setup

This program supports hundreds of specialized thermal and thermal transfer label printers and any printer with a valid Windows driver supplied by the manufacturer. Printer drivers included with this label design software are installed to the program's **Drivers** directory when the program is installed.

For optimum results when designing and printing labels in this label design software, use one of the high speed printer drivers installed with the program.

**Installing a Thermal/Thermal Transfer Printer**

1. On the **File** menu, click **Select Printer**, and then click **Install**.
2. Using the **Available Printer Drivers** lists, select your printer's manufacturer and model.

![Figure 2-2 Install Printer Drivers](image)
The printer models appearing in the list depend on the check box settings below it. Depending on the printer you are using, there may be several driver choices available in the software. You may want to try all of the drivers available for your particular printer model and determine which one works best for your label printing needs.

Some printers include both a native driver and an extended driver for the same printer model, designated in the program as follows:

\((V)\) = Driver is a native software driver (developed specifically for use with this label design software).

\((X)\) = Driver is from an extended driver set.

**Note**

If you plan to print labels from a PRINTPAD CE or Pocket PC device, you must select a native \((V)\) driver.

3 With the desired printer selected, click **Install**.

The printer driver appears highlighted in the **Installed Printers** list.

4 Click **Connect** and select the port to use for printing. Adjust the settings, if necessary, according to your printer documentation.

If the printer is connected to a serial port, click the **Setting** button to configure the driver to match the printer device settings (baud rate, data bits, stop bits, parity, flow control). The printer and the computer MUST be set to exactly the same values. Check your printer documentation for the correct settings.

5 Click **OK**, **Close**, and **OK** to return to the design window.

The selected printer appears in the Status bar.

**Note**

Printer device settings—such as print speed, paper feed mode, and cutter options—are defined during label setup from the **Options** tab.
Selecting a Printer

1. On the File menu, click **Select Printer**.

2. Click the Printer drop-down arrow to display a list of installed printers.

   If you previously installed a thermal/thermal transfer printer driver for use with this label design program, your printer should appear in the list of installed printers.

3. Select the appropriate printer and click **OK**.

**Note**

If your label was designed for a different printer, a message will appear asking if you want to modify the label. Click **Yes** to convert the label to work with the currently selected printer. The changes made for the conversion will not be permanent until you save the label. You may need to do some fine-tuning if the label conversion is not exact, so be sure to print a test label before you commit to a large print run.

Removing a Printer

1. On the File menu, click **Select Printer**, and then click **Install**.

2. In the **Installed Printers** list, click on the printer you want to remove.

3. Click **Yes** to confirm that you want to remove the selected printer, and then click **Remove**.

4. Click **Close** and then click **OK** to return to the design window.
Designing Labels

Creating a New Label

1. Do one of the following:
   - On the File menu, click New.
   - Click New on the Style Bar.

The Label Setup tabs appear.

![Label Setup Tabs](image)

*Figure 3-1 Label Setup Tabs*
2 On the **Label Setup** tab, set the label width, height, margins, and other general label settings.

3 Click the **Options** tab and set up printer options for the label.

**Note**
The printer settings on the **Options** tab control the physical properties of the printer that you are using. Not all options are available for all printers.

4 If you want to set up security for the label, click the **Password** tab and set the appropriate password protection settings.

5 If you want to assign a description to the label, click the **Label Description** tab and enter the description text.

6 Click **OK** to save your label setup.

**Opening an Existing Label**

1 Do one of the following:
   - On the **File** menu, click **Open**.
   - Click **Open** on the **Style Bar**.

The **Open** dialog box appears.

![Figure 3-2 Open an Existing Label](image-url)
2 Click the **preview** check box if you want to view a preview of each label file as you click on it.

If a preview does not appear for a label file, click **Build Missing Preview Files** to generate new label previews for all files in the current directory.

3 Locate the desired label file and double-click on it to open it in the label design software.

**Note**

If the label was originally created for a printer other than the one currently selected, you will be asked if you want to convert the label for the new printer. Click **Yes** to convert the label to work with the currently selected printer. The changes made for the conversion will not be permanent until you save the label. If **No** is chosen, the label will not open.

### Adding Objects to the Label

#### Adding Text

1 Do one of the following:
   - On the **Draw** menu, click **Text**.
   - Click **Add Text** on the **Drawtools Bar**.

   The **Text** properties tabs appear.

![Figure 3-3 Text Properties Tabs](image-url)
2 On the **Text** tab, click the **Font** drop-down list and do one of the following:

- Select a **printer-resident font** from the list. Printer-resident fonts are resident on your thermal printer; that is, they are stored in your printer’s memory.
- Select the **TrueType Fonts** option. TrueType fonts are supplied by Windows and are resident on your PC; and may or may not be resident on your printer.

![Warning]

If your printer does not support TrueType fonts, they will be processed as graphics. Graphics require more memory, taking longer to print than fonts that are resident on the printer.

The settings available on the **Text** tab depend on if you select a printer-resident font or a TrueType font.

3 If using a printer-resident font, set the following properties:

**Expand Height:** Allows you to stretch the height of the printer font. A value of 1 is the normal height. If large text is required, it is better to use a large font instead of using a small font and stretching it, as the edges can become rough.

**Expand Width:** Allows you to stretch the width of the printer font. A value of 1 is the normal width.

**Rotation:** Controls the orientation of the text object. The options are Normal, Sideways Up, Sideways Down, and Upside Down.

4 If using a TrueType font, set the following properties:

**TrueType Font:** Select from a list of installed fonts.

**Point Size:** The size of the font expressed in points.

**Language:** Select from a list of character sets appropriate for the language you are using.

**Style:** Select from a list of available styles for the selected font. For most TrueType fonts, available styles include Normal, Bold, Italic, and Bold & Italic.
Rotation: Controls the orientation of the text object. The options are Normal, Sideways Up, Sideways Down, and Upside Down.

5 Click the Data Source drop-down list and select the source from which the text object will get its value. The default data source is Fixed (never changing). See the Data Sources chapter for more information.

6 If adding text with a Fixed data source, in the Text String box, type the text to be printed on the label.

7 Click the Options tab to assign a unique name to this field and if desired, set other optional text properties.

8 If you want to apply color to the text, click the Color tab to access the color settings.

If you do not have a color printer, colors have no effect on the output; but they can help you differentiate between different types of fields in the design window.

9 Click OK and then click on the label in the position where you want to place the text.

Adding a Paragraph

1 Do one of the following:
   • On the Draw menu, click Paragraph.
   • Click Add Paragraph on the Drawtools Bar.

   The Paragraph properties tabs appear.
2  On the **Paragraphs** tab, click the **Font** drop-down list and select either a printer-resident font or select the TrueType Font option.

3  Set the font properties as appropriate for this paragraph object. See the *Adding Text* section on page 3-3 for descriptions of the printer-resident font and TrueType font properties.

**Note**

The settings available on the **Paragraphs** tab depend if you are using a printer-resident font or a TrueType font.

4  Set the following paragraph field properties:

**Characters/Line:** The maximum number of characters in each line of the paragraph. For proportional fonts, this is an approximate value. Text wraps to a new line when this value is reached. Line breaks in the original file are ignored. (Note: You can use the tilde character (~) in the text file to force a line break on the label.)

**Maximum Lines:** The maximum number of lines the
paragraph may have. Text that exceeds this maximum will not appear on the label.

**Line Spacing:** The amount of space between each line in the paragraph. This value must be specified as a number of dots (the smallest unit of measurement on the printer). A value of 0 may cause printed text to be difficult to read. A value of 2 or 3 is generally acceptable.

**Word Wrap:** Automatically wraps to the next line if the last word exceeds the number of characters allowed in a line. Without word wrap, the word is truncated and the rest of the file lost.

**Justification:** Aligns the text to the field’s left margin, right margin, to both margins, or to the center of the field.

**Edit File:** Displays a text box for you to edit the selected paragraph file.

**Stretch to Fit:** Once the paragraph has been added to the label, with this option enabled you will be able to click and drag the paragraph’s image handles to change its size. Based on the data, the font will be stretched (or shrunk) to fit the defined area.

5 Click the **Data Source** drop-down list and select the source from which the paragraph object will get its value. The default data source is Fixed (never changing). See the **Data Sources** chapter for more information.

6 If using a Fixed data source, click the **Paragraph File** drop-down list and select the name of the file that contains the data for this paragraph field.

   You can also select `<new file>` to display a text box for creating a text file.

7 If you want to apply color to the paragraph, click the **Color** button on the **Paragraphs** tab to access the color settings.

8 Click on the **Options** tab and assign a unique field name to this field.

9 Click **OK** and then click on the label in the position where you want to place the paragraph.
**Adding a Bar Code**

Do one of the following:

- On the **Draw** menu, click **Bar Code**.
- Click **Add Bar Code** on the **Drawtools Bar**.

The **Bar Code** properties tabs appear.

2. Select the desired bar code type from the **Bar Code Type** drop-down list of choices.

   ![Figure 3-5 Bar Code Properties Tabs](image)

   **Figure 3-5 Bar Code Properties Tabs**

   The default values and properties appearing on the **Bar Code** tab will differ depending on the type of bar code that you select.

3. On the **Bar Code** tab, set the following bar code properties as appropriate for this field:

   - **Bar Code Type**: Select one of over 30 different bar code symbologies supported by the label design software.
   - **Rotation**: Controls the orientation of the bar code object. The options are Normal, Sideways Up, Sideways Down, and Upside Down.
   - **Bar-Width Ratio**: Controls the relative size between thick and thin bars and spaces.
**Multiplier:** While the relative thickness of the bars is defined by the bar-width ratio, the overall thickness of the bars can be changed using the bar width multiplier. Use this value to adjust the overall width of the bar code.

**Height:** The height of the bars in the code; does not affect the height of the human readable characters.

**Bar Code Value:** This setting appears only if the source of data is Fixed. The actual value for the bar code should be entered here.

4 Click the **Data Source** drop-down list and select the source from which the bar code field will get its value. The default data source is Fixed (never changing). See the **Data Sources** chapter for more information.

5 If using a Fixed data source, in the **Bar Code Value** box, type the text to be used as the actual value of the bar code.

6 Click the **Human Readable** tab to specify whether to print human readable text along with the bar code.

7 Click the **Options** tab to access additional settings.

8 Click **OK** and then click on the label in the position where you want to place the bar code.
Adding a 2D Bar Code

1. Do one of the following:
   - Click Add 2D Bar Code on the Drawtools Bar.

The 2D Symbology properties tabs appear.

2. Select the desired 2D bar code type from the 2D Symbology drop-down list of choices. (Note: Not all bar code types are available for all printers.)

   ![Figure 3-6 2D Symbology Properties Tabs](image)

   The default values and properties appearing on the 2D Symbology tab will differ depending on the type of symbology that you select.

3. On the 2D Symbology tab, set the following bar code properties as appropriate for this field:

   - **ECC Level/Percent:** The Error Correction Control (ECC) settings determine how resistant the bar code is to destruction, while still maintaining maximum readability. Note that while the higher ECC levels (larger numbers) provide better error correction, they also increase the size
of the 2D bar code. The default ECC level setting is Auto. If an Auto ECC level is used then an ECC percent may also be chosen for fine adjustment of the Error Control.

**Dot Width/Height:** The Dot Width and Height settings determine the width and height of the 2D bar code (similar to the Bar Width Ratio setting in a linear bar code). The unit of measurement is mils, where 1mil=1/1000”. Typically, the Dot Width and Height settings are dependent upon the type of printer used and the labeling specifications to be met, if any.

4 Click the **Data Source** drop-down list and select the source from which the 2D bar code will get its value. The default data source is Fixed (never changing). See the *Data Sources* chapter for more information.

5 If using a Fixed data source, click the **File Name** drop-down list and select the name of the text file that contains the data to be encoded into the bar code. (Note: The text file must reside in the directory specified for text files in the **Options > Directories** dialog box.)

This file can also be created using Windows Notepad, available from the **Tools** menu.

6 Click the **Options** tab to access additional settings.

7 Click **OK** and then click on the label in the position where you want to place the 2D bar code.

**Adding a Picture**

1 Do one of the following:
   - On the **Draw** menu, click **Picture**.
   - Click **Add Picture** on the **Drawtools Bar**.

The **Picture** properties tabs appear.
2 On the **Pictures** tab, set the following picture properties as appropriate for this field:

**Rotation:** Controls the orientation of the picture object. The options are Normal, Sideways Up, Sideways Down, and Upside Down.

**Ratio:** Determines if and how the image can be resized.
- **Fixed Ratio** means both the height and width will remain proportional as the size changes.
- **Stretchable** means there is independent control of the height and the width.
- **Non-Resizable** means the picture cannot be resized.

**Preview:** Click this box if you want to see a preview of the selected picture file.

3 Click the **Data Source** drop-down list and select the source of the picture object. The default data source is Fixed (never changing). See the *Data Sources* chapter for more information.

4 If using a Fixed data source, click the **Pictures** drop-down list and select the name of the picture file (e.g., logo.pcx). (Note: The picture file must reside in the directory speci-
ffeed for picture files in the **Options > Directories** dialog box.)

5 If you are adding a color picture, click on the **Options** tab to access additional color settings.

6 Click **OK** and then click on the label in the position where you want to place the picture.

**Adding an OLE Object**

1 Do one of the following:
   - On the **Draw** menu, click **OLE Object**.
   - Click **Add OLE Object** on the **Drawtools Bar**.

The **Insert Object** dialog box appears.

![Insert Object dialog box](image)

**Figure 3-8 Insert OLE Object**

2 Select one of the following options:
   - **Create New**: The **Object Type** list displays objects associated with your other installed applications that support Object Linking and Embedding (OLE). Select an object type from the scroll list and click **OK**. The program associated with the selected object type will open, allowing you to create a new object using that program. (Note: Creating a new object does not create a new file; therefore, these objects are embedded and not linked.)
   - **Create from File**: If the object you want to use on the label is already saved on your system, use this option to locate it and insert the object as a link. You will be prompted to enter the location and file name, or you can browse to find it.
3  Click OK and then click on the label in the position where you want to place the object.

Adding a Box

1  Do one of the following:
   • On the Draw menu, click Box.
   • Click Add Box on the Drawtools Bar.

The Box properties appear.

2  Specify the thickness and color of the horizontal and vertical sides of the box. If you have a single-color printer, however, the box will print only in that color.

3  Click OK and then click on the label in the position where you want to place the box (the cursor position will be the upper left corner of the box).

4  The box will appear with a default size. If you want to change the size of the box, click and drag one of the box's handles until you have reached the desired size.

Adding a Line

1  Do one of the following:
   • On the Draw menu, click Line.
   • Click Add Line on the Drawtools Bar.

2  Click and drag the cursor (appearing as a crosshair in the design window) to draw a vertical or horizontal line.

3  To specify the thickness or color of the line, right-click on the line and select Edit.
Adding a Shape  

1. Do one of the following:
   - On the **Draw** menu, click **Shape**.
   - Click **Add Shape** on the **Drawtools Bar**.

   The **Shape** properties tabs appear.

2. On the **Shape** tab, in the **Shape Category** drop-down list, select the category that contains the shape you want. For example, if you are looking for a fire extinguisher icon, select the Fire Safety category. All the available shapes for the selected category appear.

3. Scroll through the displayed shapes and click the shape you want. The selected shape will appear in the lower portion of the dialog box.
4 In the **Rotation** box, select the orientation of the shape. The options are Normal, Sideways Up, Sideways Down, and Upside Down.

5 In the **Ratio** box, select one of the following options for resizing the shape:
   - **Fixed Ratio** means both the height and width will remain proportional as you change the size.
   - **Stretchable** means you have full control over the height and width of the image.

6 If you want to apply color to the shape, click on the **Options** tab to access the color settings.

7 Click **OK** and then click on the label in the position where you want to place the shape.

### Working with Placed Objects

#### Moving an Object on the Label
1 Place the mouse pointer over the selected object.
2 Click the left mouse button and drag to move the object to the desired location.

#### Sizing an Object on the Label
1 To size the object while keeping the aspect ratio of the height and width the same, click on one of the four corners of the object handles (so the cursor is at a diagonal).
2 Drag to the desired size.

### For More Information on Designing Labels

For detailed information on all label design functions available in this label design software, use the program’s online Help. Help is available by selecting **Help** from the **Help** menu or by pressing F1.
This chapter provides an overview of the types of data sources available in the label design software. Only a brief explanation is given here; additional information can be found in the online Help.

What is a Data Source?

A data source identifies the source of the data to populate a field. You must select a data source for every text, paragraph, bar code, 2D bar code, or picture field that you place on the label. A data source can be constant or variable.

- **Constant:** The data you enter for the field is the same every time it is printed. An example would be a **Fixed** data source, where the field’s value is entered when the field is created and that value does not change.

- **Variable:** The field receives its value at the time of printing. An example would be a **Date** data source, where the actual value printed will vary depending on the current date.

You specify the data source in the properties dialog box for each field.
The following table describes the data sources from which you can select. Not all data sources are available for all types of fields.

<table>
<thead>
<tr>
<th>Data Source</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Fixed</strong></td>
<td>The value is entered when the field is created, and does not change.</td>
</tr>
<tr>
<td><strong>When Printed</strong></td>
<td>The operator is prompted to enter the value at print time. For paragraphs and 2D bar codes, this option can only be used to pass information to the field from an external controlling program.</td>
</tr>
<tr>
<td><strong>Linked</strong></td>
<td>The value is obtained from one or more other fields on the label, or from a mathematical or logical expression.</td>
</tr>
<tr>
<td><strong>dBase</strong></td>
<td>The value is retrieved from a dBase-compatible database. The operator can be prompted to enter the key field data at print time, initiating a lookup in the database to retrieve the data that you want to print.</td>
</tr>
</tbody>
</table>
## Data Sources

Data Sources Chapter 4-3

Table continued from previous page

<table>
<thead>
<tr>
<th>Data Source</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>ODBC</strong></td>
<td>The value is retrieved from an ODBC database. The operator can be prompted to enter the key field data at print time, initiating a lookup in the database to retrieve the data that you want to print. To use the ODBC data source you must first install the ODBC drivers on your PC. You then need to set up ODBC within the label design software (Options menu &gt; Directories &gt; Data Source button).</td>
</tr>
<tr>
<td><strong>OLE DB</strong></td>
<td>The value is retrieved from an OLE DB database. The operator can be prompted to enter the key field data at print time, initiating a lookup in the database to retrieve the data that you want to print. To use the OLE DB data source you must first set up the database through the OLE DB Manager (Options menu &gt; Configuration &gt; OLE DB Manager tab).</td>
</tr>
<tr>
<td><strong>Date/Time Stamp</strong></td>
<td>The date/time, based on the system clock, populates the field. An offset may be defined to print a past or future date/time.</td>
</tr>
<tr>
<td><strong>Serial File</strong></td>
<td>At print time, the value is retrieved from a serial file that is incremented or decremented with each label printed. The serial file can be reset automatically after each print job, to begin again at the starting value; or, counting can resume from the last label printed.</td>
</tr>
<tr>
<td><strong>CommWatch</strong></td>
<td>The value is retrieved from an external device—such as a weigh scale, scanner, sensor or PLC—through the computer’s serial port.</td>
</tr>
<tr>
<td><strong>Accumulator File</strong></td>
<td>The value is retrieved from an accumulator file. An accumulator file takes the numeric value from a field on a label (or from multiple formats) each time the label(s) is printed. The values are added together (accumulated) in the accumulator file; the total of which can be printed using this data source.</td>
</tr>
<tr>
<td><strong>Pick List</strong></td>
<td>The value is selected at print time from a predefined drop-down list of choices. Input can be limited to the list to ensure exact entry of data with no unauthorized entries.</td>
</tr>
<tr>
<td><strong>Shift Code</strong></td>
<td>The value is a pre-determined code that is based on the time of day the label was sent to the printer.</td>
</tr>
<tr>
<td><strong>Data Dictionary</strong></td>
<td>The operator is prompted to enter the value at print time; the prompt is derived from the data dictionary.</td>
</tr>
</tbody>
</table>
Creating Your First Label

Introduction

This chapter walks you through the process of creating two different sample label designs. The steps covered in this chapter introduce some of the most frequently used features and functions of the label design software.

- *Designing a Product Label (Basic)* provides step-by-step instructions for selecting a printer, completing your label setup, and adding several different types of fields including text, bar code, and picture fields. We will also add a line, a date stamp, and a pick list field that allows you to select from a list at print time.

- *Designing an Inventory Label (Advanced)* covers more advanced features available only in the mid-range and high-end editions of the label design software. In this tutorial you will add text, bar code, and picture fields that get their values from a database. We will also add a hidden field, an incrementing serial file field, and a linked field that combines text with an existing field on the label.

Designing a Product Label (Basic)

In this section we will create a basic product label. The label is intended for use on a package of coffee, and includes product specific information such as product name, flavor, picture, and sell by date, as well as a UPC bar code.

The following is a sample of the product label we will create.
This type of label would typically be printed using a thermal or thermal transfer label printer; even if you do not have this type of printer or label stock size available, you can still go through the basic label design steps covered in this tutorial.

Selecting a Printer

The first step to designing a label is to select the printer you will use for printing. The printer model selected determines what options are available as well as the label’s size limitations.

To select a printer for your label design:

1. Start the label design software.
2. On the File menu, click Select Printer.

The Select Printer dialog box appears.
3 Do one of the following:

- If you previously installed a thermal/thermal transfer printer driver for use with this label design program, click the Printer drop-down arrow and select your printer from the list of installed printers.

- If you have not yet installed a thermal/thermal transfer printer driver for use with this label design program, click Install, select your printer’s manufacturer and model, and again click Install. The new printer will be copied to the Installed Printers list. Click Close.

4 Click OK.

**Label Setup**

When you start the program, a default label appears ready for you to design. The label width, height, margins, and other general setup options can be changed using the Label Setup tabs.

► **To set the units of measure for the label:**

1 On the Options menu, click Configuration, and then click the Display tab.

2 In the Units box, click inches.

3 Click OK.

► **To set up the label:**

1 On the Edit menu, click Label Setup.

The Label Setup tabs appear.
The settings appearing on the **Label Setup** tab will vary depending on the type of printer selected for this label design.

2 On the **Label Setup** tab, set the following label properties:
   - **Width**: 4.0
   - **Height**: 2.5
   - **Left Margin**: 0
   - **Labels Across**: 1

3 Leave the other label setup settings at their defaults.

4 Click **OK**.

**Adding Text**

1 Do one of the following:
   - On the **Draw** menu, click **Text**.
   - Click **Add Text** on the **Drawtools Bar**.

The **Text** properties tabs appear.
The settings available on the Text tab will vary depending on whether you are using a printer-resident font or a TrueType font.

2 In the Font box, click TrueType Fonts.

3 On the Text tab, set the following properties for this text field:
   - TrueType Font: Times New Roman
   - Point Size: 18
   - Language: Western
   - Style: Bold & Italic
   - Rotation: Normal
   - Data Source: Fixed
   - Text String: Central Perk Gourmet Coffee

4 Click the Options tab and in the Field Name box, type Brand.

5 Click the Color tab, click the color box drop-down arrow and select a color for the text. (Note: If you do not have a color printer, colors have no effect on the output.)

6 Click OK.
7 Use the mouse to position the text field near the top edge of the label and click once to place the text (you do not need to worry about precise field positioning at this time).

8 On the File menu, click Save As and save the label file to the program’s Samples folder as basic.lbl.

Adding a Line

1 Do one of the following:
   • On the Draw menu, click Line.
   • Click Add Line on the Drawtools Bar.

Your cursor appears as a crosshair in the design window.

2 Click below the Central Perk Gourmet Coffees text and draw a horizontal line.

3 Right-click the line, and click Edit.

   The Line dialog box appears.

4 In the Width box, enter 3.80.

5 In the Height (thickness) box, enter .05.

6 Click OK.

Positioning Objects on the Label

We will now use the Float Bar tool buttons to precisely position the text and line fields on the label.

1 Click the View menu and ensure that a checkmark appears next to the Float Bar toolbar option.

2 On the label design, hold down the SHIFT key while clicking on the Central Perk Gourmet Coffees text and on the horizontal line, and then click the Center Horizontally button on the Float Bar.

3 On the File menu, click Save to save your changes.

Adding a Picture

1 Do one of the following:
   • On the Draw menu, click Picture.
   • Click Add Picture on the Drawtools Bar.

The Picture properties tabs appear.
2 On the **Pictures** tab, set the following properties for this picture field:
   - **Rotation**: **Normal**
   - **Ratio**: **Fixed Ratio**
   - **Data Source**: **Fixed**
   - **Pictures**: **coffee.jpg**

3 Select the **preview** check box to display the selected picture.

4 Click **OK** and then click in the lower left corner of the label to place the picture.

5 If the picture appears to be too small for the label, you can easily size the picture while keeping the aspect ratio of the height and width the same. To do this, click on one of the four corners of the object handles (so the cursor is at a diagonal) and drag to increase the size.

At this point, your label should look something like this:
6  On the **File** menu, click **Save** to save your changes.

### Adding a Pick List Field

A pick list file contains values from which you can select at print time. We will create a pick list file that contains three different coffee flavors. At print time, you can then simply click the drop-list and select the appropriate flavor to print on the label.

- **To create a pick list file:**
  1  On the **Options** menu, click **Picklist Setup**.

    The **Picklist Setup** dialog box appears.

  2  Click **New**.

    The **Picklist File: new file** dialog box appears.
3 Click New, type Dark Roast, and click OK.

The value is added to the pick list.

4 Add the Espresso and Colombian values to the pick list.

5 Click Dark Roast, and then click As Default.

6 Click Sort.

7 Click the Force data to come from list check box, and click OK.

The File Name dialog box appears.

8 Type flavors.pkl, click OK, and then click Exit to return to the design window.

9 On the File menu, click Save to save your changes.

To add a field with a Pick List data source:

1 On the Draw menu, click Text.

The Text properties dialog box appears.

2 Select these font properties:
   Font: TrueType Fonts
   TrueType Font: Arial
Point Size: **14**  
Style: **Normal**  
Rotation: **Normal**

3 In the **Data Source** box, click **Pick List**.

4 In the **Pick List** box, click **flavors.pkl**.

5 In the **Prompt** box, type **Flavor**.

![Figure 5-8 Pick List Data Source](image)

6 Click the **Options** tab.

7 In the **Required** box, click **Yes** to prevent users from printing without entering a value for this field.

8 In the **Clear After Print** box, click **Yes** to restore the field to its default after printing.

9 Click **OK**, and place the field on the right side of the label, below the horizontal line.

Because its data source is a pick list file accessed at print time, the field will display on the label as a series of Xs.

10 On the **File** menu, click **Save** to save your changes.
Adding a Bar Code 1  Do one of the following:


- Click Add Bar Code on the Drawtools Bar.

The Bar Code properties tabs appear.

![Bar Code Properties Tabs](image)

The default values and properties appearing on the Bar Code tab will differ depending on the type of bar code that you select.

2  On the Bar Code tab, set the following properties for this field:

Bar Code Type: **UPC-A**

Data Source: Fixed

Bar Code Value: **45634563456**

3  Leave the other bar code settings at their defaults.

4  Click the Human Readable tab.

5  In the Human Readable box, click Yes.

6  Click the Options tab.

7  In the Field Name box, type UPC.

8  Click OK and then click on the right side of the label to place the bar code below the pick list field.
Chapter 5-12
Quick Start Guide

9 On the **File** menu, click **Save** to save your changes.

Adding a Date Stamp

1 On the **Draw** menu, click **Text**.
   The **Text** properties tabs appear.

2 Select these font properties:
   - Font: **TrueType Fonts**
   - TrueType Font: **Arial**
   - Point Size: **9**
   - Style: **Normal**
   - Rotation: **Normal**

3 In the **Data Source** box, click **Date stamp**.

4 In the **Date Format** box, click **mmm dd, yyy**.

5 In the **Date Offset** box, type **6**.

6 In the **Offset Unit** box, click **Months**.

7 Click the **Options** tab and in the **Field Name** box, type **SellDate** (no spaces).

8 Click the **Color** tab, click the color box drop-down arrow and select a color for the text.

9 Click **OK**, and place the field in the lower right corner of the label.
   The date appears, offset by 6 months.

10 Now to add “Sell By:” in front of the date, on the **Draw** menu, click **Text**.
   The **Text** properties dialog box appears.

11 Select these font properties:
   - Font: **TrueType Fonts**
   - TrueType Font: **Arial**
   - Point Size: **9**
   - Style: **Normal**
   - Rotation: **Normal**
   - Data Source: **Fixed**
   - Text String: **Sell By:**
12 Click the **Color** tab, and select the same color you chose previously for the date stamp.

13 Click **OK**, and place the field to the left of the date stamp field.

14 Hold down the SHIFT key while clicking on the **Sell By:** text and on the date stamp field, and then click the **Align Top** button on the **Float Bar**.

15 On the **File** menu, click **Save** to save your changes.

**Printing the Label**

1 On the **File** menu, click **Print**.

The **Quick Printing** dialog box appears.

![Quick Printing Dialog Box]

**Figure 5-10 Quick Printing Dialog Box**

2 In the **Flavor** box, click **Espresso**, and then click **Print**.

The label is printed.

3 Click **Close** to return to the design window.
Designing an Inventory Label (Advanced)

Many of the features used in this tutorial are available only in the mid-range and high-end editions of the label design software.

In this section we will create a slightly more advanced parts inventory label. The label is intended to be used as a shelf label, and includes information such as the part description, part number, and picture, as well as a bar coded stocking number.

The following is a sample of the parts inventory label we will create.

![Inventory Label](image)

**Figure 5-11 Inventory Label**

This type of label would typically be printed using a thermal or thermal transfer label printer; even if you do not have this type of printer or label stock size available, you can still go through the basic label design steps covered in this tutorial.
To set up the label:

1. Close any open label design files.

2. Right-click on the blank label design area and select **Label Setup**.

   The **Label Setup** tabs appear.

3. On the **Label Setup** tab, set the following label properties:
   - Width: **3.0**
   - Height: **1.5**
   - Left Margin: **0.0**
   - Labels Across: **1**
   - Horizontal Gap: **0.0**

4. Leave the other label setup settings at their defaults.

5. Click **OK**.

6. On the **Style Bar** toolbar (above the design area), click the **Zoom factor** drop-down list and click **Full** to design the label using a magnified display.

   To see the actual size of the label we’ll be designing, click **100%**.

---

**Adding a dBase Text Field**

Before retrieving data from a dBase database, you must provide the label design software with the location of your database files. For purposes of this example, we will be using the **fittings.dbf** sample database file that is installed with the program.

To set the path to the .dbf database file:

1. On the **Options** menu, click **Directories**.

   The **Directories** dialog box appears.

2. In the **Path of Database Files** box, click **Browse**, and select the path to the label design program’s **DBF** folder (e.g., **c:\LVWIN70\DBF**).

3. Click **OK** to return to the design window.
To add a field that uses a .dbf database:

1. On the Draw menu, click Text.

   The Text properties tabs appear.

   Note

   You can use the dBase data source for text, paragraphs, bar codes, 2D bar codes, and pictures.

2. Select these font properties:
   - Font: TrueType Fonts
   - TrueType Font: Arial Black
   - Point Size: 10
   - Style: Normal
   - Rotation: Normal

3. In the Data Source box, click dBase.

4. In the Database box, click fittings.dbf.

   Fittings.dbf is a sample dBase file that installs with the program.

5. In the Key field box, click PART.

   The key field is the database field that allows you to locate the desired record.
6 In the **Print field** box, click **DESC1**.

The print field is the database field that contains the data you want to print on the label. It can be the same as the key field, or another field in the database.

7 In the **Keyfield Data** box, click **Prompted**.

The keyfield data defines the source of the key field (either prompted at print time or linked to another field on the label).

8 In the **Prompt** box, type **Part Number**.

9 Click the **Options** tab, and set the following properties for this field:
   - Increment: **1**
   - Copies: **1**
   - Reset after each record: **No**
   - Clear After Print: **No**
   - Field Name: **PartDesc**

10 Leave the other **Options** tab settings at their defaults.

11 Click **OK**, and place the field in the top left corner of the label.

12 On the **Style** bar, click the button to display the name of the field (Name Mode), click the button to display the field length (XXX Mode), and finally, click the button to display the value of the first record in the database (Value Mode). Leave the field display in Value Mode.

13 On the **File** menu, click **Save As** and save the label file to the label design program’s **Samples** folder as **advanced.lbl**.
Adding a Hidden Field

The second dBase field we will add to the label will be set up as a *hidden* field. This means that it will be available to use to create other linked fields, but it will not print on the label. Later in this section we will add a field that links to this hidden field.

To add a hidden text field:

1. On the **Draw** menu, click **Text**.
   
The **Text** properties tabs appear.

2. In the **Data Source** box, click **dBase**.

3. In the **Database** box, click **fittings.dbf**.

4. In the **Print field** box, click **PART**.

5. Click the **Options** tab, and set the following properties for this field:
   
   Increment: **1**
   
   Copies: **1**
   
   Reset after each record: **No**
   
   Clear After Print: **No**
   
   Field Name: **PartNo**
   
   Hidden: **Yes**

6. Leave the other **Options** tab settings at their defaults.

7. Click **OK**, and place the field in the top right corner of the label.
   
The field appears in red to indicate that it is a hidden field.
   
   It displays on the label for placement purposes, but will not print on the label.

8. On the **File** menu, click **Save** to save your changes.
Adding Lines  

In the following steps we will add a horizontal line and a vertical line, as shown in the following figure.

![Figure 5-13 Horizontal and Vertical Lines](image)

1. On the **Draw** menu, click **Line**.
   
   Your cursor appears as a crosshair in the design window.

2. Click on the left side of the label below the two dBase text fields, and draw a horizontal line across the entire label as shown in the figure above.

3. Right-click the line, and click **Edit**.
   
   The Line dialog box appears.

4. In the **Width** box, enter **2.86**.

5. In the **Height** (thickness) box, enter **.02**.

6. Click **OK**.

7. On the **Draw** menu, click **Line** again and this time add a vertical line in the middle of the label, as shown in the figure.

8. Right-click the line, and click **Edit**.
The Line dialog box appears.

9 In the Width box, enter .02.

10 In the Height (thickness) box, enter 1.0.

11 Click OK.

12 On the File menu, click Save to save your changes.

Adding a Serial Number

To set up an incrementing serial number you must specify Serial file as the data source and link the field to a serial file. The serial file allows the program to track the last serial number printed and start the next print job with the next number in the series.

In order to set up a serial number field, you first need to create a serial file. The serial file contains the starting value for the counter; that is, the first number to be printed.

To create a serial file:

1 On the Options menu, click Serial Files.

The Serial files dialog box appears.

2 Click New.

3 The Serial file: Untitled dialog box appears prompting you to enter the starting value for the counter; that is, the first serial number to be printed.

![Serial file: Untitled](image)

**Figure 5-14 Serial Number Starting Value**

4 In the Serial Number box, type 100001, and click OK.

5 The Save Serial Files dialog box appears prompting you to name the serial file.

6 In the Serial file box, type stockno.srl, click OK, and then click Exit to return to the design window.
To add a serial number (link to the serial file):

1. On the **Draw** menu, click **Bar Code**.
   The **Bar Code** properties tabs appear.

2. Select these bar code properties:
   - **Bar Code Type**: *Interleaved 2 of 5*
   - **Rotation**: *Normal*
   - **Multiplier**: *2 (10 mils)*
   - **Bar-width Ratio**: *2:1*
   - **Height**: *0.50*

3. In the **Data Source** box, click **Serial file**.

4. In the **Serial file** box, click **stockno.srl**.

5. Click the **Human Readable** tab and click **No** for the **Human Readable** setting.

6. Click the **Options** tab and set the following properties:
   - **Increment**: *1*
   - **Copies**: *1*
   - **Reset after each record**: **No**
   - **Field Name**: **StockNo**

7. Leave the other **Options** tab settings at their defaults.

8. Click **OK**, and place the field in the lower right part of the label.

9. On the **File** menu, click **Save** to save your changes.

### Adding Linked Fields

You can use the **Linked** data source to combine text and fields (or to combine two fields) into one field on the label.

**To combine text with a dBase field:**

1. On the **Draw** menu, click **Text**.
   The **Text** properties tabs appear.

### Note

You can use the **Linked** data source for text, bar codes, 2D bar codes, and pictures.
2 Select these font properties:
   Font: TrueType Fonts
   TrueType Font: Arial
   Point Size: 8
   Style: Normal
   Rotation: Normal

3 In the Data Source box, click Linked.

4 In the Linked Fields box, type the following:
   “PART: “ + PartNo

   ![Figure 5-15 Linked Field](image)

5 Click the Options tab, and in the Field Name box, type LinkedPartNo.

6 Leave the other Options tab settings at their defaults.

7 Click OK, and place the field on the left side of the label, slightly below the horizontal line.

   Because its data is being accessed from a dBase file at print time, the part number will display as a series of Xs.

   ▶ To combine text with a Serial File field:

1 On the Draw menu, click Text.

   The Text properties tabs appear.
2 Select these font properties:
   Font: TrueType Fonts
   TrueType Font: Arial
   Point Size: 8
   Style: Normal
   Rotation: Normal

3 In the Data Source box, click Linked.

4 In the Linked Fields box, type the following:
   “STOCK #: “ + StockNo

5 Click the Options tab, and in the Field Name box, type LinkedStockNo.

6 Leave the other Options tab settings at their defaults.

7 Click OK, and place the field on the right side of the label, above the bar code field.

8 On the File menu, click Save to save your changes.

Adding a dBase Picture Field

In order to automatically include the correct picture on each label, we will access the name of the picture file from a database at print time using the dBase data source. The picture to be printed on each label is determined by a graphic file name in the database.

1 On the Draw menu, click Picture.

2 Set the following properties for the picture field:
   Rotation: Normal
   Ratio: Fixed Ratio
   Data Source: dBase
   Database: fittings.dbf
   Print field: PICTURE

3 Click OK, and place the picture field on the left side of the label, below the LinkedPartNo field.

   Because its value will be accessed from a dBase file at print time, the picture field appears on the label as a double-bordered frame. The correct picture will print on the label, however, based on the corresponding graphic file name in the database.
4 On the **File** menu, click **Save** to save your changes.

Your label design should now look similar to the label below.

![Label with Picture Field](image)

**Figure 5-16** Label with Picture Field

**Positioning Objects on the Label**

We will now use the **Float Bar** tool buttons to position objects on the label in relation to each other.

1 Click the **View** menu and ensure that a checkmark appears next to the **Float Bar** toolbar option.

2 On the label design, click the horizontal line to select it, and then click the **Center Horizontally** button on the **Float Bar**.

3 Click the vertical line and then click the **Center Horizontally** button.

4 Hold down the **SHIFT** key while clicking on the **PartDesc** and **LinkedPartNo** fields, and then click the **Align Left** button.
5 Hold down the SHIFT key while clicking on the **Linked PartNo** and **LinkedStockNo** fields, and then click the **Align Top** button.

6 On the **File** menu, click **Save** to save your changes.

**Printing the Label**

Labels that contain fields populated by a database can require user input at print time if the **Key Field Data** property is set to **Prompted**.

If set to **Prompted**, then a button appears at print time for displaying the database records in a grid. The database grid allows you to select, scroll to, and search for the records you want to print.

➢ **To print a label that uses a database field:**

1 On the **File** menu, click **Print**.

   The **Quick Printing** dialog box appears.

   ![Quick Printing Dialog Box](image)

   **Figure 5-17** Quick Printing Dialog Box

2 Click located to the right of the **PART** box.

   The **fittings.dbf** database file appears in the database grid.
Figure 5-18 Database Grid

3 Hold down the CTRL key while you click on the **Cap Nut Connector**, **Hex Nut**, **Bronze Faucet**, and **Clamp** records (rows) to select them, and then click **Select**.

4 Click **OK** to close the database grid and return to the **Quick Printing** dialog box.

5 Click **Print**.

Labels are printed for each of the selected records according to the print quantities you selected.

Verify that the stock number increments by 1 with each label printed (i.e., 100001, 100002, etc.).

6 Click **Close** to return to the design window.
Index

Numerics
2D bar codes 3-10
  adding 3-10
  properties 3-10

A
accumulator files 4-3
  adding
    2D bar codes 3-10
    bar codes 3-8
    boxes 3-14
    lines 3-14
    OLE objects 3-13
    paragraph 3-5
    pictures 3-11
    shapes 3-15
    text 3-3
  aligning objects 2-5

B
bar codes 3-8
  adding 3-8
  properties 3-8
  boxes 3-14
    adding 3-14
    properties 3-14

C
command files 2-3
  CommWatch 4-3
  coordinates 2-6
  create new label 3-1
  cursor position 2-6

D
data dictionary 4-3
  data source
    definition 4-1
    types 4-2
  DataWatch Server 2-3
  date 4-3
dBase dBase 4-2
  DDE Server 2-3
  display modes 2-2
  display settings 2-6
  Drawtools Bar 2-3

F
fixed data source 4-2
  Float Bar 2-5

G
  graphics 3-11
  grid 2-2
  grid display 2-6

H
  Help 1-5
I

inches 2-6
installation 1-3
installing a printer 2-7
installing the software 1-3
interface 2-1
introduction 1-1

K

key 1-2

L

Label Select 2-3
label setup 3-1, 5-3
language selection 2-6
License Manager 1-3
lines 3-14
linked data source 4-2
LVLICENSEMANAGER.EXE 1-4

M

Menu Bar 2-1
menus 2-1
millimeters 2-6
moving objects 3-16
multi-user installation 1-3

N

Name mode 2-2
network installation 1-3
new label 3-1

O

objects
  adding 3-3
  aligning 2-5
  moving 3-16
  sizing 3-16
ODBC 4-3
OLE DB 4-3
OLE objects 3-13
opening a label 3-2

P

paragraphs 3-5
  adding 3-5
  properties 3-6
  pick list 4-3
  pictures 3-11
    adding 3-11
    properties 3-12
  preview label 3-3
  printer
    selecting 5-2
    setup 2-7
  product components 1-2
  product label 5-1

R

Readme.txt file 1-4
registration 1-5
requirements 1-1
Rotation button 2-6
ruler colors 2-6
rulers 2-6

S

sample labels 5-1
security key 1-2
selecting a printer 2-9, 5-2
serial file 4-3
Server Bar 2-3
setup 3-1
shapes 3-15
  adding 3-15
  properties 3-15
shift code 4-3
single user installation 1-3
sizing objects 3-16
snap to grid 2-2
software security key 1-2
starting the program 2-1
Status Bar 2-6
Style Bar 2-2
system requirements 1-1

T

technical support 1-5
text 3-3
  adding 3-3
  properties 3-4
time 4-3
toolbars 2-2, 2-3, 2-5, 2-6
TrueType font 3-4
two-dimensional bar codes 3-10

U

units of measure 2-6, 5-3
\textbf{V}
Value mode 2-2
view modes 2-2

\textbf{W}
when printed data source 4-2
workstations 1-4

\textbf{X}
XXX mode 2-2