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CHAPTER 1

Introduction

Introduction
Form Designer is a visual designing tool that allows you to
rapidly build front-end data entry and label printing
applications.
It includes features such as:
* Label and printer type selection
* Print preview
» Page and printer settings
* Database connections

* Multiple screen/form application

¢ Pre-defined values and data control

The layout

Form Designer’s layout is easy to use, reducing the time
necessary to familiarize yourself with the software. It
includes a Menu bar, a Tool bar, a Tool box, a Properties
grid, a Main window and a Status bar.
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Title: Form
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lcon 1 <Default>
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Actions

Form properties

The Menu bar

The Tool bar

New Save

The Menu bar contains six items: File, Edit, View, Data,
Layout, and Help. When clicked, each item will expand
showing a new list of items, to allow the user to perform a
variety of functions. To access the menu items more
quickly, press Alt + the underlined letter from your desired
choice: Alt+F will open the File menu.

File Edit Wi Datas  Lawvout Help

The Tool bar is usually displayed just below the Menu bar.
It is made up of icons which represent the most commonly
used software functions. These icons can be clicked to
quickly access these functions.
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The Tool box The Tool Box is made up of the 12 controls that can be
added to a form: Label, Link label, Button, TextBox,
CheckBox, GroupBox, ListBox, ComboBox, DataGrid,
DatabaseGrid, PictureBox, and Preview.

ToolBoxr o =

Controlz -~

A Label

A LinkLabel
! Y
[abl T entE ox

W' CheckBox
m GroupB o
EH ListBow

=8 ComboBox
5] DataGiid

51 DatabaseGrid
FictureB ox

El Preview

Each control serves a specific purpose. They can be linked
to fixed or variable data and can be associated with actions.
To insert a control into your form, simply click on the control
and drag and drop it into the form.

Control Description

Label Non-active text used to show the
name of an input field

LinkLabel Active text used to link to a webpage
or other specific location

Button An active control used to perform set
functions/actions

TextBox Data entry field

CheckBox A control used to activate/deactivate

or select/deselect predefined features
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Control Description

GroupBox Non-active box placed around a
group of controls for visual
organization

ListBox Displays a list of data as defined in its
properties
ComboBox Displays a drop-down list of data as

defined in its properties

Datagrid Displays predefined data in a grid
such as variable names, values, or
customized data

DatabaseGrid Displays the database defined in the
properties along with some basic
functionality such as filters and
search fields.

PictureBox A box where an image can be
imported into
Preview A box that will display a preview of the

label attached to the form

The Properties The Properties Grid lists all the properties for the selected

Grid control. Here you can change the characteristics of your
controls such as control name, color, size, or actions. It is
context sensitive, so the list of properties will change
according to the control selected. Having the grid displayed
replaces the usual right-click menu command.
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D atas of the form

Atached 1:[7]] DBASE.Ibl
" ariables 7 Variables

B Window Window Form
Title Database Form
B Size G44: 417
Width 644
Height 417
Backoolor [ ] 224; 223; 22
[com [ <Default:

Bl Backgroun <Emptp>
File nam <E mpty>
Alignmer TopCenter
Stretch 1 OniginSize

B Actions
Loading < Emphy>
nloadic < Emply:

Form properties

The Main

The Main window, displayed in the center, is your work
Window

area. Here, you will add controls and create the forms you
will use to input data for label printing. Once the form has
been created and configured, you can go to View >
Execution to run the form and see its final result.

ot Vew Data  Layot  Help

H ¥ X&(a e e smdaasd G

(=I5l |2 Form properties
B Data Dpat
Attached label

Variables

MAIN WINDOW
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The Status bar

[Indefined”

The Status bar gives you the x axis and y axis location of
your pointer, the form name and the name and basic details
of the control you have selected.

Farm , Mo attached label E i I e

The Basics

What are
Actions?

Actions are functions that are assigned to buttons and to
load/unload forms. In Form Designer, 12 pre-defined
Actions have been included in the Actions menu to save
you time and to eliminate the need for programming. In
some cases, where specific parameters must be configured,
these, too, have been predefined in the action’s
configuration.

The predefined actions are:

Action Show the document property dialog box

Displays the Properties dialog box for the
selected document, which shows information
such as creation date and its location.

Action Show the form dialog box

Displays the Form dialog box, where the
user can set the values for the form variables

Action Show the options dialog box

Displays an Options dialog box, where you
can change the display language and other
settings.

Action Show the printing dialog box

Displays the Print dialog box, where you
print from. Here, you can also set the
number of labels printed and see a preview
of the print job.
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Action

Show the printer selection dialog box

Displays a dialog box showing a list of all of
the possible printers to print from.

Action

Show the printer settings dialog box

Displays the Printer Settings dialog box
where settings can be set

Action

Show the page setup dialog box

Displays the Page Setup dialog box, where
the user can set label size, page size,
margin, and size.

Action

Print

Allows the user to print.

Parameters

Label Quantity

Sends the printer the number of labels to be
printed. If the document includes a counter,
the counter increments along with the
number of labels.

Label Copy

Lets the printer know how many identical
copies of each label should be printed.

Inter Cut

Lets the printer know how many labels to
print before each cut.

Page Copy

Lets the printer know how many copies of
each page to print.




Chapter 1-8 Form Designer User Guide

Action Select printer

Allows the user to print from the selected
printer and override any printers that may be
associated with the document.

Parameter Printer

Allows you to set a printer as the default
printer to use when the button is clicked, or to
use the printer selected from a list - if a printer
selection variable is used and defined in the
form properties.

Action Show Label Designer

Allows the user to launch the label designer
for label editing.

Parameter Show

Launches and displays the label designer

Action Load a new form.

Allows the user to open a new form.

Parameters File name

Links an .xmf file to the action.

New Window

Opens the chosen file in a new window if set
to True.

Action Execute a VB Script

Allows the user to execute a user-defined VB
script that can perform actions beyond the
Form Designer’s capabilities. This gives the
user greater flexibility.

Parameters File name
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Links a .vbs file to the action.

Synchronous

Synchronizes the VB script with Form
Designer.
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Creating a form

Designing forms

Designing forms is easy with Form Designer. All controls
can be added to a form using drag and drop, then configured
in the Properties grid to set color, text, action...

To show you how to create a form, we will reproduce two
examples: the DBF.xmf form and the Generic.xmf form.

& Database Form
Mumber of Labels Printer j
°
Nuts & Bolts Ltd
P&RT DESCY SIZE ary FICTURE wi
¥ 200400 Cap MutCon 144 ] capnut. pox < 1t Carrs
200500 T clip Connec 142 10 clip.pox -
200600 Flare Tee Fiti 2142 5 teg.pox F——r
200700 Lock Mut Ada 142 ] lock_nut pox L
200800 “wWall Stiap Co 142 10 tetrap. pox
200900 Hex Mut 34 ] fiting. pcx
201000 Bronze Fauc  Standard 1 faucet].pcx
201100 Gold Faucet  Standard 1 faucet?. pcx
201200 ReducingHe 1 1/2 5 hexnut. pey
201300 Mounting St~ 144 10 shiap. pc
201400 Clamp 142 10 Clamp.pex -
201500 wiood Sciew 2174 50 Screwper @ ink
*
Rec: 14 = 1 » » Numberof records: 12 [ BacktoPortal
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DBForm.xmf

* Placing the
controls

 Setting the control
properties (no data)

This simple form includes a Database grid where you can
quickly view, change or add data in your database.

For this example, you will need to drag and drop the
following controls:

e 2 Labels

¢ 1 TextBox

¢ 1 ComboBox

¢ 1 Database Grid
* 1 Preview

¢ 2 Buttons

Place the items as shown in the following diagram.

Label Text Box Label Combo Box

Database Grid Preview

Button

With Form Designer, it is easy to set your control properties
since the Properties grid is displayed on the right-hand side
of your screen. If you do not see the Properties grid, go to
View > Properties grid.

When you select a control in your form, the associated list of
properties will be displayed in the Properties grid.

1 Set the Label properties as follows:

* Name: IblLabelNumber

* Contents > Type: Fixed Contents

* Contents > Value: Number your Labels:
* Font name: MS Sans Serif
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e Font size: 8,25
e Font Bold: True

¢ Name: IblPrinter

* Contents > Type: Fixed Contents
¢ Contents > Value: Printer:

¢ Font name: MS Sans Serif

e Font size: 8,25

¢ Font Bold: False

2 Set the Preview properties as follows:
* Name: prvPreview
* Contents > Type: Fixed Contents
* Contents > Value: Preview

3 Set the Database Grid properties as follows:
* Name: dbgDatabase
* Contents > Type: Fixed contents
e Contents > Value: DataBaseGrid

4 Set the Text box properties as follows:
* Name: txbQty

NOTE
Input mask

Characters like "0" and "L" can be used to force the input as
numeric or alphabetic respectively. For a complete and up-
to-date list of symbols, please consult the Microsoft table
here:

https://learn.microsoft.com/en-us/dotnet/api/
system.windows.forms.maskedtextbox.mask

5 Set the Combo Box properties as follows:
* Name: cbxPrinter

6 Set the Button properties as follows:
* Name: btnPrint
* Contents > Type: Fixed Contents

¢ Contents > Value: Print

and the second button as:


https://learn.microsoft.com/en-us/dotnet/api/system.windows.forms.maskedtextbox.mask
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 Setting the control
properties (with
data)

* Name: btnPortal
* Contents > Type: Fixed contents
¢ Contents > Value: Back to Portal

Some of the controls require more than just setting text
properties. Buttons require actions, grids require data, and
boxes require variables. The next few steps will walk you
through these controls, their properties, and configurations.

Setting the Database grid’s properties

I

| =l 4| B0 7 %

Fec: 14« » » |Number of records : 0

A Database grid allows the user to view a pre-selected
database. A selected row will display the associated label
in the preview box. The user can Add, Delete, Filter and
Search for information with the Database grid.

e Database > Connection: Select Batcher from the
drop-down menu

* Database > Table: Select Print Job from the drop-
down menu

[ Note |

From Database > Connection, you can select from an
existing list of linked databases or add a new one. The
latter will take you to the Add Database Connection
wizard.

For example, select the FITTINGS.mdb database.

Setting the Form’s properties

Although the form does not appear in the ToolBox, it, too, is
a control to be configured. In fact, for certain controls, such
as datagrids or listboxes, where data can be linked, the
Form acts as the base, and requires specific parameters to
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be set in order for the data controls to be functional.

* Attached label: DBase label

* Variables: 5 variables should have automatically filled
in this field. The 5 variables are the label variables
received from the label's attached database. However,
two Form variables must also be added to use with the
Print button to set the label’'s default printer as the one
be used for printing and to define the number of labels
thant should be printed.

To add these new variables:

1 Click on the down-arrow from the Variables field.

2 In the section titled Form Variables, click Add.

3 Enter the printer name, and click OK.

4 Repeat steps 2 and 3 for Qty.

When you return to the Form properties grid, you will notice

that you now have 7 variables.

El Form properties

E Data Datas of the form
Attached label [ #]] DBASE.IbI
W ariables ¥ Yariables =
B window Window Form
Title Databaze Form
Size 628 407
Backcolor [ ] 224; 223; 227
lcon [ <Default»
Backaground ima <Empty>
Actionz

Setting the TextBox’s properties

The TextBox is used to tell the printer how many label
copies it must print. The number entered in the TextBox by
the user defines the number of copies. If a counter is present
on the label, the counter will be incremented with each label
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copy. To set the properties:
1 Contents > Type: Variable contents

2 Contents > Value: Select Qty from the drop-down list (this
variable was created in the Form Properties)

Form vanables

M arme
Prirter
[ty 1

Setting the ComboBox’s properties

The ComboBox is used to select a printer from the
predefined list. To set the properties:

1Contents >Type: Variable contents

2 Contents > Value: select Printer from the drop-down list
(this variable was created in the form properties)

3 Data > Type: Printers
4 Data > Value > Printers type: select THT
Setting the Buttons properties

Buttons not only require the standard text properties such as
Name and Font, but they also require an action. Form
Designer has included, an Action field that allows you to
pick from a standard list of actions. These actions have
been created and predefined for the ease of the user,
eliminating the need for complex programming and reducing
the possibility of errors.

1 Click the Print button (btnPrint).
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2 Go to Actions and click the _I button. A dialog box
appears.

3 Click Add.

4 In Description, click the down-arrow and choose Select
printer. One parameter must be defined.

5 Click on Parameters. A new dialog box appears.
6 Set the Type field to Variable.

7 Set the Value field to Printer. (which you can select from
a drop down list... Printer is the form variable created in
the Form properties). Click OK.

8 Back in the original Actions window, click Add.

9 Under Various > Description, click the down-arrow and
choose Print. Four parameters must be defined.

e Label Quantity: Set Type to Variable and Value to
Qty (this variable can be selected from a drop-down list.
It is the variable created in the form properties).

* Label Copy: Keep default settings.

* Inter Cut: Keep default settings.

* Page Copy: Keep default settings.

|Action Collection Editor
Hermbers: Prirk Properties:

+| [EHie
Description Print
+ arametets

eters 4 Parameters
Parameter Collection Editor

Members Label Quantity Propeties

0 E Misc

1] Cabel Copy Name Label Quantity
3] Inter Cut | e Fixed

3| Page Copy Value 1

Add Remove

Add Bemove

ok | Coneal Hep |
4
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10 Click OK.

The Print button has been configured to print the number of
labels as defined by the user in txbQty. The label's counter
will be incremented accordingly (if applicable).

11Click the Back to Portal button (btnPortal).
12Click the _I button. A new dialog box appears.

13Go to Various > Description and select Load new form
from the drop-down menu. 2 parameters must be defined:

* File Name: Set Type to Fixed and Value to
MainMenu.xmf

* New Window: Set Type to Fixed and leave Value
empty

The Back to Portal button has been configured to open the
MainMenu.xmf form, where the user can select a printer and
access the page setup, the printer settings, and printer
management.
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Example 2
Generic.xmf This form allows you to see some of the more advanced
features of Form Designer. It lets you choose a label from a
list, view its data variables, preview your label, choose how
many label copies you would like to print as well as
configure and select the printer to be used.
* Placing the For this example, you will need to drag and drop the
controls following controls:
* 3 Labels
* 1 Link label
* 1 Picture box
* 3 Buttons
e 1 TextBox
» 1 ListBox

¢ 1 ComboBox
¢ 1 GroupBox
* 1 Preview

1 Datagrid

Place the items as shown in the following diagram:

Picture Group Box
Box LinkLabel

Label
List Box

Button

Label Combo Box Button
Data Grid

Label Text Box Button

 Settingthe control  When you select a control in your form, the associated list of
properties (no data) properties will be displayed in the Properties Grid.

1 Set the label properties as follows:

¢ Name: IblSelect
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* Contents > Type: Fixed Contents

» Contents > Value: Select your label:
* Font Name: MS Sans Serif

¢ Font Size: 8,25

* Font Bold: True

¢ Name: IblPrinter

* Contents > Type: Fixed Variables
¢ Contents > Value: Printer:

¢ Font Name: MS Sans Serif

e Font Size: 8,25

¢ Font Bold: True

* Name: IblQty

* Contents > Type: Fixed Contents
» Contents > Value: Label Quantity:
* Font Name: MS Sans Serif

e Font Size: 8,25

* Font Bold: True

2 Set the Picture Box properties as follows:

* Name: picRandD

* Image File Name: Teklynx.jpg ( clicking on the down-
arrow will open a dialog box: Select Fixed and locate the
image in the Icons folder of you software’s directory)

¢ Alignment: TopCenter

* Stretch Mode: OriginSize

3 Set the LinkLabel properties as follows:

* Name: lIblyourwebsite

¢ Contents > Type: Fixed Contents

* Contents > Value: yourwebsite.com

* Font Name: MS Sans Serif

e Font Size: 8,25

* Font Bold: False

¢ Navigate URL: http://www.yourwebsite.com

4 Set the GroupBox properties as follows:

* Name: gbxPreview
* Contents > Type: Fixed Contents
* Contents > Value: Preview
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» Setting the control
properties (with
data)

5 Set the Button properties as follows:
* Name: btnSetting
 Contents > Type: Fixed Contents
* Contents > Value: Settings
* Image File Name: pagesetup.bmp
* Name: btnPrint
* Contents > Type: Fixed Contents
* Contents > Value: Print
* Name: btnPortal
* Contents > Type: Fixed Contents
* Contents > Value: Back to Portal
6 Set the Preview properties as follows:
* Name: prvLabel
7 Set the ListBox properties as follows:
* Name: IbxLabels
8 Set the TextBox properties as follows:
* Name: tbxQty
9 Set the ComboBox properties as follows:
* Name: cbxPrinters
10 Set the DatagridBox properties as follows:
* Name: dgdVariables
Setting the Buttons properties
1 Click the Settings button (btnSettings).
2 Go to Actions and click the _I button.

A dialog box opens.

3 Click Add.
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4 Under Various > Description, click on the down-arrow
and select Show the printer selection dialog box.

5 Click OK.

The Settings button has been configured to open a dialog
box where the user can select a printer to print to that may
be different from those available in the dropdown
ComboBox (to configure, see Setting the ComboBox
properties )

1 Click the Print button (btnPrint).

2 Go to Actions and click the _I button.

A dialog box opens.

3 Click Add.

4 Under Various > Description, click the down-arrow and
select Print. Four parameters must be defined.

5 Under Various > Parameters, click on the _I button.

* Label Quantity: Keep default settings.

* Label Copy: Keep default settings.

* Inter Cut: Keep default settings.

* Page Copy: Keep default settings.
6 Click OK.
The Print button has been configured to print the selected
label. The parameters ensure that the there is only one
page copy of the print job and that the number of label
copies corresponds to the number defined by the user.
1 Click the Settings button (btnSettings).
2 Go to Actions and click the _I button.
A dialog box opens.

3 Click Add.

4 Under Various > Description, click the down-arrow and
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select Load a new form.
5 Under Various > Parameters, click the ..J button.
6 Under Various, enter as follows:
* Name: File Name

* Type: Fixed
¢ Value: MainMenu.xmf

Action Collection Editor

Members:

LoadForm Properties:

[i] LoadForm + Bl Misc
Description Load a new form
+ 3 2 Parameters L

Members: Fil= Name Propetties

] + | [E Mizc

1] Hew window Hame File Name

hd I Type Fized
Value MainMenuxmf ||
Add Remaove
Add Bemove
0K | Cancel Hep |
v

7 Repeat steps 6: Name it New Window and set its value to
True.

8 Click OK.

The Back to Portal button has been configured to open the
MainMenu.xmf file which allows the user to select a printer,
change its settings, manage printers, modify the page
setup, and navigate to other forms.

Setting the Form properties

For the purpose of this example, you will notice that there is
a listbox which displays a list of labels. Therefore, it can be
said that there is a Label Selection variable since there is no
fixed, attached label.

There are also two other variables required in this form: the
Printer Selection Variable which is selected from the drop-
down list, and the Label Quantity Variable, which the user
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defines as the number of label copies to be printed.

" Fixed % Variable
Label Selection
Printer Selection
Label Quantity

Label variables Preview:

<Empty>

ok | Cancel |

To set the Form variables:

1 Click the down-arrow in the Variables field of the form’s
property grid.

A dialog box appears.
2 Under Form Variables, click Add.
3 Enter Label Selection.

4 Repeat steps 2 and 3 for Printer Selection and Label
Quantity.

These variables will be required when configuring the
ListBox, the TextBox, and the ComboBox.

As mentioned earlier, there is no fixed attached label.
However, a label must be attached, anyway. To attach a
label:

1 Click on the down-arrow in the Attached label field of the
form’s properties grid.

A dialog box appears.

2 Select Variable since we do not want to attached a
specific label.

The display changes to show the list of Form variables that
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have just been defined.

3 Select the Label Selection variable and click OK.
Setting the ListBox properties

The ListBox is used to display a list of all of labels that can
be selected for printing. To configure, you must select the
location where the list of labels is coming from, and define
the contents as variable, since they will change along with

your selection. To do so:

1 In the Properties grid, click Contents > Type and define
the type as Variable.

2 Click Contents > Value and define the value as Label
Selection.

3 Click Data > Type and select a directory. The information
in the ListBox will come from a specific directory.

4 Click the down-arrow in Data > Value > Folder.
A dialog box appears.

5 Select Fixed and locate the Label folder in your
computer’s directory.

6 Click OK.
Setting the ComboBox properties

The ComboBox is used to select a printer from the
predefined list. To set the properties:

1 Click Contents > Type and define it as Variable.

2 Click Contents > Value and define it as Printer
Selection.

3 Click Data > Type and select Printers.
4 Click Data > Value > Printer type and select Windows.

This will display the list of Windows printers configured on
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the workstation or network.

Printer | j

Herow DocuTech 135 P52 w2010-5 LPT2:
YWwiebhwirks Rasterizer LPT1:

RoboPDF Generator POFPORTY:

Genenic PostScript Printer LPT3:

CutePDF Wiiter CPw2:

Canon iR5000-6000 PCLSe, 172 21.160.32:canan
Acrobat POFwiiter LPT1: b
Aicrobat Digtiler C:\Documents and Setingshall sers\Burex

|+

Setting the TextBox properties

This TextBox is used to tell the printer how many label
copies should print. The number entered in the TextBox by
the user defines the number of copies. If a counter is present
on the label, the counter will be incremented with each label
copy. To set the properties:

1 Click Contents > Type and set it to Variable contents.
2 Click Contents > Value and select Label Quantity.
Setting the Preview properties

Click Contents > Type and set it to Variable contents.

This is all the configuration needed to preview the label
chosen in the listbox.

Setting the Datagrid properties

The Datagrid displays the data from the selected label along
with its variable names. To set its properties:

1 Click Contents > Type and set to Fixed contents.
2 Click Data and set it to Table.
3 Click Data > Type and set to Label variables.

4 Click Data > Table > Title and set it to Please enter data.
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Once finished this procedure, go to View > Execution or
press F4 to execute your form and test that everything works
properly.
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	3 Data > Type: Printers
	4 Data > Value > Printers type: select THT
	2 Go to Actions and click the button. A dialog box appears.
	3 Click Add.
	4 In Description, click the down-arrow and choose Select printer. One parameter must be defined.
	5 Click on Parameters. A new dialog box appears.
	6 Set the Type field to Variable.
	7 Set the Value field to Printer. (which you can select from a drop down list... Printer is the form variable created in the Form properties). Click OK.
	8 Back in the original Actions window, click Add.
	9 Under Various > Description, click the down-arrow and choose Print. Four parameters must be defined.
	10 Click OK.
	12 Click the button. A new dialog box appears.
	13 Go to Various > Description and select Load new form from the drop-down menu. 2 parameters must be defined:


	Example 2
	Generic.xmf
	2 Set the Picture Box properties as follows:
	3 Set the LinkLabel properties as follows:
	4 Set the GroupBox properties as follows:
	5 Set the Button properties as follows:
	6 Set the Preview properties as follows:
	7 Set the ListBox properties as follows:
	8 Set the TextBox properties as follows:
	9 Set the ComboBox properties as follows:
	10 Set the DatagridBox properties as follows:
	2 Go to Actions and click the button.
	3 Click Add.
	4 Under Various > Description, click on the down-arrow and select Show the printer selection dialog box.
	5 Click OK.
	2 Go to Actions and click the button.
	3 Click Add.
	4 Under Various > Description, click the down-arrow and select Print. Four parameters must be defined.
	5 Under Various > Parameters, click on the button.
	6 Click OK.
	2 Go to Actions and click the button.
	3 Click Add.
	4 Under Various > Description, click the down-arrow and select Load a new form.
	5 Under Various > Parameters, click the button.
	6 Under Various, enter as follows:
	7 Repeat steps 6: Name it New Window and set its value to True.
	8 Click OK.
	2 Under Form Variables, click Add.
	3 Enter Label Selection.
	4 Repeat steps 2 and 3 for Printer Selection and Label Quantity.
	2 Select Variable since we do not want to attached a specific label.
	3 Select the Label Selection variable and click OK.
	2 Click Contents > Value and define the value as Label Selection.
	3 Click Data > Type and select a directory. The information in the ListBox will come from a specific directory.
	4 Click the down-arrow in Data > Value > Folder.
	5 Select Fixed and locate the Label folder in your computer’s directory.
	6 Click OK.
	2 Click Contents > Value and define it as Printer Selection.
	3 Click Data > Type and select Printers.
	4 Click Data > Value > Printer type and select Windows.
	2 Click Contents > Value and select Label Quantity.
	2 Click Data and set it to Table.
	3 Click Data > Type and set to Label variables.
	4 Click Data > Table > Title and set it to Please enter data.




