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Connecting to Database Files

Database Connections window
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Figure 1
Database Connections window

The Database Connections window is used to connect the
software to the various database files that are to be used.
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Connect the Database Manager module to the

database

Database Manager must be open in the Database
Connections window.

You can connect the Database Manager module to an
existing database or a new one.

To create a new database to connect to the Database
Manager module:

1 Go to File > Create new database.
2 Select dBase or Access database from the submenu.

A Save as dialog box will open, allowing you to specify a
name and location for the database file, and then click Save.

The new database connection will be displayed in the
Database Connections window.

To connect an existing database to the Database Manager
module:

1 Go to File > Open.

A File selection dialog box will open allowing you to browse
to and select the database of your choice.

You can only select the following database types:

Access (*.mdb)
Excel (*.xls)
Dbase(*.dbf)

A wizard is available to help you connect the software
to the most frequently used databases. Choose the
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format option that matches your database format. If the
format required is not available, do the following:

1 Click Add.

2 Select a database type from the list.
- Or -
Select Others.

3 Click Connection Setup.

Add database connection

Advanced mode

- [Connestion Senp

- Connection string

Provider=Microgoft Jet. OLEDB. 4.0:Persist Security Info=F alze

[ Back | [ Hew Finish

4 Click the Provider tab on the dialog box.

5 Select the required provider.
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Provider |E0nnection:, Advanced || Al

Select the data you want to connect to:

Fournizzeur(s] OLE DE

OLE DB pour 'annuaire Active Directory de Microzoft Provider
MediaCatalogDE OLE DE Provider
MediaCatalogtdergedDE OLE DB Provider
MediaCatalogiw/ebDE OLE DB Provider
Microzoft Jet .0 0LE DB Provider

Microsoft OLE DB Provider For D ata Mining Services
Microgoft OLE DE Provider for Indexing Service
Microzoft OLE DB Provider for Intemet Publishing
Microzoft OLE DB Provider for ODBC Drivers
Microzoft OLE DB Provider for OLA&P Services 8.0
Microsoft OLE DB Provider for Oracle

Microzoft OLE DB Provider for Search

Microzoft OLE DB Pravider for SOL Server

Microzoft OLE DB Simple Provider

M5DataShape

SOL Mative Client

Ok H Cancel H Help ]

6 Click Next.

The choice of provider changes according to the
system’s type of database.

7 Click the Browse button.
8 Select afile.

9 Click Open.
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Data Link Properties

Provider Eonnection!i Advanced || All |

Specify the following to connect to Access data:

1. Select or enter a database name:

2. Enter information to log on the dathase:

LUser name: : |Admin |

Pazsward; | |

Blank password D Allowy saving password

Test Connection

[ 0K ][ Cancel ][ Help ]

10 Click OK.

11 Click Next.

12 Enter a name for the connection.

Add database connection

Finish

Connection Name

| Chemical

Cannection string

Provider=Microsoft.J et OLEDE. 4.0:Persist Security Info=False

Nesb> [ Frish ][ Cacel ]

13 Click Finish.
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You can repeat this procedure as often as necessary to
obtain the required number of connections.

Modify the database connection parameters
Database Manager must be open in the Database
Connections window. The required connection must be
selected.

1 Click Edit.

2 Make the required changes.

Remove a connection

Database Manager must be open in the Database
Connections window. The required connection must be
selected.

¥ [Chemical

1 Click Remove.
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Database File Structure

Database Structure window

T+ Database Manager

Eile iew Taols

Database Structure

=13 Databaze Table
Database =it ﬂ CHEMICAL v
Connections

.»1 Narne Type | Length | Scale | Alownul | Unique
T e e Yl
] -
Database Struchse |§ g A5 E::Z::: :g * O
vacha @ u
RISKR4 archar a0 | || e
ﬂ RISKS1 Varchar 50 vl ]
| RISKS2 Yarchar B0 vl |
Edit Database [ RISKS3 Varchar 50 V|
| RISKS4 Varchar 50 [v]
| || Losm Varchar 50 v
'DDD | LoGO2 Varchar 50 [_’_’_} [ ]

D atabase Query

The Database Structure window is used to manage the
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structure of the databasefile. From this window, you can
add, modify, or delete tables and fields.

Choose a database from the list of connections

Database Manager must be open in the Database
Structure window.

1 Click the Database drop-down list.

2 Click the required data.

D atabaze

| Chemical ; W :

COFFEE
Copy of Chemical
FITTIMGS

Choose a table in a database

Database Manager must be open in the Database
Structure window.

1 Click the Table drop-down list.

2 Click the required data.

Tahble
| CHEMICAL v |

CHEMICAL

Add a table to the active database

Database Manager must be open in the Database
Structure window.

1 Click Add table.
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2 Enter the name of the new table.
3 Click OK.
Add table... 5]
Table Mame |Ehemical1 |
[] Duplicate with
[ 1] l [ Cancel ]

You can also copy the structure of the table from a table that
already exists in the selected database. To do so:

1 Select the Duplicate with option.
2 Click the drop-down list.
3 Click the required data.

4 Click OK.

Table Mame | Chemizall

Duplicate with | CHEMICAL v
CHEMICAL

Delete a table in the active database

Database Manager must be open in the Database
Structure window.

1 Click the Table drop-down list.

2 Click the required data.
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Table
| CHEMICAL v |

CHEMICAL

3 Click Delete table.

View/hide active table’s data

Database Manager must be open in the Database
Structure window.

To review the active table's data, click View data.

Define a key field

Database Manager must be open in the Database
Structure window.

1 Select the checkbox next to the required field.
==
2
I T
2 Click Apply.

Define a field’s type of content

Database Manager must be open in the Database
Structure window.

1 Click the required field in the Type column.
2 Click the drop-down list button.

3 Click the required data.
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Short
Long
Single
Double
Currency
[ atetime
Boolean
Buyte
Guid

‘-.:’arl:uinari

Decirmal
Mermo

4 Click Apply.

Define a field’s maximum size

Database Manager must be open in the Database
Structure window.

1 Click the required field in the Length column.

2 Enter the required value.
Length
50
3 Click Apply.

Allow an empty field

Database Manager must be open in the Database
Structure window.

1 Select the Allow Null check box for the required field.
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Al rll
W

2 Click Apply.
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Database Contents

Edit Database window

.. Database Manager

File View Tools 7
= Edit Database
El=
E-. =14 Database Table
Database el | ﬂ | CHEMICAL v|
Connections
7 \ 3 | | (= B0 |
o] NAME [RISKAT _ |AISKA2  |AISKA  |AISKA4  |AISKST | [ Cancel ]
smpase SHUEME | T AATRICAL. R ol ol {rull) 524/25
 1234TETR A1 R20/21/22 ] frul) 535
~ [12345PEN R21/22 R36/38 frul) frul) 535
= 1.20laMIND R1D R21/22 R34 R43 59

2 [null)
I CHPTAFOL R4S ETE

[ {rul] {rul] 553
_|CranszINE  R22 ) {rul) [l 522

_ |cvcLoButa RN {rull] {rul] ] 59

i _ |ENDOSULFA R24/25 R38 {rul] {rul] 528

= |FENsON R22 R36 ) {rul) 524
Database Query | |FLUORINE A7 R26 A3 {rll) 571/3

=

Print

< | >
Fec: 4 = B »  »i Mumber of records : 11

The Edit Database window is used to manage the contents
of the database file. From this window, you can, modify, or
delete data.

These actions depend on the type of database. Excel file



Chapter 3 - 14

Database Manager - User manual

records cannot be modified.

Select records according to their content

Use the content
of a field to find
arecord

= Database Manager

Eile Wiew Tools

Database
Connections

Database Structure

Edit Database

el

Database Ouery

==

Print

?

= Datahase
[ Chemical v =3 | cHEMICAL v|

Database Manager must be open in the Edit Database
window.

1 Click the drop-down list button.
2 Click the required data.

3 Click the data input field.

4 Enter the required value in the data input field.

Edit Database

Tahle

) C— = =
NME MSKA RISKA2  RISKA3 RSKA4 | IKST

1.1,1-TRICHL R20 {rl] {rull] {rul] 524/25
31 2347ETR R R20/21/22 {rul] 535
1.2345FEN R21/22 R36/38 {rul) [l 535
1.2DIaMND R1O R21/22 R34 R43 59
(BENZEME  Rd5 R R23/24/25  (rull] 553
|CAPTAFOL R4S R43 ) ) 553
|CvaNaZINE R22 il {rull {rull] 522
_|crcLoBuTa A1 {rul] {rul] {rul] 59
ENDOSULFA R24/25 R36 ) [l 528
_ |FEnsON  R22 R36 {rull] {rul] 524
FLUORINE A7 R28 R35 {rul] 57/3

< | >

Fec: a4« EZ:] »  »i Mumber of records : 11

Select all identical Database Manager must be open in the Edit Database

records

window and at least one record must exist.
1 Click the drop-down list button.
2 Click the required data.

3 Click the data input field.
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Select an
identical record

4 Enter the required data in the data input field.

5 Click the Select all button.

You can also specify the filter by clicking on the
|a:A. Check case button.

Database Manager must be open in the Edit Database
window and at least one record must have been found.
There must be several identical contents in the Search field.

To select a record, use the search tool: click 1 (First), 2
(Previous), 3 (Next) or 4 (Following).

|F|ec::Hq|8 | 2
1 2 3 4




Chapter 3 - 16 Database Manager - User manual

Find a record according to its row in the table

Database Manager must be open in the Edit Database
window.

1 Click the search tool’'s data input field.

2 Enter the required data.

T
hd

|Hec: -

Create a new record

Database Manager must be open in the Edit Database
window.

1 Click a field in the row marked with an asterisk.
2 Enter the required values in the corresponding fields.

3 Click Apply.

Ilm [rull) [rwall) [ruall) [rull) [ruall)

Duplicate a record

Database Manager must be open in the Edit Database
window.

1 Click or double-click a row or a series of rows to highlight
the selected records.

2 Right-click to view the context menu.

3 Select Duplicate selected record(s).

Modify a record

Database Manager must be open in the Edit Database
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window.
RiskAZ V][ | [lE0
| HAME RISKR1 RISKRZ RISKR3 RISKR4 RISKST
111-TRICHL R20 {rull {rual {ruul 524/25
a2 R1 2 [null] [ruall] 535

1.2345PEN R21/22 R36/33 [rull) [riuil] il

1.2DIaMINO- R10 R21/22 R34 R43 53
|BENZEME I:nrah'-. -:.-.Ir-.rh:.-rnr.:h"-:"u 123/24/25  [null) 553
CAPTAFOL e T Lull] [rull) 553
CYANAZIN Delete selected record(s) Lull] frul] oo
CYCLOBUTA R [rull) [rul) [rull) 59
EMDOSULFA R24/25 R36 [rull) [rull) 528
FEMSON Ra2 R36 [rull) [rll) 524
FLUORINE  R? R26 R35 [rull) 57/9

*
1 Click on the data you want to modifiy.
2 Enter the required data.

3 Click Apply.

Sort a series of records by alphanumerical order

Database Manager must be open in the Edit Database
window. There must be at least two records in the table.

1 Click on the name of the field required.

(LOTNUM || LOTNUM [ZT]|Lothum [T

1011 0339 1030
1001 1001 1026
0333 1002 1025
1009 1002 1024
1007 1004 1023
1005 1005 1011
1004 1007 1009

1024 1005
1002 1004
1002 1002
1025 1002
1026 10Mm
1030 0333
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To sort records in descending order, click the same
field again.

Delete a record

Database Manager must be open in the Edit Database
window.

1 Click the database cursor for the required field.
2 Right-click the database cursor for the required field.

3 Click Delete Record in the context menu.

) m@
—  Delete selected recordis)
= 05 golf
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Database Query window

% Database Manager.

Ele  iew Ioos 7
Database Query
o
g Databasa Table . Queny
Database - ﬂ | CHEMICAL v\'EIEID | Quent v|
Connections
Fiekds | Fiters | 5L Duery|
& e ot
Datsbase Structiee || [199  Unused fields A1) Orcered el
— = HAME 1 7 &
Dm]  Aiske 4 i
ﬂ RISKR2 +
v Roes
RISKR#
Edit Database RISKS1
E RISKS2
RISKS3
E RISKS4
LOGO1
LOGOZ
Database Quen
NAME RISKR1 RISKRZ  |RISKR3  |RISKR4 | RISKS]
[=[=] »|111-TRICHL R20 frull) [ruil] [l S24/75
(1234TETR R1 RA0/21/22  frudl ol 5%
Print 1.2345PEN R21/22 R36/38 (G [hwal) 535
1.2DIAMIND R10 R21/22 R34 R43 59
~ BEMZENE Ra5 R11 R23/24/25  [rull) 553
(CAFTAFOL R4S Rd3 fnull ) 583
CYANAZINE  R22 (null) (G [hul) s2
CYCLOBUTA R11 frull) fruil) (] 59
ENDOSULFA R24/25 R3E [l [rwall) 528
(FENSON A2 E ) ) s34
FLUDRINE R7 R2E R35 [hull) 57/9
< ] >
Fec:t4 4| 1 |» m1 Numberof records: 11

The Database Query window is used to create and apply
various filters.

Add a query
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Database Manager must be open to the Fields tab in the
Database Query window.

1 Click Add query.
2 Enter a name for the query.

3 Click OK.

Select/deselect one or more fields

Database Manager must be open to the Fields tab in the
Database Query window.

To select or deselect one or more fields, click on the button
next to 1, 2, 3, or 4 in the navigation tool.

M

|- |-
A WN =

Click Query.

Modify the order of fields selected

Database Manager must be open to the Fields tab in the
Database Query window.

1 Click the required field in the Ordered fields window.

2 Click the Up or Down arrow to reach the required data.
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’UDD Ordered fields

NAME 2§
RISERT
RISKRZ ¥
RISKR3
RISKR4
RISKS1
RISKS2
RISKS3

3 Click Query.

For a better view of the query application, you can
increase the size of the data display area by reducing
the height of the Fields, Filter, and SQL Query tabs.

Create a filter using predefined data

Database Manager must be open to the Filter tab in the
Database Query window.

1 Click the Add row button.

Fields Fiter |5QLQuery|

Select filter

Conditions table

- Logical | | Operatar |

2 Click in the Field field.
3 Click the drop-down list button.

4 Click the required data.
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Field

| MAME v

5 Click in the Operator field.
6 Click the drop-down list button.
7 Click the required value.

| Operatar |




Database Queries Chapter 4 - 23

Table 1: Description of operator functions

Operator Lookup

= Equal to

<> Different from

> Greater than

>= Greater than or equal to
< Less than

<= Less than or equal to
NOT

IN

LIKE

NOT LIKE

BETWEEN

NOT BETWEEN

8 Click in the Value field.

9 Enter the required value.

" alue
FLUORIME

10 Click Query.
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Apply a logical operator to several filters

Database Manager must be open to the Filter tab in the
Database Query window. Several filters must exist.

1 Click in the Logical field.
2 Click the drop-down list button.

3 Click the required data.

Logical |

And

4 Click Query to apply and view the changes.

Sort the list of filters

Database Manager must be open to the Filter tab in the
Database Query window. Several filters must exist.

1 Click the database cursor for the required field.

2 Click the Up or Down arrow to reach the required data.

Conditions T able
Logical

Field Walle
MHaME FLUORIME

Or RISERT M F
RISKER2

Operator
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Remove a filter

Database Manager must be open to the Filter tab in the
Database Query window. At least one filter must exist.

1 Click the database cursor for the required field.

2 Click the Remove row button.

Fields Filters ISBLE!uer_I,JI

Filter zelection

Conditions Table
Logical

Field Operator Walue
- MNAME = FLUORINE

Or RISKR1 IM F
And RISKRZ < [l

Modify a filter in SQL

Database Manager must be open to the SQL Query tab in
the Database Query window. At least one filter must exist.

1 Select the Modify the query in SQL language option to
activate the SQL Query and make manual changes.

] SEL Query

Select 5OL query

b adify the querny in SOL language
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2 Click Query.

The filter can be created directly in SQL without having

to use the Filter tab first.

Choose an existing query in a database

Database Manager must be open in the Database Query
window.

1 Click the Query drop-down list.

2 Click the required data.

The selected query can be modified later.
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Print window

7> Database Manager

Eile Todls

Yiew

=

Edit Database

m

Database Query

Prirter Nams

) Piinter

& &

Micrasoft KPS Docun v

Database Table . Ouey
Database | Chermical v =3 [CHEMICAL v 00 [quem v
Connections
[ Labs Nams a1 EEE
Dalabase Stiuchue @rie [ovoLasbl |

- | Settings

SRR

Quanty | NAME

I | I— [

'K

RISKR2

&

| RISKAT |FISKR3 | RISKRA4
y[o TAITRICHL Az0 {roal) {rul) (ol
B o 1234TETR A1 R20/21/22  (rul) {rul)
m: R21/22 R36/38 {rul) (2}
WL 12DIAMING R10 R21/22 GED R43
] BENZENE R4S A1 A23/2425  [nul]
o CAPTAFOL R4S R43 {rul) {rul)
[m CrANAZINE  R22 {rl) {rul) {ral)
0 CYCLOBUTA RT1 {ril) {ru) ()
wild ENDOSULFA F24/25 A3 () {rul)
0 FENSON  R22 A3 {rul) )
0 FLUORINE  R7 Fi26 ik {rual)

524/25
535
535
59
553
553
522
59
528
524
5719

| RIsKS2

{ral)
{roal)
[l
5%
516
S44

Rec

The Print window is used to select files for printing, to

PR e

Mumber of records : 11

Designer
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assign printers, and to define various parameters before
printing is launched.
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Display options
Database Manager must be open in the Print window.

Click Settings.

|_,=

25 Settings

Preview the document

Database Manager must be open in the Print window.

Click Preview.

Q Prewiew

Display the label design software
Database Manager must be open in the Print window.

Click Designer.

| III Designer

Select a document to be printed

Create a new Database Manager must be open in the Print window.
label template

for printing Click the Create labels wizard button.

3] x| &

6 Follow the wizard’s instructions.
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Select an
existing label
template

[ Note |

Creating a label in relation to the database allows you to
define exactly which elements are required to position
each database field.

Database Manager must be open in the Print window.

1 Click the Open an existing document button.

o=@

2 Select a label file.

3 Click OK.

| Note |

The Field radio buttons in the Label name and Printer
name groups of options allow you to choose the label
or printer required, when label or printer is defined in
one of the fields of the active database.

Select a printer

Database Manager must be open in the Print window. A
label template must be selected.

1 Click the Add or remove a printer button.
EEY
2 Select the printer required.

3 Click Validate.

The last printer used is selected by defaulit.

Configure the selected printer

Database Manager must be open in the Print window. A
label template and printer must be selected.
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1 Click the Printer settings button.

3| &f

2 Adjust the required settings.

3 Click OK.

Select records to be printed

Selecting Database Manager must be open in the Print window.
records
manually 1 Select the checkboxes next to the records required.

The height of the data display grid can be modified by
dragging the top of the window.
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Selecting Database Manager must be open in the Print window.
records

automatically 1 Click the drop-down list button.

2 Click the data required.

3 Click the data input field.
4 Enter the data required.

5 Click the Select all button.

6 Click the Verify button.

Configure the print media

Database Manager must be open in the Print window. A
document must be selected.

1 Click on the Page setup button

0| @{x[]
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Display the selected printer’s properties

Database Manager must be open in the Print window.

1 Click the Page setup button.

0 =]

Settings... |

Define the number of printed pages according to a
field

2 Click Settings.

Database Manager must be open in the Print window and
a printer must be selected. Records to be printed must also
be selected.

1 Click the Quantity column drop-down list.
2 Select the data required.
3 Click the selected data’s drop-down list button.

4 Select the required value or enter a whole numeric value.

This option allows a selection of labels to be printed
according to numeric values defined in specific fields.
Different criteria can be set:

+ SERIALQTY: Defines the number of times the label
series will be printed.

* LABELCPY: Defines the number of times the label
selected will be printed.

* PAGECPY: Defines the number of times the page of
labels will be printed.
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Launch printing

Launch printing
manually each
time

Database Manager must be open in the Print window. A
label template and printer must be selected. The records to
be printed must also be selected.

Click the Print records button.

Database Manager must be open in the Print window. A
label template and printer must be selected. The records to
be printed must also be selected.

1 Select the Display the print dialog box between each
record.

2 Click the Print records button.

Update variable with database

Merge Database
attached to
document

Allow the
database to be
edited

Database Manager must be open in the Print window. A
label template and printer must be selected. The records to
be printed must also be selected.

1 Select the Update variable with database.

2 Click the Print records button.

Database Manager must be open in the Print window. A
label template and printer must be selected. The records to
be printed must also be selected.

1 Select the Merge Database attached to document.

2 Click the Print records button.

Database Manager must be open in the Print window. A
label template and printer must be selected. The records to
be printed must also be selected.
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1 Select the Allow the database to be edited.

2 Click the Print records button.

Stop printing
Database Manager must be open in the Print window. A
label template and printer must be selected. The records to
be printed must also be selected. Printing must have already
been launched.

Click the Stop printing button.

e

Refresh database view
Database Manager must be open in the Print window. A
label template and printer must be selected. At least one

record must also be selected.

Click the Refresh database button.
=

Close a document

Database Manager must be open in the Print window. A
label template must be selected.

1 Click the Documents drop-down list.
2 Click he data required.

3 Click the Close current document button.
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