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The information in this manual is not binding and may be
modified without prior notice.

Supply of the software described in this manual is subject to
a user license. The software may not be used, copied or
reproduced on any medium whatsoever, except in
accordance with this license.

No portion of this manual may be copied, reproduced or
transmitted by any means whatsoever, for purposes other
than the personal use of the buyer, unless written permission
is obtained from Teklynx Corporation SAS.

©2025 Teklynx Corporation SAS
All rights reserved.

Teklynx and its products are trademarks or registered
trademarks of Teklynx Corporation SAS. All other brands
and product names are the trademarks of their respective
owners.
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About this manual

Typographical This manual distinguishes between different types of
Conventions information using the following conventions:
* Terms taken from the interface itself, such as
commands, appear in bold.
» Keys appear in small caps, for example: “Press the
SHIFT key.”
* Numbered lists mean there is a procedure to follow.

*» When the conjunction -or- appears next to a
paragraph, it means there is the choice of another
procedure for carrying out a given task.

« When a menu command contains submenus, the
menu name followed by the command to select appear
in bold. Thus, “Go to File > Open” means choose the
File menu, then choose the Open command.

This symbol highlights important information on

how a particular command or procedure works.

for optimizing tasks, speeding up commands, and

Following this symbol, you will find hints and tips
; so on.
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1

Introduction

Welcome!

Congratulations! You have just acquired a complete and
secure product solution to store barcode labels, trace the
history of design modifications and print events, manage
label versions, and set up approval workflows.

LABEL ARCHIVE Server and Client applications run on your
company's network in conjunction with CODESOFT, and an
optional Web module can also be used to provide limited
access to external users.

The scalability of this product allows you to also install all
components on your PC, and work in standalone mode like
a simple desktop application.
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LABEL ARCHIVE Modules

LABEL ARCHIVE
Server

LABEL
ARCHIVE Client

LABEL ARCHIVE
Web Module

How It Works

The LABEL ARCHIVE package contains several modules:
LABEL ARCHIVE Server, LABEL ARCHIVE Client, and the
LABEL ARCHIVE Web module.

LABEL ARCHIVE Server is a centralized database driven
through a Windows® service. It establishes the connection
with the different data sources, and processes all client
requests: Check In, Check Out, Print History, Document
Approval, etc. The Server also uses two subsystems to
operate: UMSS (User Management System) and MSGS
(Messaging System). UMSS and MSGS respectively
perform user configuration and messaging functions.

The LABEL ARCHIVE Client is the add-in for the Label
Designer application. When the user invokes LABEL
ARCHIVE from the Label Designer, this add-in connects to
the Server and checks user rights. If the connection is
successful then the user is allowed to perform different
document management actions such as Check In and
Check Out, and is given access to the centralized label
storage database. The actions allowed depend upon the
security settings and permissions that have been granted to
the group to which the user belongs.

The LABEL ARCHIVE Web Module is a Web application
accessible from any Web browser on the Internet or an
intranet. Upon successful user Web authentication, this
module establishes a connection with LABEL ARCHIVE
Server and gives access to limited functions including
viewing documents and history records, and approving
documents before delivery in production.

LABEL ARCHIVE Server typically runs on a server machine.
On the internal network, any client station that has a label
designer and the LABEL ARCHIVE Client add-in can
interact with the server at any time. All LABEL ARCHIVE
components can also be installed on a single PC. In that
case the system works in standalone mode, like a simple
desktop application.
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Product Description

LABEL ARCHIVE is designed to run on any computer
running a supported Windows® operating system.

Your product includes the following components:
- DVD
« complete documentation
* alicense agreement

» A Serial Number and password, which allows you
to activate the license of LABEL ARCHIVE Server
on your server machine

[Note |

If you have not purchased a license yet, you can still
use LABEL ARCHIVE for 30 days. During this trial
period you can install as many clients as you want, and
the system will accept up to three simultaneous
connections to the server. After the trial period you will
need to purchase a license. All the work that was done
during the trial period is kept in the database, and you
can continue it after activation without any disruption.
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CHAPTER 2

LABEL ARCHIVE Server
Installation

System Requirements

The basic software and hardware requirements needed
to run the LABEL ARCHIVE Server application are:

« A PC with Windows Server 2016, 2019, 2022, 2025
Windows Server Core 2016, 2019, 2022, 2025

4 GB RAM minimum (8 GBs recommended) and
2 Ghz processor

* A VGA monitor or
better.

* Min resolution
1366x768

A hard drive with at least 1.5 Gb of free disk space

Microsoft® .NET Framework 4.8, 8.0

Supported database management systems:
SQL Server 2016/2017/2019/2022
Oracle 19 or higher.

SQL Server Express is recommended for demo purpose
only. For the big data volumes and multiple users it's
recommended to use full SQL Server version.
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Installation

Before running the installation program, check the
configuration of your server machine.

LABEL ARCHIVE Server installation requires administration
rights on the server machine. Please check that all needed
permissions are granted, both at the operating system level,
and at the DBMS level, as you will be installing new
Windows services, copying program files, setting up a Web
module on Internet Information Services (IIS), and creating
new databases on your DBMS.

If you are installing the Web module, and your

!’F platform does not yet have Microsoft ® IIS
installed, it is recommended that you install
Microsoft .NET Framework 4.8, 8.0 after IIS so
that the ASP.NET service registration can be done
automatically.

To install LABEL ARCHIVE Server:
Step 1 > Place the DVD in the appropriate disk drive.

The LABEL ARCHIVE DVD window should appear. Select
LABEL ARCHIVE Server and click Install icon.

If the DVD-ROM does not start up automatically, go to Start
> My Computer and double-click on the LABEL ARCHIVE
DVD.

If the DVD does not automatically open, go to Windows
Explorer and locate the DVD drive letter and click on it
to view its contents. Double-click on the Index.hta (or just

“Index” if you have file extensions hidden) file located on
the DVD.
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The Installation Wizard window will appear.

Welcome to the InstallShield Wizard for LABEL
ARCHIVE Server 2025

The InstallShield ‘wizard will install LABEL AR CHIVE
Server 2025 on your computer. To continue, click Mext.

< Back Cancel

Figure 1 Installation Wizard window

Step 2 > Click Next.

The License Agreement window will appear.

LA

TEKLYNX Corporation SAS Software License ~
Agreement

TEKLYNX Corporation SAS (hereafter "Teklynx") or its affiliated companies
hereby grant you a non-exclusive, nontransferable license to use ths
softiware and the accompanying documentation according to the terms szt
outin this document.

To know the concessions and conditions of your license please refer to
the corresponding section which concerns your software, which appears v

(@1 accept the terms of the license agreement Prin: ‘
(D1 do not accept the terms of the license agreement

<Back Next > Cancel

Figure 2 License Agreement window

Step 3 > Read the license agreement. If you agree with the
terms of license agreement, select | accept the terms of
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the license agreement.

Step 4 > Click Next.

The Destination Location window will appear.

Setup will install LABEL ARCHIVE Server 2025 in the following folder.

To install to this folder, dick Next. To install to a different folder, dick Browse and select
another folder.

Destination Folder

C:\Program Files (x86)\Teklynx\ Browse...

<Back Cancel

Figure 3 Destination Location window

Step 5 > Choose the destination folder.

In this step, you are able to select which folder the files will
be installed in. The default install folder is C:\Program
Files\Teklynx\ and it is recommended that you do not
change it.

Step 6 > Click Next.
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The Select Features window will appear.

.

Select the features you want to install, and deselect the features you do not want to install.

Description

Provides extemal access to
LABEL ARCHIVE Server

193.32 MB of space required on the C drive
224023.83 MB of space available on the C drive

< Back : Next >

Figure 4 Select Features window

By default, the LABEL ARCHIVE Web module is not
selected. To view and approve labels through a Web
browser, select LABEL ARCHIVE Web.

Step 7 > Click Next.

Step 8 > Click Next.

The UMSS and MSGS Servers window will appear.
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Connecting Label Archive to the User Security module [UMSS) and Messaging Service module
MSGS)

@) | want to install a new UMS5-MSGS module

@) | want to connect Label Archive ta an existing UMSS-MSGS module in my company's
network.

DEVPC Browse

< Back Cancel

Figure 5 UMSS and MSMG Servers window

If you are installing TEKLYNX software for the first time,
select the | want to install a new UMSS-MSGS module
option and follow the steps in the UMSS-MSGS installation
wizard.

If you have previously installed TEKLYNX software, you may
have an existing user management module installed. To
check, go to Control Panel > Add/Remove Programs. If
UMSS-MSGS appears in the program list, select the | want
to connect LABEL ARCHIVE to an existing

UMSS-MSGS module in my company’s network option.

Step 9 > Click Next.

Step 10 > Click Next.

The Ready to Install window will appear.
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LA

Click Install to begin the installation.

If you want to review or change any of your installation settings, dlick Back. Click Cancel to
exit the wizard.

< Back Install Cancel

Figure 8 Ready to Install window

Step 11 > Finish the installation by clicking Install.

In the end of installation process Application Configuration tool
will appear to let user create new / upgrade databases, enter
credentials and specify LA Web settings.

Application Configuration - o X

Services

Specify local or domain user for application service logon.

Services [ Define Service User Account
Database action selection

Databass type selection
LABEL ARCHIVE (Database)
Web Action Selection

Web Account

Web Server

User:

Password:

Communication
Firewall Action Selection
Ready

Progress

ATTENTION

Complete
By defautt the application service is logged on as Local System account.

< Back Next > Cancel
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- [m] X

Database action selection

Select appropriate action to corfigure database.

Services

Database action selection

(® Create/Update database

Databass type selection
LABEL ARCHIVE (Database)
Web Action Selection

Web Account

Web Server

Communication

Firewall Action Selection
Ready

Progress

Complete

Create/Update database

Creates new or updates existing database with saving connection
options

Use f automatic database creation is a prefemable solLtion

< Back Next > Cancel

Database type selection
Specify type of server database

Services @ SaL Server
Database action selection
Database type selection O Oracle
LABEL ARCHIVE (Database)
Web Action Selection

Web Account

Web Server

Communication

() Azure 5QL

Firewall Action Selection
Ready
Progress

Complete

< Back Next > Cancel
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- O

x

LABEL ARCHIVE (Database)
Select database connection options

Senvices

Database action selection
Database type selection

LABEL ARCHIVE (Database)
Web Action Selection

Server name:
Database name:

Authentication:

[oca) -]

[LABELARCHIVE |

Windows Authentication ~

SIG-PC\Sigurd-PC

Web Account Pass
Web Server
Communication

Firewall Action Selection
Ready

Progress

Complete

< Back Mext > Cancel

Web Account
Specify local or domain user for web application logan.

Senices [ Define Service User Account
Database action selection
Database type selection
LABEL ARCHIVE (Database)
Web Action Selection

Web Account

Web Server

User:

Password

Communication
Firewall Action Selection
Ready

Progress

ATTENTION
Complete
By defaut the application service is logged on as LocalSystem account

< Back Next > Cancel
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Application Configuration

O x

Web Server
Corfigure web server applications

Senvices

Database action selection
Database type selection
LABEL ARCHIVE (Database)
Web Action Selection
Web Account

Web Server
Communication

Firewall Action Selection
Ready

Progress

Complete

-] Web Server
[ Stes
£ [ Defauit Web Site
L. [ZILASAPI
FILASWEB
{.[ZIMSGSAPI
M TcioP

web application settings.

Configure web application settings you would like to be created on web server.
Click "Properties™ in web application context menu or press Alt+Enter in order to edit

Drag and drop web application ta ancther web ste to changs defautt web site

<Back | [ Net> || cancel
Application Configuration - O X
Communication
Specy proper URLs for web services.

Services Typs URL

Database action selection Identty Provider ~ | hittp://MY-PC/TCIDP

Database type selection MSGS API | http://MY-PC/MSGSAPI

LABEL ARCHIVE (Database) LABEL ARCHIVE API |~ |http://MY-PC/LASAPI

Web Action Selection Alowed Host URL | hitp://localhost

Web Ascount #  |Mlowed Host URL |~ |hitp://MY-PC

Web Server

Communication

Firewall Action Selection
Ready
Progress

Complete:

The following URL types are available to configure:
- Idertity Provider - authentication and authorization service for web aplications;
- Print AP - TEKLYNX CENTRAL printing service;
- Mllowed Host URL - URL permitted to access TEKLYNX CENTRAL services
(Identity Provider, Print APl etc.). You can specify several allowed URLs by

adding/removing esra row:
Double click o press F2 on appropriate cell in orderto edit communication URLs

|<Bad(

H Next >

| | canesl |
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— ]

Ready

Verify database configuration options to be applied.

Services

Database action selection

(=) Summary A
- LABEL ARCHIVE

(- Database

Database type selection --S:DQ Cm;t: d;‘g*ﬁﬁ;é
- Database type erver
e Bt =) Connection string wil be saved
Web Action Selection = Connection
\Web Accourt i~ Server name: SIG-PC
Database name; LABELARCHIVE
RoEsm | User name: sa
Communication - Web Server
Firewsll Action Selection 5 f:;’“;” SIE‘at
- Web applications
Ready - LASAPI
Progress Application pocl; TEKLYNX LAS AFI
- -~ Physical path: C:\Frogram Files {36\ Teklynx\Label Archi
omplete | Wb site: Defaut Web Ste
£ LASWEB
- Application pool: TEKLYNX LAS Client
- Physical path: C:\Program Files (x86)\Teklyrc\Label Archi
Web site: Default Web Ste v
< >
< Back Cancel
A - 0
Complete
Databass configuration completed
Services
S - Application Status
abase action selection
P & LABELARCHIVE Database  Succeeded
& LABEL ARCHIVE Web Succeeded
LS ) &  LABEL ARCHIVE Communi... Succeeded
Web Action Selection @& LABELARCHIVEFrenal  Succeeded
Web Account & Common Senvices Succeeded
Web Server

Communication

Firewall Action Selection
Ready

Progress

Complete

Summary log file has been saved to the following location:

C:\ProgramData’\Teklynx\Logs\Install Db \Install DB-15528 txt

You have successfully installed the LABEL ARCHIVE

Server module.

You can use LABEL ARCHIVE in trial mode for 30 days.
After that period the server is blocked. Any connection
attempt results in an error message “Maximum number of
connections reached”. To continue to use the software you
must activate the license. Activation wizard is launched

after installation.
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LABEL
ARCHIVE Web
Module
Configuration

If you activate the license once the trial period is
expired, you will need to reboot the LABEL ARCHIVE
Server computer.

After installing the LABEL ARCHIVE Web module, you
should verify the Web site settings:

Step 1 > Go to Control Panel > Administrative Tools >
Internet Information Services.

Step 2 > In the navigation frame on the left, navigate to the
Application Pools.

Step 3 > Make sure LABEL ARCHIVE AppPool has been
created automatically.

Step 4 > Verify that the .NET version is set to 4.0.
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# | 0‘? Application Pools
i z
£-95 WIN-IAEGFLAQBBQ (WIN-IAEGH ) ) ) . o ) )
Dy o This page lets you view and manage the list of application pools on the server, Application pools are associated with worker proces:
(=} Application Pools Y ety 5 e
58] Skes applications, and provide isolation among different applications.
=€) Default Web Site Filter: ~ 0060 - Ghshow Al | Groupby: No Grouping v
= 3 f:psna-d'e”t Name [ status [ MET Frame... [ Managed Pipeli... | Identity |_Applications |
& ;ASP.NET v4.0 Started v4.0 Integrated ApplicationPoollden... 0
QASP.NET v4,0 Classic Started v4.0 Classic ApplicationPoollden... 0
QCIassic .NET AppPoal Started v2.0 Classic ApplicationPoollden... 0
QDeFauItAppPool Started v2.0 Integrated ApplicationPoollden... 1
@LA%L ARCHIVE AppPool Started 4.0 Integrated LocalSystem 1
Edit Application Pool 1IN 21|
Mame:
|LABEL ARCHIVE AppPool
(MET Framework version:
| NET Framework v4.0.30319 4|
Managed pipeline mode:
IIntegrated > I
IV start application pool immediately
oo |

Figure 9 Pool Properties window
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Uninstallation

To remove the different server components from your
computer:

Step 1 > Goto Control Panel > Add or Remove Programs.

Step 2 > Select LABEL ARCHIVE Server and click on
Change/Remove.

Step 3 > In the next window, select the Remove option and
click Next.

Welcome to the LABEL ARCHIVE Server 2025 Setup Maintenance program, This program lets
you modify the current installation. Click one of the options below.

(@ Modify
M. Selectnew program features to add or select currently installed features to
@)  remove.

O Repair
.:’ Reinstall all program features installed by the previous setup.

(O Remove
3]

Remove all installed features.

< Back Cancel

Figure 10 Modify, Repair, or Remove the Program window

The uninstallation program will delete the installed
components from your computer and optionally the
databases if specified. You will be asked whether you want
to also remove the UMSS-MSGS module. Please note that
the UMSS-MSGS module is also used for other TEKLYNX
products.
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LABEL ARCHIVE Repair

If the installed LABEL ARCHIVE Server components proved
to be corrupted, you can fix them using the Repair mode
(see Figure 12).

In this mode, the setup application will reprocess the
installation of the different components. The installation
settings that you entered during the last installation will be
reused.

SQL Database: In this mode, the structure of SQL
Database will be repaired (for example, if your SQL
database structure was corrupted).

Oracle Database: In this mode, the structure of Oracle
Database will be repaired (for example, if your Oracle
database structure was corrupted).

Access Database: In this mode, the Access Database will
be overwritten, but before starting the repair process, the

setup will propose to create backup-files for your databases,
and after the repair you will be able to replace the database.

LABEL ARCHIVE Modification (Add/Remove
Features)

If you want to add components which were not previously
installed, you can use the Modify mode (see Figure 12). In
this mode, the setup application will propose to select the
components to be installed.
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Select the features you want to install, and deselect the features you do not want to install.

4 LABEL ARCHIVE Server - Description
[[JLABEL ARCHIVE Web Pm\{ides label management
[[JLABEL ARCHIVE Backup services

51.61 MB of space required on the C drive
2967.94 MB of space available on the C drive

< Back Nexst > | Cancel I

Figure 11 Select Features window

Special Notes

* The administration user interfaces LABEL
ARCHIVE Server and Client are created using the
MMC (Microsoft Management Console) snap-in,
so they can be manipulated like any standard
MMC component in Windows.

» Full SQL Server is required to install the database
on a computer that is different from the one that
hosts the LABEL ARCHIVE Server processes and
services.

* For SQL Server, make sure that remote
connections are allowed (disallowed by default).

* If you have a firewall, you must unblock ports 8088
and 8989.

* LABEL ARCHIVE Server Windows service: The
Server program is run through a Windows service
named LABEL ARCHIVE Server, which is configured
by default to start automatically. The service has a
dependency link with the UMSS/MSGS Windows
service, named TkxSvr Servers service. You can
start and stop Windows services manually by using
the standard Windows administration tool.
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Before doing administration work on LABEL
ARCHIVE Server (i.e., changing parameters and

options, importing/exporting data, etc.), it is highly
recommended to first ensure that all clients are
disconnected. If you change some settings, you
may then want to stop and restart the LABEL
ARCHIVE Server Windows service for all changes
to be effective.




CHAPTER 3

LABEL ARCHIVE Client
Installation

System Requirements

The basic software and hardware requirements needed to
run the LABEL ARCHIVE Client application are:

» A PC with Windows 10 (x32/x64), Windows 11 (x64)

* 4 GB RAM minimum (8 GBs recommended) and
1.2 Ghz processor

* A VGA monitor or better

* Min resolution 1366x768

* A hard drive with at least 1.5 Gb of free disk space
¢ Microsoft .NET Framework 4.8, 8.0

» TEKLYNX CODESOFT 2025.00.00
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Installation

Before running the installation program, check the
configuration of your PC.

To install LABEL ARCHIVE Client:
Step 1 > Place the DVD in the appropriate disk drive.

The LABEL ARCHIVE CD window should appear. Select
LABEL ARCHIVE Client and click Install icon.

If the DVD does not start up automatically, go to Start
> My Computer and double-click on the LABEL ARCHIVE
DVD.

If the DVD does not automatically open, go to Windows
Explorer and locate the DVD drive letter and click on it
to view its contents. Double-click on the Index.hta (or just

“Index” if you have file extensions hidden) file located on
the DVD.

The Installation Wizard window will appear.

Welcome to the InstallShield Wizard for LABEL
ARCHIVE Client 2025

The InstallShield Wizard will install LABEL ARCHIVE Client
2025 on your computer. To continue, click Next.

Figure 1 Installation Wizard window
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Step 2 > Click Next.
The License Agreement window will appear.

LA

TEKLYNX Corporation SAS Software License »
Agreement

TEKLYNX Corporation SAS (hereafter "Teklynx”) or its affiliated companies
hereby grant you a non-exclusive, nontransferable license to use this
software and the accompanying documentation according to the terms set
outin this document.

To know the concessions and conditions of your license please refer to
the corresponding section which concerns your software, which appears v

(®1 accept the terms of the license agreement Print ‘
(D1 do not accept the terms of the license agreement

<Back || Next> Cancel |

Figure 2 License Agreement window

Step 3 > Read the license agreement. If you agree with the
license agreement, select | accept the terms of the license
agreement.

Step 4 > Click Next.

The Customer Information window will appear.

C |

Company Name:

_ <Back || Next>  Cancel

Figure 3 Customer Information window



Chapter 3 - 29

Administrator’'s Guide

Step 5 > Enter the following customer information:
* User name
» Company name
* Who will be able to use this application (only you, or
anyone who uses the computer)
Step 6 > Click Next.
The Destination Location window will appear.

Setup will install LABEL ARCHIVE Client 2022 in the following folder.

To install to this folder, dick Next. To install to a different folder, dick Browse and select
another folder.

Destination Folder
C:\Program Files (x86)\Teklynx\ Browse...

< Back Next > Cancel

Figure 4 Destination Location window

Step 7 > Choose the folder where the files will be installed.

In this step, you are able to select which folder the files will
be installed in. The default install folder is C:\Program
Files\TeklynxX\LABEL ARCHIVE Client\ and it is
recommended that you do not change it.

Step 8 > Click Next.
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The Select Features window will appear.

Select the features you want to install, and deselect the features you do not want to install.

LABEL ARCHIVE Client SSapton
-] Administration
- [/]LABEL ARCHIVE Administration
[MuMSs-MSGS Administration

49.76 MB of space required on the C drive
12160.91 MB of space available on the C drive

<Back Next> | Cancel

Figure 5 Select features window

Step 9 > Choose the client components from the list.
In this step, you are able to select components that will
be installed with LA Client. This includes Server, Client
Administration snap-ins and UMSS-MSGS snap-in.

Step 10 > Click Next.

The LABEL ARCHIVE Server Settings window
will appear.
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It's recommended to use computer name instead of localhost'

Select the address of LABEL ARCHIVE Server:

LAS: [mv-pC | | Browse

Select the address of UMSS\MSGS Server:

UMSS\MSGS:  [MY-PC | | Browse

< Back Next> Cancel

Figure 6 LABEL ARCHIVE Server Settings window

Step 11 > Browse to and select the location of the
LABEL ARCHIVE Server machine to which the client will
connect.

Step 12 > Browse to and select the location of the
UMSS\MSGS Server machine to which the user will
be authenticated.

Step 13 > Click Next.

The Start Installation window will appear.

Click Install to begin the installation.

If you want to review or change any of your installation settings, dick Back. Click Cancel to
exit the wizard.

< Back Install Cancel

Figure 7 Start Installation window

Step 14 > If you are sure that the parameters/settings
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Uninstallation

entered in previous steps are correct, click Install. You have
successfully installed the LABEL ARCHIVE Client.

If you want to review or change any of the installation
settings, click Back to return to the previous screens.

To remove the LABEL ARCHIVE Client from your
computer:

Step 1 > Goto Control Panel > Add or Remove Programs.

Step 2 > Select LABEL ARCHIVE Client and click
Change.

Step 3 > In the next window, select the Remove option and
click Next.

Welcome to the LABEL ARCHIVE Client 2025 Setup Maintenance program. This program lets

you modify the current installation. Click one of the options below.

® Modify

.:' Select new program features to add or select currently installed features to
0] remove.

(O Repair

-‘, Reinstall all program features installed by the previous setup.
™)

(O Remove

(¥ Remove all installed features.
(¢)

Figure 8 Repair or Remove the Program window

The uninstallation program will delete the installed
components of LABEL ARCHIVE Client from your
computer.
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LABEL ARCHIVE Client Repair

If the installed LABEL ARCHIVE Client is corrupt, you can
fix it using the Repair mode.

In this mode, the system will redo the installation of LABEL
ARCHIVE Client. The installation settings that you entered
during the last installation will be reused.
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LABEL ARCHIVE User and
Password Management

Managing Users and Permissions

Predefined User
Profiles

* ADMINISTRATORS

* MANAGERS

LABEL ARCHIVE uses the UMSS subsystem to manage all
users and permissions. At any time, the administrator can
create, modify, or delete users, passwords, and user
groups. For more details about permissions management,
please refer to the LABEL ARCHIVE User guide.

At install time, the system creates predefined user groups.

These groups correspond to typical profiles that a company
may need to use to manage the different user permissions

for all LABEL ARCHIVE business processes.

Five different user groups are available:

Administrators have all rights for LABEL ARCHIVE, and also
on UMSS and MSGS subsystems. Their typical role is to
have full IT responsibility of the entire system.

A default Administrator user is provided. Its initial password
is admin.

Additional users can be created and assigned to the
Administrators group.

Managers’ typical role is to be in charge of the business data
and processes of LABEL ARCHIVE. Managers can define
system settings, create approval workflows, or be required
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* DESIGNERS

* PRINT USERS

to approve documents before delivery in production.

Compared to Administrators, Managers do not have
permission to administrate the database or define
workstation settings. They cannot perform operations like
import DB, export DB, force undo check-out, DB archive, or
manage workstations.

A default Manager user is provided. Its initial password is
empty.

Additional users can be created and assigned to the
Managers group.

Designers’ typical role is to be in charge of the creation and
management of a document or a set of documents.
Designers can create documents, modify documents,
check-in new versions, submit documents for approval, and
participate in approval processes.

Compared to Managers, Designers do not have permission
to modify system settings, create or modify approval
schemes, or modify categories.

A default Designer user is provided. Its initial password is
empty.

Additional users can be created and assigned to the
Designers group.

Print Users’ typical role is to open documents and print them
in production.

Compared to Designers, Print Users do not have permission
to modify documents, and they can only access documents
that are in Final state.

Print Users can use the Runtime version of the label
designer to carry on their activities.

A default PrintUser user is provided. Its initial password is
empty.

Additional users can be created and assigned to the
PrintUser group.
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* CUSTOMERS

In some cases, documents may need to be approved by
Customers before delivery in production.

Customers, therefore, are given minimum access to the
system, including browsing their documents and all related
details, and taking part in an approval workflow.

Customers can use the LABEL ARCHIVE Web module,
through an Internet browser, and receive notifications by
e-mail.

A default Customer user is provided. Its initial password is
empty.

Additional users can be created and assigned to the
Customers group.

predefined groups, users and permissions, except

You can freely modify, customize or delete the
; for the Administrator.

To view all permissions that are granted to a given User,
select the related Group from the “User Groups” node
in UMSS, and click on the Permission tab.

Default Administrator user

LABEL ARCHIVE has predefined Administrator user with
default password admin. This password can be changed in
UMSS Administration later.
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Adding and Configuring Active Directory Users

Active Directory

Active Directory is a special-purposes database used to
store non-dynamic data such as users, groups, and
configuration data. By adding and configuring users in
Active Directory, administrators can now automate LABEL
ARCHIVE login using Windows authentication.

To add and configure an Active Directory User in LABEL
ARCHIVE:

Step 1 > Launch the LABEL ARCHIVE Server.

Step 2 > Log in using a known user account, or use the
default user name Administrator and the default password
admin.

Step 3 > In the console tree on the left, select LABEL
ARCHIVE Administration > Settings > Functions, and
confirm that the Allow different user connection option is
selected in the Options and Functions area.

[Note |
This is the default setting.

D LABEL ARCHIVE Administration

2 +0-
[
=+{IA LABEL ARCHIVE Administration
-, LABEL ARCHIVE SERVER settings
23 Seftings
e Funcions|
& History settings
(7] Watermark
-[7] Tags settings
=451 Management
&0 Database information
iy Workstation settings
Connections
B4 Tasks
-f] Reset documents
(] Checkout state:
(7] Valid from date
| Delete history records
-£]| Delete documents and data
#] Restore documents and data
D Bxport database
% Import database
© Bxpott variables data
-£7] Populate documents metadata
T Approval rdes
E-£] Documents
©s CODESOFT

Options and Functions
Archiving

Approval
[ 3-state Approval

Allow Check-In

[J Only work with LABEL ARCHIVE

Password required in approval

[J User and password required in approval

Allow different user connection

[ Don't save drafts betwsen final versions

[ Delete documents and history permanently

[J GComments are required on document Check-in
Store decument metadata

Add lab extension automatically to document name on Check-in
[ Enable document Details tab on Check-out dialog
O Enable Label Request Functionality

[ Allow to Gheck-out a Final document version as Draft

100 |3 Default Web preview quality on Check-in

Client Settings

[ Den't show warning message "Check out as Draft"

Figure 1 Setting LABEL ARCHIVE administrative options



Step 4 > In the console tree on the left, select
LABEL ARCHIVE Administration > LABEL
ARCHIVE Server Settings and confirm that the
Always prompt login option is not selected in the
Connection area.

[ Note |
This is the default setting.

-8
He +©-

][R LABEL ARCHIVE Administration Languages
-8 LABEL ARCHIVE SERVER settings | (@) Engish () French (O Geman (O Spansh () halian
-4 Settings
-3 Functions Connection
& History settings
(7] Watemark =

(7] Tags settings

£-{§0 Management

+f] Database information
-y Workstation settings

[] Aways prompt login

Server name [s16-PC ] Browse
Connections
T Tasks Fort [s083 ]
2] Reset documents
] Checkaut state For Windows workgroups without DNS server
(7] Valid from date force to resolve server host IP
~s| Delete history records
] Delete documents and data Tum onthis opton when

B - Test Connection has failed with message: StatusCode="Unavailable", Detail="DNS resolution failed for servics”
~| Restore documerts and data - Client and Server hosts are in a Windows Workgroup without DNS server.

© Export database - Serverhost has several network adapters with dfferent IP addresses
% import database
0 Export varables deta s recommended to use computer name instead of Tocalhost”

Figure 2 Enabling automatic prompts at log in

Step 5 > Close the LABEL ARCHIVE Administration.

Step 6 > From the Start menu, select All Programs >
Teklynx > UMSS-MSGS Servers Administration to
launch UMSS.

Step 7 > Log in using a known user account, or use the
default user name Administrator and the default password
admin.

Step 8 > In the console tree on the left, right-click UMSS-
MSGS Servers > UMSS > Users, and then select New >
User.

Step 9 > From the Authentication drop-down menu,
select Windows.

Step 10 > Click the _J button.

Step 11 > Click Locations.
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Step 12 > From the Locations area, select the domain
network that the user is on, and click OK.

x

Select the location you want to search.

Locations:
1 GHOS2126 (local)
SRR bic (Domain)

OK Cancel |
2

Figure 3 Selecting the domain network

Step 13 > Enter the user's last name in the Name field, and
click Find Now.

Step 14 > From the Search results list, select the
appropriate user and click OK.

_xj
From this location:
{BRC (Domain) Locations
Common Queries |
Find Now I
Name: IStan with :J Idoe.j
Search results:
Name I E-Mail Address ]
Doe. Jane
Doe. John
oK Cancel
Y

Figure 4 Searching for users



Step 15 > In the User Properties - New dialog box, select
the User tab and do the following:

« Enter the user's first name in the First name field.
« Enter the user's last name in the Last name field.

« If desired, enter the user's phone, mobile and e-mail
information in the areas provided.

Because the user's passwords are being managed by
the Windows account, the User may change password,
User must change password, and Locked options aren't
available.

i
User IGnupmembershipsl
Username  |brc\ohndos _]

Firstname |John

Last name |Doel

Authentication | Windows |

Password |

Password (again) |
User may change password [

User must change password [~

Locked [~

Figure 5 Adding user information

Step 16 > From the Group memberships tab, double-click
to select the groups that the user should belong to, and click
OK.
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& User properties - New =10] x|

User  Group memberships |

Designers
Managers
Customers

oKk |  cacel | Hep |

A

Figure 6 Defining group memberships

Step 17 > From the File menu, select Save to save the
MMC (Microsoft Management Console) file.

If prompted to update MMC, click Yes.
Step 18 > Launch CODESOFT.

Step 19 > From the File menu, select LABEL ARCHIVE >
Connect to automatically connect to LABEL ARCHIVE.

[ Note |

If you launch the LABEL ARCHIVE Administration or
the LABEL ARCHIVE Server, you will be prompted to
enter a username and password. To log in without
having to enter them, select the Use Windows
Authentication check box and click OK.

m’ LABEL ARCHIVE administraticn login X

[] Use Windows Authertication

Uzer |Ac|ministrator

Paszword | | [] Change

Cancel

Figure 7 Enabling Windows authentication
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