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Getting Started

About this Manual

This manual is designed to provide you with the basic 
information you need to install, configure, and use TEKLYNX 
CENTRAL GHS.

Typographic 
Conventions

This manual uses the following conventions to distinguish 
between different types of information:

• Terms taken from the interface itself, such as menu names, 
commands and button names appear in bold.

• Keys appear in uppercase, as in the following example:

“Press the SHIFT key.”

• Numbered lists indicate a procedure to follow.

• The sequence for selecting a command from a menu will be 
described, but a button is also available for many 
functions.

• Angle brackets <> indicate system setup information that 
must be entered by keyboard. Enter only the information, 
not the brackets.

Product Components 

Your software is packaged with the following components:

• DVD

• This documentation

e
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System and Server Requirements

Other Documentation Resources

Product CD In addition to any printed documentation that may be included 
with your product, you can find all available TEKLYNX 
CENTRAL GHS documentation in PDF format on the product 
DVD. The PDF documents can be viewed in Adobe Acrobat 
Reader and printed for easy reference.

Processor Minimum:
2 GHz or faster

Operating
System

• Windows Server 2003 x32/x64 (including R2 edition)

• Windows Server 2008 R2 x64

Memory 1 GB of free RAM

Hard Disk 
Space

Minimum 1.5 GB of free disk space

Supporting 
Software

On the server:
Microsoft Internet Information Services (IIS) 6.0 or 7.0
Microsoft SQL Server 2005 or later
.NET Framework 3.5 SP1
.NET Framework 4.0
ASP .NET 2.0

On the print client:
Microsoft Internet Explorer 7 or later

On the label designer client:
Microsoft Internet Explorer 6.0 SP1 or later
.NET Framework 3.5 SP1
Microsoft Data Access Components (MDAC) 2.8 or later
Adobe Acrobat Reader 6.0 or later

Video Card DirectX 9.0 minimum

Additional 
Requirements Administrator rights to the computer used during installation
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To access the TEKLYNX CENTRAL GHS documentation on the 
DVD, click the Installation Guide button available on the DVD’s 
opening screen.

You can also download product documentation at 
www.teklynx.com.

Other Product 
Documentation

Supplementary manuals for CODESOFT, LABEL ARCHIVE, 
LABELNET, and SENTINEL are also included on the DVD. For 
more detailed instructions on these products, refer to the 
corresponding product documentation.

User and administration manuals for these applications are also 
available online at www.teklynx.com.
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Installation

Welcome!

Thank you for purchasing TEKLYNX CENTRAL GHS. This 
installation guide contains information on how to install and 
configure TEKLYNX CENTRAL GHS, in addition to using the 
Command Center to interact with CODESOFT, LABEL 
ARCHIVE, LABELNET, and SENTINEL.

About TEKLYNX CENTRAL GHS

TEKLYNX CENTRAL GHS is designed specifically to address 
Globally Harmonized System of Classification and Labeling of 
Chemicals (GHS) and other chemical labeling requirements. 
TEKLYNX CENTRAL GHS manages enterprise labeling users, 
licenses, and installation within one interface. 

This command center coordinates TEKLYNX’s proven label 
design, printing, security, and tracing applications to simplify 
administration.

TEKLYNX CENTRAL GHS offers the following features:

GHS Compliance – GHS compliance will create consistent 
protection for people who are potentially exposed to chemicals 
and simplify regulations for companies producing chemicals. 

Label Design Security and Traceability – You can create all 
of your label templates in the label designer and secure them in 
the label database. All modifications and print requests are 
tracked in the database to provide an audit trail of print and label 
history.

Browser-Based Printing Interface – The browser-based 
printing interface uses a unique data input model that allows 
you to eliminate unnecessary user steps by limiting access to 
labels at the work order, workstation, and printer level. In 

e



Chapter 2-5 Installation Guide

addition, the configurable interface allows you to use 
terminology specific to your business environment, which 
reduces training time for new users.

Label Printing – Print requests that are sent from a host system 
or the browser-based user interface are processed and sent to 
networked printers.

Installing TEKLYNX CENTRAL GHS

1 Insert the DVD, click TEKLYNX CENTRAL GHS 

Installation, and then click the Install icon. If the DVD does 

not automatically launch, use the Windows Run command 

to type the letter of the DVD drive followed by index.hta (for 

example, D:\index.hta) and press ENTER.

The TEKLYNX CENTRAL GHS Installer opens.

Figure 2-1 TEKLYNX CENTRAL GHS Installer

2 Click Start. If a required Windows application is missing on 

your system, the installation program will prompt you to 

install the prerequisite file.



Installation Chapter 2-6

Figure 2-2 Required Windows Prerequisites

Click Install to install any required prerequisites. 

Installation of Windows prerequisites may require a system 

reboot to complete the installation. If a system reboot is 

required, a message will appear prompting you to restart 

your computer. Click Yes to restart your computer.

3 If all required Windows prerequisites are already installed, 

or after the installation of any necessary prerequisites has 

finished, the TEKLYNX CENTRAL GHS Installation 

Wizard appears.
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Figure 2-3 TEKLYNX CENTRAL GHS Installation Wizard

4 Click Next.

The License Agreement window appears.

Figure 2-4 License Agreement window
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5 Read the license agreement. If you agree with the terms of 

the license agreement, select I accept the terms of the 

license agreement and click Next. 

The Customer Information window appears.

Figure 2-5 Customer Information window

6 Enter your name and the name of your company and click 

Next.
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The Destination Folder window appears.

Figure 2-6 Destination Folder window

7 The default installation folder is C:\Program Files\Teklynx 

(recommended). If you must change the installation folder, 

click Change and browse to the desired location. Click 

Next.
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The Web Site Selection window appears.

Figure 2-7 Web Site Selection window

8 From the drop-down list, select the IIS web site. The IIS 

web site is the site from which the TEKLYNX CENTRAL 

GHS browser-based printing interface will launch on client 

workstations. Click Next. 
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The Virtual Directory window appears.

Figure 2-8 Virtual Directory window

9 Specify the virtual directory name for the TEKLYNX 

CENTRAL GHS browser-based printing interface. The 

virtual directory is part of the path that displays in the 

browser address bar when a user launches the printing 

interface. Click Next. 
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The Database Server window appears.

Figure 2-9 Database Server window

10 From the drop-down list, select the SQL database server. 

This is the server that stores your configuration data 

(including label data and the relationships between items 

and labels).

Note: SQL configurations with “named instances” require 
special installation. During TEKLYNX CENTRAL GHS instal-
lation, the wizard may display several possible database 
servers; for example, (Local)/DB instance name or (Work-
station name)/DB instance name. You must select an item 
that contains a workstation name to ensure a correct con-
nection. Click Next.
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You are ready to install TEKLYNX CENTRAL GHS.

Figure 2-10 Ready to Install window

11 Click Install to begin installing TEKLYNX CENTRAL GHS. 

The installation wizard will indicate when installation is 

complete.

12 Click Finish to exit the wizard.

13 When installation is complete, click Close to exit the 

TEKLYNX CENTRAL GHS Installer.
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Using the Command Center

Once TEKLYNX CENTRAL GHS has been installed, it can be 
used to administer all components of your enterprise labeling 
solution.

The Command Center

The TEKLYNX CENTRAL GHS Command Center provides 
access to all components of your enterprise labeling software. 

Figure 3-1 TEKLYNX CENTRAL GHS Command Center

Use the default user to log into TEKLYNX CENTRAL GHS for 
the first time. The username for this account is administrator 
and the password is admin.

Managing Software Maintenance Agreements

A TEKLYNX Software Maintenance Agreement (SMA) gives 
you access to the latest software updates and training manuals 

e
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for your registered TEKLYNX products. Entering your SMA 
number into the Command Center gives you quick access to 
your registration and expiration information. The system will 
also remind you when your SMA contract is up for renewal.

Entering 
SMA 
Information

To enter your SMA number in TEKLYNX CENTRAL GHS:

1 Click the Enter SMA Number link in the Software 

Maintenance Agreement (SMA) section. The SMA Number 

window opens.

Figure 3-2 SMA Number window

2 Type your SMA number in the Enter SMA Number field.

3 Click OK.

TEKLYNX CENTRAL GHS will query the TEKLYNX SMA 

Center to locate the expiration date of your maintenance 

agreement. If your system does not have an Internet 

connection, an error message will appear.



Using the Command Center Chapter 3-16

Managing Licenses

The Licenses section of the Command Center allows you to 
manage user licenses and roles.

Adding/
Configuring 
User Rights

To add or configure user rights:

1 Click the Manage Users link in the Licensing section. 

The UMSS-MSGS window opens.

Figure 3-3 UMSS-MSGS window

2 In the file tree on the left, go to UMSS-MSGS Servers > 

UMSS > Users, and right-click to select New > User. 
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The User Properties - New window opens.

Figure 3-4 User Properties - New window

3 On the User tab, enter the user’s first and last name in the 

appropriate fields.

Then, if: 

• Using UMSS authentication, enter a user name and 
password, and confirm the password.

• Using Active Directory, select Windows from the 
Authentication drop-down list and click the Browse 
button to locate the appropriate user.

4 On the Group Memberships tab, select the user groups that 

the user should belong to.

The following user groups can be used:

• Administrators – This user group is used by the 
installed components of TEKLYNX CENTRAL GHS and 
provides initial access to the application to set up other 
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users. You must have at least one user in this user 
group. This user can then create the TEKLYNX 
CENTRAL GHS Administrator in user group 
ACAdministrator.

• PrintUsers – This user group should not be used. 
TEKLYNX CENTRAL GHS print users should be added 
to the ACPrintUser group.

• ACAdministrator – These administrators can connect 
to the TEKLYNX CENTRAL GHS Command Center, 
design labels, approve labels, print labels, and create 
reports.

• ACDesignUsers – Designers have the ability to design 
labels and approve labels.

• ACPrintUsers – Print users have the ability to print 
from the web printing interface.

• ACReportUsers – Report users have the ability to 
generate audit and print history reports.

Figure 3-5 User Properties - Group Memberships tab
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5 Click OK to save your user and group settings.

Viewing 
Connected 
Users

To view connected users:

1 Click the View Connected Users link. 

The Users window appears.

Figure 3-6 Users window

2 Expand each user group to display the connected users.

Adding 
Licenses

To activate or add licenses:

1 Click Add Users and Printers. The License Activation 

window appears.

Figure 3-7 License Activation window
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2 Click Browse and locate the License_upgrade.exe file.

3 Follow the instructions displayed in the wizard to activate or 

add a TEKLYNX CENTRAL GHS license.

Using the Label Designer

The Label Designer and Label Manager section of the 
Command Center provides links to launch the label designer 
application, where you can design and test print labels.

The label designer is powered by CODESOFT. For more 
information on designing and test printing labels, refer to the 
CODESOFT 9 User Guide. For more information on checking 
labels in and out of the label database, refer to the LABEL 
ARCHIVE User Guide.

To launch the label designer, click the Design and Test Labels 
link in the Label Designer and Label Manager section.

Using the Label Manager

The Label Designer and Label Manager section of the 
Command Center provides links to manage labels and define 
approval rules.

The TEKLYNX CENTRAL GHS label manager is powered by 
LABEL ARCHIVE. For more information on managing labels, 
refer to the LABEL ARCHIVE Administrator Guide and LABEL 
ARCHIVE User Guide.

Managing 
Labels

1 Click the Manage Labels link in the Label Designer and 

Label Manager section. This will launch the LABEL 

ARCHIVE Server application.

2 To delete labels:

a In the LABEL ARCHIVE Server application, select 
Console Root > LABEL ARCHIVE Server 
Administration > Tasks > Delete documents and 
data from the Console Root tree in the left pane.

b On the Filter tab, choose the categories and types of 
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labels to search for.

c On the Documents tab, choose the labels to delete and 
click Delete.

Note: This action will permanently delete labels from the 

label database.

3 To archive labels:

a In the LABEL ARCHIVE Server application, select 
Console Root > LABEL ARCHIVE Server 
Administration > Tasks > Archiving from the Console 
Root tree in the left pane.

b On the Filter tab, choose the categories and types of 
labels to search for.

c On the Documents tab, choose the labels to archive.

d On the Archive Options tab, browse to the folder 
where the archived database will be stored. Enter a 
name for the backup file and click Save.

If you want to delete the label(s) from the label 

database, select Delete after archive and click 

Archive.

4 To reset the label’s check out state:

a In the LABEL ARCHIVE Server application, select 
Console Root > LABEL ARCHIVE Server 
Administration > Tasks > Reset documents > 
Checkout state from the Console Root tree in the left 
pane.

b Select the desired label and click Reset.

Managing 
Approval 
Rules

1 Click Configure Approval Rules. The LABEL ARCHIVE 

Client application will launch.

2 In the LABEL ARCHIVE Client application, select Console 

Root > LABEL ARCHIVE Client Administration > 

Approval rules from the Console Root tree in the left pane.

3 To create a new approval rule, click New.

4 Enter a name for the new rule in the Name field.

5 Select when the step should be processed in the State 
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drop-down list.

6 Select whether the step applies to a single user or a user 

group in the Handler drop-down list.

7 Select the user or user group in the Parameter drop-down 

list.

8 If the step is mandatory, select Must Approve in the Type 

drop-down list.

9 Click Apply.

Using the Print Manager

The Print Manager and Printing Interface section of the 
Command Center provides links to create maps, configure 
sentinels, and monitor sentinels.

The TEKLYNX CENTRAL GHS print manager is powered by 
SENTINEL. For more information on managing sentinels, refer 
to the SENTINEL Administrator’s Guide and SENTINEL User 
Guide.

Configuring 
Printing for 
Data 
Watches

Two sentinel watches (LABELNET and Preview) are 
automatically created for the browser-based printing interface 
during the installation. Printers must be configured for both of 
these watches.

To add or remove printers:

1 Click the Configure Data Watch link in the Print Manager 

and Printing Interface section of the Command Center.

2 Select the LABELNET sentinel and click Properties.

3 On the Process tab, select CODESOFT Printing. Click 

Settings to launch the CODESOFT Printing Plug-in 

properties, where you can add or remove printers and 

define default settings.

4 After you have configured the printer, click OK.

5 Select the Preview sentinel and click Properties.
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6 On the Default Values tab, select a printer from the Printer 

drop-down list.

7 Click OK.

Creating 
Additional 
Data 
Watches

Additional sentinel watches are required if you are sending data 
to TEKLYNX CENTRAL GHS at print time to trigger a print 
request.

To create a sentinel watch:

1 Click the Configure Data Watch link in the Print Manager 

and Printing Interface section of the Command Center.

Note: Data watches install automatically for the web 

printing module.

2 Click File > New.

3 On the General tab, enter a name and group for the data 

watch. If you are sending data within a file, select the map 

you created for the file.

4 On the Input tab, select how the data input will be sent to 

TEKLYNX CENTRAL GHS (that is, what will trigger the 

print request). If you are sending data within a file, click File 

Capture. Click Settings to define the folder where the file 

will be created to trigger the print request.

5 On the Process tab, select CODESOFT Printing. Click 

Settings to launch the CODESOFT Printing Plug-in 

properties, where you can add or remove printers and 

define default settings. On the Archiving tab of the 

CODESOFT Printing Plug-in properties, enter a username 

and password for a print user in the PrintUser group.

6 Click OK.

7 Check the Enable option in the Manager window.

Managing 
Printing 
Status

To activate a sentinel watch or monitor status:
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1 Click the View Printing Status link in the Print Manager 

and Printing Interface section of the Command Center.

2 To activate a watch, select the watch and select Activate 

from the SENTINEL menu.

3 To monitor print status, select Information from the View 

menu. The Information window opens. Select the Log tab 

to view print status.

Creating Map 
Files

A map file is required if you are sending data within a file to 
TEKLYNX CENTRAL GHS at print time to trigger a print 
request. Because the necessary sentinels and map files are 
automatically created when TEKLYNX CENTRAL GHS is 
installed, you will only need to create map files if you have a 
specific need.

To create a map file:

1 Create a sample of the data that will be sent to trigger the 

print job.

2 Click the Create Map link in the Print Manager and Printing 

Interface section of the Command Center.

3 Click File > New and follow the instructions in the wizard to 

create a new map file.

Using the Printing Interface

The Print Manager and Printing Interface section of the 
Command Center provides links to configure and test the 
printing interface.

The TEKLYNX CENTRAL GHS label manager is powered by 
LABELNET. For more information on configuring the printing 
interface, refer to the LABELNET Installation Guide.

Configuring 
the Printing 
Interface

To configure the printing interface:
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1 Click the Configure Printing Interface link in the 

Print Manager and Printing Interface section of the 

Command Center.

2 Configure the printing interface to match your business 

needs.

Testing the 
Printing 
Interface

To test the printing interface:

1 Click the Launch Printing Interface link in the Print 

Manager and Printing Interface section of the Command 

Center.

2 Enter a user name and password for a user with print 

access from the ACPrintUser group.

3 Enter information based on your business process and click 

Print.

Using the Workstation Install Module

The Workstation Install section of the Command Center allows 
you to remotely install the label designer application on client 
workstations.

Installing 
software on a 
client 
workstation

1 Click the Install Label Designer link in the Workstation 

Install section of the Command Center.
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The TEKLYNX CENTRAL GHS Remote Installation 

window appears.

Figure 3-8 TEKLYNX CENTRAL GHS Remote Installation window

2 Click Browse and locate the remote workstation. Select the 

client workstation in the list.

Note: The user who is attempting to install the application 

via TEKLYNX CENTRAL GHS must be an administrator on 

the remote workstation for the installation to be successful.

3 Click Install to begin the installation.

Installing 
client 
applications 
from the DVD

You can also install the label designer and label manager 
applications directly from the TEKLYNX CENTRAL GHS DVD.

1 On the client workstation, insert the DVD and install the 

Label Designer Client application.

2 Install the Label Manager Client application from the DVD. 

During the installation process, you will be asked to select 

the LABEL ARCHIVE Server. Enter or select the name of 

the server on which TEKLYNX CENTRAL GHS is installed.

3 Edit the CS.ini file, which is installed in C:\Documents and 

Settings\All Users\Application 

Data\Teklynx\CODESOFT 9. For Windows Vista and 2008 

users, this file is located in 
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C:\ProgramData\Teklynx\CODESOFT 9.

Add the line UMSSAVAILABLE=1 in the General section of 

the file.

4 Launch CODESOFT. The application will launch in 

evaluation mode.

5 Go to Tools > Users Management. The Users 

Management window opens.

6 Select the Use User Management System (UMSS) 

option.

7 In the server address tcp://localhost:8989, replace 

localhost with the name of the server on which TEKLYNX 

CENTRAL GHS is installed.

8 Click OK.

9 You will be prompted for a username and password. Use 

the username and password of a TEKLYNX CENTRAL 

GHS administrator.

10 Restart CODESOFT for the changes to take effect.


